Closed Bug 1150485 Opened 5 years ago Closed 5 years ago

No SIM card detected

Categories

(Firefox OS Graveyard :: RIL, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: gerard-majax, Unassigned)

References

Details

Attachments

(2 files)

Attached file sim.log
Updated my device today (from a build of yesterday), fresh new profile.

I'm experiencing multiple strange issues:
 - sometimes SIM card is not detected
 - sometimes I have black screen when starting the Settings app

After enabling RIL Debug, the SIM card is detected.

Attached is the log with SIM card detected and black screen in Settings.
I see a big set of backout after doing a new repo sync:
commit 9b168d2c013af3ae6231ad8f244d5519e304cc78
Author: Wes Kocher <wkocher@mozilla.com>
Date:   Wed Apr 1 20:52:33 2015 -0700

    Backed out 14 changesets (bug 1143714, bug 1143796, bug 1139751, bug 1139460, bug 1140558) for Win PGO xpcshell failures
    
    Backed out changeset d2567d89cda3 (bug 1139751)
    Backed out changeset a8edee74d07f (bug 1139751)
    Backed out changeset 613fd260f646 (bug 1143796)
    Backed out changeset 7a6f6bdd6edf (bug 1143796)
    Backed out changeset fdf9d0174142 (bug 1143714)
    Backed out changeset 18989d1ebd43 (bug 1140558)
    Backed out changeset a4f545b715ae (bug 1140558)
    Backed out changeset b2e92f548736 (bug 1140558)
    Backed out changeset a082c774db0a (bug 1140558)
    Backed out changeset f9f66f6aaa86 (bug 1139460)
    Backed out changeset d8b62b11c43e (bug 1139460)
    Backed out changeset 77090798e88c (bug 1139460)
    Backed out changeset ea6da072eb0c (bug 1139460)
    Backed out changeset 58c2eb92a959 (bug 1139460)
    
    --HG--
    extra : amend_source : 850bad063645f0d6c632ca1d93a716d9c444f383
(In reply to Alexandre LISSY :gerard-majax from comment #1)
> I see a big set of backout after doing a new repo sync:
> commit 9b168d2c013af3ae6231ad8f244d5519e304cc78
> Author: Wes Kocher <wkocher@mozilla.com>
> Date:   Wed Apr 1 20:52:33 2015 -0700
> 
>     Backed out 14 changesets (bug 1143714, bug 1143796, bug 1139751, bug
> 1139460, bug 1140558) for Win PGO xpcshell failures
>     
>     Backed out changeset d2567d89cda3 (bug 1139751)
>     Backed out changeset a8edee74d07f (bug 1139751)
>     Backed out changeset 613fd260f646 (bug 1143796)
>     Backed out changeset 7a6f6bdd6edf (bug 1143796)
>     Backed out changeset fdf9d0174142 (bug 1143714)
>     Backed out changeset 18989d1ebd43 (bug 1140558)
>     Backed out changeset a4f545b715ae (bug 1140558)
>     Backed out changeset b2e92f548736 (bug 1140558)
>     Backed out changeset a082c774db0a (bug 1140558)
>     Backed out changeset f9f66f6aaa86 (bug 1139460)
>     Backed out changeset d8b62b11c43e (bug 1139460)
>     Backed out changeset 77090798e88c (bug 1139460)
>     Backed out changeset ea6da072eb0c (bug 1139460)
>     Backed out changeset 58c2eb92a959 (bug 1139460)
>     
>     --HG--
>     extra : amend_source : 850bad063645f0d6c632ca1d93a716d9c444f383

I cnanot reproduce after this backout.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
I still see this happening. A first boot was okay, I got LTE and then SIM card disappeared.

Rebooting results sometimes in SIM detected, sometimes not ("No SIM card").
Status: RESOLVED → REOPENED
Flags: needinfo?(stas)
Resolution: WORKSFORME → ---
Summary: [Aries] No SIM card detected, black screen in Settings → No SIM card detected
I can confirm that my SIM is detected at boot, and them some time after (I have no data), I get "no SIM card".
Airplane mode does not help.
In Bug 1150565, problems also appear upon reboot, although it's still intermittent.  They're working on obtaining the regression window at the moment.
See Also: → 1150565
Attached file ril-crash.log
Component: General → RIL
Flags: needinfo?(htsai)
I'm seeing strange cardState changes:
> 04-03 12:28:38.878   319   900 I Gecko   : RIL Worker: [0] iccStatus: {"cardState":0,"universalPINState":0,"gsmUmtsSubscriptionAppIndex":-1,"cdmaSubscriptionAppIndex":-1,"imsSubscriptionAppIndex":-1,"apps":[]}
> 04-03 12:28:38.878   319   319 I Gecko   : -*- RadioInterface[0]: Received message from worker: {"rilMessageType":"cardstatechange","cardState":4294967295,"rilMessageClientId":0}
> 04-03 12:28:38.908  1528  1528 I Gecko   : -*- RILContentHelper: Received message 'RIL:CardStateChanged': {"clientId":0,"data":{"rilMessageType":"cardstatechange","cardState":4294967295,"rilMessageClientId":0}}
> 04-03 12:28:38.908  1423  1423 I Gecko   : -*- RILContentHelper: Received message 'RIL:CardStateChanged': {"clientId":0,"data":{"rilMessageType":"cardstatechange","cardState":4294967295,"rilMessageClientId":0}}
> 04-03 12:28:38.918   319   319 I Gecko   : -*- RILContentHelper: Received message 'RIL:CardStateChanged': {"clientId":0,"data":{"rilMessageType":"cardstatechange","cardState":4294967295,"rilMessageClientId":0}}
Wondering if it could be a regression from bug 1114935
Flags: needinfo?(btseng)
>  10253 04-03 12:28:38.868   319   900 I Gecko   : RIL Worker: [0] Handling parcel as UNSOLICITED_RESPONSE_SIM_STATUS_CHANGED                           
>  10254 04-03 12:28:38.868   319   900 I Gecko   : RIL Worker: Outgoing parcel: 0,0,0,8,1,0,0,0,166,1,0,0                                               
>  10255 04-03 12:28:38.868   319   900 I Gecko   : RIL Worker: Next parcel size unknown, going to sleep.                                                
>  10256 04-03 12:28:38.878   319   900 I Gecko   : RIL Worker: Received 40 bytes.                                                                       
>  10257 04-03 12:28:38.878   319   900 I Gecko   : RIL Worker: Already read 0                                                                           
>  10258 04-03 12:28:38.878   319   900 I Gecko   : RIL Worker: New incoming parcel of size 36                                                           
>  10259 04-03 12:28:38.878   319   900 I Gecko   : RIL Worker: Parcel (size 36): 0,0,0,0,166,1,0,0,0,0,0,0,0,0,0,0,0,0,0,0,255,255,255,255,255,255,255,255,255,255,255,255,0,0,0,0
>  10260 04-03 12:28:38.878   319   900 I Gecko   : RIL Worker: We have at least one complete parcel.                                                    
>  10261 04-03 12:28:38.878   319   900 I Gecko   : RIL Worker: [0] Handling parcel as REQUEST_GET_SIM_STATUS                                            
>  10262 04-03 12:28:38.878   319   900 I Gecko   : RIL Worker: [0] iccStatus: {"cardState":0,"universalPINState":0,"gsmUmtsSubscriptionAppIndex":-1,"cdmaSubscriptionAppIndex":-1,"imsSubscriptionAppIndex":-1,"apps":[]}
>  10263 04-03 12:28:38.878   319   900 I Gecko   : RIL Worker: Next parcel size unknown, going to sleep.                                                
>  10264 04-03 12:28:38.878   319   319 I Gecko   : -*- RadioInterface[0]: Received message from worker: {"rilMessageType":"cardstatechange","cardState":4294967295,"rilMessageClientId":0}
Blocks: spark
(In reply to Alexandre LISSY :gerard-majax from comment #9)
> Wondering if it could be a regression from bug 1114935

I see the backout of this bug on http://git.mozilla.org/?p=releases/gecko.git;a=history;f=dom/icc;hb=HEAD but I don't see the reland ?!
Woo, I don't reproduce on other devices ... And after removing/putting back my SIM in the Z3 Compact, it's detected again, but I've lost LTE. Starting to think my SIM may be at fault.
My Z3 do not expose the issue. My Z3 Compact stopped to expose the issue, and I have LTE working again now that I put some money on the SIM card.

Looks like this may have been a hardware glitch.
Flags: needinfo?(stas)
Flags: needinfo?(htsai)
Flags: needinfo?(btseng)
Is QA still needed on this bug?
Nope. Everything points to hardware-level issue: either SIM or device itself. Since comment 13, the device has been getting stable network and SIM is still detected.
Status: REOPENED → RESOLVED
Closed: 5 years ago5 years ago
Resolution: --- → INVALID
Blocks: spark-device
No longer blocks: spark
You need to log in before you can comment on or make changes to this bug.