[Window Management] Rocketbar is available underneath the Network & Connectivity settings screen.

RESOLVED DUPLICATE of bug 1150834

Status

Firefox OS
Gaia::System::Window Mgmt
RESOLVED DUPLICATE of bug 1150834
3 years ago
3 years ago

People

(Reporter: YeojinC, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.2 affected, b2g-master affected)

Details

(Whiteboard: [3.0-Daily-Testing], URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8588195 [details]
logcat_20150403_1446.txt

Description:
The rocket bar can be accessible underneath the Network & Connectvity settings screen when the user taps the rocket bar area mulitple times.

Pre-requisite: No internet is connected.

Repro Steps:
1) Update a Flame to 20150403010203.
2) Tap on the rocket bar, and type some letters.
3) Tap "No internet connection".
4) On the settings screen, double-tap the upper side of the screen where the cursor was left from the previous screen.

Actual:
The carat  and keyboard appear on the screen. When the user types on the keyboard, it is shown rocket bar after the user presses "done" on the settings screen.

Expected:
Rocket bar is NOT accessible underneath the settings screen.

Environmental Variables:
Device: Flame 3.0
Build ID: 20150403010203
Gaia: 7969b367a7da62877c3a24a26d3cb5fda89d766c
Gecko: 70a113676b21
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Repro frequency: 7/10
See attached: video clip, logcat
https://youtu.be/Yfqrg_M8l1I
(Reporter)

Comment 1

3 years ago
This issue also reproduces on Flame 2.2.

Result: The carat and keyboard for the rocket bar appears on the settings screen.

Environmental Variables:
Device: Flame 2.2 (KK, 319mb, full flash)
Build ID: 20150403002503
Gaia: 022eeb91197ba4a9adfd67bd6db5aa03cc69eb31
Gecko: 77fdc6fbcae9
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

================================================

The UI in Flame 2.1 is different. The minimized rocket bar with the status bar appears on the settings screen. This issue is not applicable on Flame 2.1.

Environmental Variables:
Device: Flame 2.1 (KK, 319mb, full flash)
Build ID: 20150403001204
Gaia: 4e7d880defb83c25b49462479c02b3e64d21f421
Gecko: e76f5e7a264d
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 34.0 (2.1)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Not nominating to block on this since this is not a regression and it doesn't really break functionality.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Summary: [Window Management] Rocket bar is available underneath the Network & Connectivity settings screen. → [Window Management] Rocketbar is available underneath the Network & Connectivity settings screen.
Is this still reproducible? It might be fixed by the patch of bug 1150834.
Flags: needinfo?(ychung)
(Reporter)

Comment 4

3 years ago
I cannot reproduce this issue any more on Flame 3.0 and 2.2. Rocket bar is NOT accessible underneath the settings screen.

Environmental Variables:
Device: Flame 3.0 (KK, 319mb, full flash)
Build ID: 20150420010204
Gaia: cb41d8421da5dc4f16ea566ea2917a9b7f828154
Gecko: 50b95032152c
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Environmental Variables:
Device: Flame 2.2 (KK, 319mb, full flash)
Build ID: 20150420002502
Gaia: c15a2b6d3a783813959c2b3bffd2a131f4270b9e
Gecko: cc02ee38b252
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Flags: needinfo?(ychung)
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1150834
You need to log in before you can comment on or make changes to this bug.