Tap the area where the rocketbar would be displayed in the status bar through the overlay , rocketbar can be invoked.

VERIFIED FIXED in 2.2 S10 (17apr)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: zikui.yang, Assigned: apastor)

Tracking

unspecified
2.2 S10 (17apr)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [systemsfe][DUPEME])

Attachments

(4 attachments)

(Reporter)

Description

4 years ago
[1.Description]:
[Flame][v2.2&3.0][Browser]Goto a web page,open menu and tap the top left blank area in browser menu page,E.me can be invoked.Input some word to search box and tap search,Search result will not shown.
Attchment:VIDEO0338_Compress.MP4 and logcat_1646(1).txt
Happen time: 16:46

[2.Testing Steps]: 
1.Launch Browse
2.Open a web page
3.Tap menu button at left top corner to enter menu page
4.Tap a blank area in browser menu page
5.Input some word to search box and tap search


[3.Expected Result]: 
4.E.me can not be invoked.

[4.Actual Result]: 
4.E.me can be invoked.
5.Search result will not shown.


[5.Reproduction build]: 
Device: Flame 2.2 (affected)
Build ID               20150402002500
Gaia Revision          1ceca464053dee4a8bf10ea5abeef724d68c2ff2
Gaia Date              2015-04-01 09:49:30
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/427b4da96714
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150402.035057
Firmware Date          Thu Apr  2 03:51:09 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0 (affected)
Build ID               20150402160202
Gaia Revision          62042ffcc8c6cca0f51ad23f5c2b979fc153b5a7
Gaia Date              2015-04-02 16:01:42
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/513265a4cbc2
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150402.192125
Firmware Date          Thu Apr  2 19:21:37 EDT 2015
Bootloader             L1TC000118D0


[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
(Reporter)

Comment 1

4 years ago
(Reporter)

Updated

4 years ago
(Reporter)

Comment 2

4 years ago
Posted file logcat_1646(1).txt
blocking-b2g: --- → 2.2?
Whiteboard: [systemsfe]
Component: Gaia::Browser → Gaia::System::Window Mgmt
NI :nhirata on this one based on the irc poke.
Flags: needinfo?(nhirata.bugzilla)
Watching the video, that's the rocketbar in the status menu that's being invoked through the overlay.
Flags: needinfo?(nhirata.bugzilla)
Summary: [Flame][Browser]Tap a blank area in browser menu page,e.me can be invoked. → [Flame][Browser]Tap a blank area in browser menu page, rocketbar can be invoked.
Pretty sure this is a duplicate of a similar "rocketbar access through overlay" bug.
Whiteboard: [systemsfe] → [systemsfe][DUPEME]
Summary: [Flame][Browser]Tap a blank area in browser menu page, rocketbar can be invoked. → [Flame][Browser]Tap the area where the rocketbar would be displayed in the status bar through the overlay , rocketbar can be invoked.
You can do this with any overlay.  I did this with the home screen overlay by long tapping on the home screen and tapping where the rocketbar would be.


This also happens on the nexus-5-l; it's not device specific.
Summary: [Flame][Browser]Tap the area where the rocketbar would be displayed in the status bar through the overlay , rocketbar can be invoked. → [Flame]Tap the area where the rocketbar would be displayed in the status bar through the overlay , rocketbar can be invoked.
* This also repros with the marketplace app.

* related to : bug 1095168 ?
** contacts import shows the same issue as bug 1095168
* not sure if this is related : bug 746062

* Correction : Interestingly, I can't do it with the share activity overlay for music.
** Video, Camera, Gallery are full screen so you don't get the status bar unless you pull it down.
** Clock always shows the status bar
** Same with the dialer, FM Radio, email, calendar, cost control, and settings.

Looks like this affects browser, marketplace and homescreen
Can we get the rocketbar / status bar a little bit more uniform?  I guess that's a separate issue.
Summary: [Flame]Tap the area where the rocketbar would be displayed in the status bar through the overlay , rocketbar can be invoked. → Tap the area where the rocketbar would be displayed in the status bar through the overlay , rocketbar can be invoked.
(Assignee)

Updated

4 years ago
Assignee: nobody → apastor
(Assignee)

Comment 9

4 years ago
Comment on attachment 8589067 [details] [review]
[gaia] albertopq:1150834-tap-dialog-rocketbar > mozilla-b2g:master

This patch should fix most of cases, but I still think that we should rely on the app title click event (instead of using the gesture topPanel in the utility tray). Not sure how to do that without affecting the utility tray though. What do you think Alive? Should we create a different bug for stop using the topPanel for detecting when the rockerbar is clicked? Thanks!
Attachment #8589067 - Flags: feedback?(alive)
(Assignee)

Comment 10

4 years ago
Comment on attachment 8589067 [details] [review]
[gaia] albertopq:1150834-tap-dialog-rocketbar > mozilla-b2g:master

I would like to know Kevin's opinion here as well. Thanks!
Attachment #8589067 - Flags: feedback?(kgrandon)
Confusing UX
blocking-b2g: 2.2? → 2.2+
Comment on attachment 8589067 [details] [review]
[gaia] albertopq:1150834-tap-dialog-rocketbar > mozilla-b2g:master

This looks ok to me, but I would like to see what Alive says. I think hierarchy manager might be able to solve this in a nice way? I think there are other cases where this might happen, and it might grow to be quite a mess. We need a priority for the objects it seems.

The alternative is to continue down this path (alternative using z-index.css fixes), which I'm fine with if this is the correct thing to do.
Attachment #8589067 - Flags: feedback?(kgrandon)
Comment on attachment 8589067 [details] [review]
[gaia] albertopq:1150834-tap-dialog-rocketbar > mozilla-b2g:master

LGTM!
Attachment #8589067 - Flags: feedback?(alive) → feedback+
(Assignee)

Comment 14

4 years ago
Comment on attachment 8589067 [details] [review]
[gaia] albertopq:1150834-tap-dialog-rocketbar > mozilla-b2g:master

Added tests
Attachment #8589067 - Flags: review?(alive)
Comment on attachment 8589067 [details] [review]
[gaia] albertopq:1150834-tap-dialog-rocketbar > mozilla-b2g:master

Thanks!
Attachment #8589067 - Flags: review?(alive) → review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Updated

4 years ago
See Also: → 1153190
Please uplift to 2.2 as well. Thanks.
Flags: needinfo?(apastor)
Keywords: verifyme
According to the STR of Comment 0,this bug has been successfully verified on latest Nightly Flame v3.0.

Actual results:Tapping the blank area in browser menu page,rocketbar will not be invoked or overlain as expected.
See attachment: verified_v3.0.mp4
Reproduce rate: 0/5

Device: Flame 3.0 build(Pass)
Build ID               20150415160205
Gaia Revision          777d01f4a2c7b41c4b02e3cf87715714ccc0590b
Gaia Date              2015-04-15 17:20:09
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/53ceefb0e1c8
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150415.192055
Firmware Date          Wed Apr 15 19:21:04 EDT 2015
Bootloader             L1TC000118D0
(Assignee)

Updated

4 years ago
Depends on: 1152938
Flags: needinfo?(apastor)
(Assignee)

Updated

4 years ago
Blocks: 1152938
No longer depends on: 1152938
(Assignee)

Comment 20

4 years ago
Comment on attachment 8589067 [details] [review]
[gaia] albertopq:1150834-tap-dialog-rocketbar > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): - 
[User impact] if declined: Rocketbar is accessible (even when not visible) when clicking in the top left area of any app.
[Testing completed]: Unit tests added
[Risk to taking this patch] (and alternatives if risky): This is the lowest risk approach to fix this issue. Still might be some edge cases, but it should make the work.
[String changes made]: -
Attachment #8589067 - Flags: approval-gaia-v2.2?(bbajaj)
Attachment #8589067 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+
Verify 2.2

*v2.2
Build ID               20150419162502
Gaia Revision          c15a2b6d3a783813959c2b3bffd2a131f4270b9e
Gaia Date              2015-04-17 17:49:32
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/cc02ee38b252
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150419.201820
Firmware Date          Sun Apr 19 20:18:31 EDT 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
Keywords: verifyme
Duplicate of this bug: 1147161
Duplicate of this bug: 1143142
Duplicate of this bug: 1140254
Duplicate of this bug: 1151109
QA Whiteboard: [MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.