Closed Bug 1151177 Opened 4 years ago Closed 4 years ago

[RTL][Usage] The blue Value Selector triangles are not mirrored in Cost Control FTE

Categories

(Firefox OS Graveyard :: Gaia::Cost Control, defect, P2)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

VERIFIED FIXED
2.2 S10 (17apr)
blocking-b2g 2.2+
Tracking Status
b2g-v2.2 --- verified
b2g-master --- verified

People

(Reporter: pmathur, Assigned: kgrandon)

References

Details

(Whiteboard: systemsfe)

Attachments

(4 files)

Description:
There are two value selectors in the usage apps FTE that are not properly mirrored to the left side of the box.

Repro Steps:
1) Open Usage App
2) Go through Usage App FTE
3) Observe Value Selectors on Step 2 of the FTE

Actual:
The two blue value selector triangles are not mirrored.

Expected:
Blue value selector triangles are mirrored properly.

Environmental Variables:
b2g v2.2
Build ID               20150403162503
Gaia Revision          a6351e1197d54f8624523c2db9ba1418f2aa046f
Gaia Date              2015-04-03 22:06:41
Gecko Revision https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/2247e3c01cc1
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150403.193948
Firmware Date          Fri Apr  3 19:39:57 EDT 2015
Bootloader             L1TC000118D0 

b2g v3.0
Build ID               20150403160204
Gaia Revision          16383ec2bf3ed46f893b15b3fab2892e9fadc4e7
Gaia Date              2015-04-03 06:14:45
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/90adc073cbc6
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150403.192314
Firmware Date          Fri Apr  3 19:23:23 EDT 2015
Bootloader             L1TC000118D0

Repro frequency: 10/10
See attached: Screenshot
Flags: in-moztrap?(lulu.tian)
QA Whiteboard: [rtl-impact]
Flags: needinfo?(lebedel.delphine)
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/15455/
Flags: in-moztrap?(lulu.tian) → in-moztrap+
Whiteboard: MGSEI-RTL-3F
triage: to be more consistent.
blocking-b2g: 2.2? → 2.2+
This should block cost-control-rtl meta bug
Flags: needinfo?(lebedel.delphine)
Hi Marina,
Could you please help to check this issue? Thanks!
Flags: needinfo?(marina.rodrigueziglesias)
Hi Kevin, Hi Etienne,
Could you please help to check the problem? Thank you!
Flags: needinfo?(marina.rodrigueziglesias)
Flags: needinfo?(kgrandon)
Flags: needinfo?(etienne)
I'll investigate this.
Assignee: nobody → kgrandon
Status: NEW → ASSIGNED
Flags: needinfo?(kgrandon)
Flags: needinfo?(etienne)
Comment on attachment 8589705 [details] [review]
[gaia] KevinGrandon:bug_1151177_gaia_select_rtl_arrow > mozilla-b2g:master

Hey Mike, Ted - this RTL fix is for one of our legacy web components. Could one of you guys could help me out with a review here. Thanks!
Attachment #8589705 - Flags: review?(tclancy)
Attachment #8589705 - Flags: review?(mhenretty)
Blocks: 1136339
Comment on attachment 8589705 [details] [review]
[gaia] KevinGrandon:bug_1151177_gaia_select_rtl_arrow > mozilla-b2g:master

LGTM, thanks!
Attachment #8589705 - Flags: review?(tclancy)
Attachment #8589705 - Flags: review?(mhenretty)
Attachment #8589705 - Flags: review+
In master: https://github.com/mozilla-b2g/gaia/commit/fe35ffcbe3c8c0a25744c513a171891883ce48ba
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Comment on attachment 8589705 [details] [review]
[gaia] KevinGrandon:bug_1151177_gaia_select_rtl_arrow > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Missing RTL fix.
[User impact] if declined: Poor RTL expeience.
[Testing completed]: Manual testing (css only fix)
[Risk to taking this patch] (and alternatives if risky): Low risk, small css fix.
[String changes made]: None.
Attachment #8589705 - Flags: approval-gaia-v2.2?(bbajaj)
Duplicate of this bug: 1136339
Attachment #8589705 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+
Attached image usage_FTE.png
This issue has been verified successfully on latest build of Flame 3.0 with the same steps in comment 0.
See attachment:usage_FTE.png
Rate:0/3

Device: Flame 3.0 (pass)
Build ID               20150409160204
Gaia Revision          eaf69e651e19b98c096f8e63b9829fb31df50927
Gaia Date              2015-04-09 12:43:21
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/dd32e3ff3717
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150409.193255
Firmware Date          Thu Apr  9 19:33:06 EDT 2015
Bootloader             L1TC000118D0
QA Whiteboard: [rtl-impact] → [rtl-impact][MGSEI-Triage+]
Whiteboard: MGSEI-RTL-3F → MGSEI-RTL-3F, systemsfe
Attached image v2.2_usage_FTE.png
This issue has been verified successfully on latest build of Flame 2.2 with the same steps in comment 0.
See attachment:v2.2_usage_FTE.png
Rate:0/3

Device: Flame 2.2 (pass)
Build ID               20150412002502
Gaia Revision          cec00d643f517ffd96cde559cd3bbd43ab85816c
Gaia Date              2015-04-10 21:41:12
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/5005522fd68e
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150412.040730
Firmware Date          Sun Apr 12 04:07:41 EDT 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
QA Whiteboard: [rtl-impact][MGSEI-Triage+] → [rtl-impact][MGSEI-Triage+][MGSEI-RTL-3F]
Whiteboard: MGSEI-RTL-3F, systemsfe → systemsfe
You need to log in before you can comment on or make changes to this bug.