Last Comment Bug 115121 - need to map "xml:lang" attribute into rule data
: need to map "xml:lang" attribute into rule data
Status: RESOLVED DUPLICATE of bug 41978
: intl, testcase
Product: Core
Classification: Components
Component: XML (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Future
Assigned To: Heikki Toivonen (remove -bugzilla when emailing directly)
: Rakesh Mishra
: Andrew Overholt [:overholt]
Mentors:
Depends on: 35768
Blocks: 121193 63316
  Show dependency treegraph
 
Reported: 2001-12-13 14:06 PST by Shanjian Li
Modified: 2002-12-02 17:22 PST (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
test case to show the problem (1.20 KB, application/zip)
2001-12-13 14:09 PST, Shanjian Li
no flags Details

Description Shanjian Li 2001-12-13 14:06:19 PST
In XML specification, 
http://www.w3.org/TR/REC-xml#sec-lang-tag
xml:lang can be used to specify the language of the content. If these 
attribute presents, we should use it to choose the right font for specified
languages. Similar problem for HTML was fixed in bug 105199. In that bug,
html "lang" attribute is mapped to RuleData and populated in Rule tree. 
I think we should do same thing here.
Comment 1 Shanjian Li 2001-12-13 14:09:23 PST
Created attachment 61620 [details]
test case to show the problem

I zip a xml file and associate css file into a package of zip file. 
(browser seems unable to download css attachment.)
Comment 2 Shanjian Li 2001-12-13 14:11:25 PST
cc to a couple of people.
Comment 3 Shanjian Li 2001-12-13 14:15:07 PST
This bug is blocking us to fix font problem for xul file. 
Comment 4 David Baron :dbaron: ⌚️UTC-10 2001-12-17 14:24:12 PST
See also bug 35768.
Comment 5 Heikki Toivonen (remove -bugzilla when emailing directly) 2002-02-06 17:36:45 PST
The blocker has been futured, and bug 35768 has been moved to 1.1. Futuring
this, but hopefully I'll get to this in 1.1.
Comment 6 Charles C. Fu 2002-09-17 23:44:31 PDT
FYI, according to XHTML 1.0 <URL:http://www.w3.org/TR/xhtml1/#C_7>, if both the
lang and xml:lang attributes are present, xml:lang takes precedence.

Starting with XHTML 1.1, the lang attribute is no longer allowed and xml:lang
must be used instead.  Since Mozilla does not handle the xml:lang attribute as
suggested, XHTML 1.1 documents in languages other than the default may not
display properly.  For example, on one of my systems with LANG=en_US, Mozilla
1.1 [Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020913
Debian/1.1-1] and Netscape 6.2, this page
<URL:http://graphics.stanford.edu/~naemura/memo/xhtml-css.html> fails to display
Japanese characters.  My own XHTML 1.1 welcome page
<URL:http://www.bacchus.com/~ccwf/>, containing Chinese, Japanese, and Korean
characters, displays those characters properly with Netscape 6.2 but NOT with
Mozilla 1.1.
Comment 7 Hixie (not reading bugmail) 2002-11-08 03:53:18 PST

*** This bug has been marked as a duplicate of 41978 ***

Note You need to log in before you can comment on or make changes to this bug.