If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

need to support xml:lang attribute

RESOLVED DUPLICATE of bug 234485

Status

()

Core
XML
RESOLVED DUPLICATE of bug 234485
18 years ago
13 years ago

People

(Reporter: Erik van der Poel, Assigned: Heikki Toivonen (remove -bugzilla when emailing directly))

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
We need to support the standard xml:lang attribute, which is very similar to
HTML's LANG attribute. We will use it to select fonts, among other things.
(Reporter)

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → M17

Comment 1

17 years ago
mark it as future
Target Milestone: M17 → Future

Comment 2

17 years ago
erik resign. reassign all his bug to ftang for now.
Assignee: erik → ftang
Status: ASSIGNED → NEW

Comment 3

17 years ago
mark all future new as assigned after move from erik to ftang
Status: NEW → ASSIGNED

Comment 4

16 years ago
Isn't it a good idea to consolidate this bug with bug 115121? Although this one
was filed
before bug 115121, more active discussion has been going on in bug 115121 so that it
seems better to mark this one as a duplicate of bug 115121 than the other way
around.
The HTML "lang" attribute is mapped to RuleData. We should do the same with
xml:lang. (When both are present, xml:lang takes precedence.)
Assignee: ftang → heikki
Status: ASSIGNED → NEW
Priority: P3 → --
QA Contact: petersen → ian
Target Milestone: Future → ---
*** Bug 115121 has been marked as a duplicate of this bug. ***
Is there anything *else* that needs to be done to "support" xml:lang?  Is it
already reflected in any UI that shows the language, or do we have any UI that
uses HTML's lang attribute?

If there is something else, then that bug should be un-duped and marked as a
dependency, and if there is something else this should probably be a style
system bug.
I'd love to hope that the UI uses the same cascade mechanism, although having
seen that code I have my doubts.

Updated

15 years ago
Blocks: 121193

Comment 9

15 years ago
In bug 35768, this bug was fixed. Shouldn't we close this bug as such? 

Comment 10

15 years ago
Marking as such.

*** This bug has been marked as a duplicate of 35768 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Nope, comment 5 was never done.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

*** This bug has been marked as a duplicate of 234485 ***
Status: REOPENED → RESOLVED
Last Resolved: 15 years ago14 years ago
Resolution: --- → DUPLICATE

Updated

14 years ago
No longer blocks: 121193
You need to log in before you can comment on or make changes to this bug.