[e10s] Flash video controls on www.cnn.com hide when moving mouse over them

RESOLVED DUPLICATE of bug 1128238

Status

()

Core
Plug-ins
RESOLVED DUPLICATE of bug 1128238
3 years ago
3 years ago

People

(Reporter: Doug Gross, Unassigned)

Tracking

({regression})

38 Branch
x86
Windows 8.1
regression
Points:
---

Firefox Tracking Flags

(e10s+)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:40.0) Gecko/20100101 Firefox/40.0
Build ID: 20150404030218

Steps to reproduce:

Simply navigate to www.cnn.com and play any video.


Actual results:

When you hover over the video the controls at the bottom are raised, but when you move the pointer to the controls they lower and lose focus.


Expected results:

When compared to Firefox vs.37.0, the controls should stay raised while hovering, and they should not lower when you move the mouse over them.  This has been an ongoing issue with all the previous versions of Nightly I have seen as well.
Component: Untriaged → Video/Audio
Product: Firefox → Core

Comment 1

3 years ago
Could you provide a link to a HTML5 video on CNN with that issue, please.
I found only Flash videos.
Flags: needinfo?(doug.d.gross)
(Reporter)

Comment 2

3 years ago
I don't believe I specified the type of video.  I would agree with you that they are flash not HTML5.  Please see my note on how to replicate the issue.  Thanks for your involvement.
Flags: needinfo?(doug.d.gross)

Comment 3

3 years ago
Mozilla/5.0 (Windows NT 6.1; rv:40.0) Gecko/20100101 Firefox/40.0

The issue also occurs in Windows 7, not just Windows 8.1 as specified in the "Platform:" field.
Here's a URL to a page with a video that has this issue: 
http://edition.cnn.com/videos/living/2015/04/02/lunar-eclipse-explainer-orig.cnn/video/playlists/most-popular-domestic/

Comment 4

3 years ago
I'm only able to reproduce the issue with e10s enabled. With e10s disabled, it works fine like in FF37.

Did you test with e10s enabled?

Comment 5

3 years ago
Yes, I tested with e10s enabled and I too have the issue only with e10s enabled, without e10s it works fine.
(Reporter)

Comment 6

3 years ago
Agreed.  Tested with e10s disabled and it works fine.  It's of course slower.

Comment 7

3 years ago
Regression range:
good=2015-01-24
bad=2015-01-25
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=c0f88b376e33&tochange=c18776175a69

Maybe due to:
Jim Mathies — Bug 1092121 - Get plugin quirks modes and nsPluginInstanceOwner::GetNetscapeWindow working with remote content. r=billm
Status: UNCONFIRMED → NEW
status-firefox37: --- → unaffected
status-firefox38: --- → ?
status-firefox39: --- → ?
status-firefox40: --- → ?
Component: Video/Audio → Plug-ins
Ever confirmed: true
Keywords: regression
Summary: Using Nightly vs. 40.0a1 (2015-04-04) video controls on www.cnn.com don't work → [e10s] Flash video controls on www.cnn.com hide when moving mouse over them

Updated

3 years ago
Blocks: 516752

Updated

3 years ago
Version: 40 Branch → 38 Branch

Updated

3 years ago
Flags: needinfo?(jmathies)

Updated

3 years ago
Blocks: 1128238
No longer blocks: 516752
status-firefox37: unaffected → ---
status-firefox38: ? → ---
status-firefox39: ? → ---
status-firefox40: ? → ---
tracking-e10s: --- → +
Flags: needinfo?(jmathies)

Updated

3 years ago
No longer blocks: 1128238
Depends on: 1128238

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
No longer depends on: 1128238
Resolution: --- → DUPLICATE
Duplicate of bug: 1128238
You need to log in before you can comment on or make changes to this bug.