Closed Bug 1151447 Opened 5 years ago Closed 4 years ago

Don't use -mnop-fun-dllimport in mingw builds.

Categories

(NSS :: Build, defect)

x86
Windows
defect
Not set

Tracking

(firefox40 affected)

RESOLVED FIXED
Tracking Status
firefox40 --- affected

People

(Reporter: jacek, Assigned: jacek)

References

Details

Attachments

(1 file)

Attached patch fixSplinter Review
This option was added in bug 337887 as a woraround for GCC/binutils limitations. It's not needed in recent versions and I don't think we care about such an old setup anymore. It causes problems like one already worked around in bug 451024, where thunks are needed for cross-dll calls, which may be unloaded too early. I recently got a report about such problem from TOR Project:

https://trac.torproject.org/projects/tor/ticket/10761
Attachment #8588582 - Flags: review?(brian)
Attachment #8588582 - Attachment is patch: true
Attachment #8588582 - Flags: review?(brian) → review?(kaie)
Depends on: 337887
This change was originally made in this commit:
  https://hg.mozilla.org/projects/nss/rev/099480454292

I don't know if this change is reasonable. If you're working with MinGW and say this is required, I'll have to trust you. Given this isn't affecting our default Windows builds (which I believe use MS compilers), I'll give you r+. I wish there was a second person doing MinGW builds and who could ack your change.
Attachment #8588582 - Flags: review?(kaie) → review+
https://hg.mozilla.org/projects/nss/rev/56b691c003ad
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → 3.20
Target Milestone: 3.20 → 3.21
Duplicate of this bug: 1218004
You need to log in before you can comment on or make changes to this bug.