Closed Bug 1151465 Opened 5 years ago Closed 5 years ago

Reading View needs an error interstitial (or maybe not)

Categories

(Firefox for iOS :: Reader View, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1151464
Tracking Status
fxios + ---

People

(Reporter: st3fan, Assigned: st3fan)

References

Details

Attachments

(1 obsolete file)

When you add items to your reading list via the Share extension, we do not actually know yet if that content can be displayed by the Reader View. (Since we have not (can not) looked at the content at that point.

So when people later open that item in Firefox there is a change that we do not have readerized content available.

I can imagine two scenarios:

1) We display a message that says 'this content cannot be displayed in reading view' - with a 'Open original page' link. (Same kind of error/message as for bug 1151464)

2) We skip the warning message and just open the original page immediately.
tracking-fennec: ? → +
Status: NEW → ASSIGNED
we're going with the native spinner for this interaction.
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → WONTFIX
No spinner here. What we need is a simple page that says 'we cannot turn the requested page into reader view' or something similar.
Status: RESOLVED → REOPENED
tracking-fennec: + → ---
Resolution: WONTFIX → ---
Assignee: randersen → sarentz
Work in progress. Still needs an image / spinner. And maybe quick look at strings / terminology.
Attachment #8633595 - Flags: ui-review?(randersen)
Comment on attachment 8633595 [details] [review]
PR: https://github.com/mozilla/firefox-ios/pull/733

Removing this PR since I attached it to the wrong bug.
Attachment #8633595 - Attachment is obsolete: true
Attachment #8633595 - Flags: ui-review?(randersen)
Going to mark this as a dupe because this error message is actually part of bug 1151464
Status: REOPENED → RESOLVED
Closed: 5 years ago5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1151464
You need to log in before you can comment on or make changes to this bug.