failure to Sync RL items due to "Sending message that cannot be cloned. Are you trying to send an XPCOM object?" error

RESOLVED DUPLICATE of bug 1149896

Status

Firefox Graveyard
Reading List
RESOLVED DUPLICATE of bug 1149896
3 years ago
2 years ago

People

(Reporter: Gavin, Unassigned)

Tracking

Details

I just tried removing and then adding items from my reading list, and hit this:

Sending message that cannot be cloned. Are you trying to send an XPCOM object? ReadingList.jsm:430:0

(https://hg.mozilla.org/mozilla-central/annotate/883e17fc475f/browser/components/readinglist/ReadingList.jsm#l430)

Sending message that cannot be cloned. Are you trying to send an XPCOM object? ReadingList.jsm:349:0

(https://hg.mozilla.org/mozilla-central/annotate/883e17fc475f/browser/components/readinglist/ReadingList.jsm#l349)

I don't see any sync logging so this seems to break syncing.

Drew, any ideas here?
Flags: needinfo?(adw)
Hmm, bug 1139718 ran into something like this? What's in the |item| being sent?
Bug 1149896 is on file for this, but I'm not sure what we're going to do about it.  I don't think it should break sync though, but it might break the front-end's handling of synced items, which may end up looking like sync is broken.  You may have to set one of readinglist.log.appender.dump or readinglist.log.appender.console to "Debug" to see logs show up in the terminal or browser console, respectively.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(adw)
Resolution: --- → DUPLICATE
Duplicate of bug: 1149896
(Assignee)

Updated

2 years ago
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.