All users were logged out of Bugzilla on October 13th, 2018

Console error when switching youtube videos to fullscreen and back: NS_ERROR_FAILURE: Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsITaskbarTabPreview.invalidate] WindowsPreviewPerTab.jsm:406:0

RESOLVED DUPLICATE of bug 1127577

Status

()

RESOLVED DUPLICATE of bug 1127577
4 years ago
3 years ago

People

(Reporter: VarCat, Unassigned)

Tracking

38 Branch
x86_64
Windows 8
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
Environment:

FF 38.0b2
Build Id: 20150406174117
OS: Win 8 x64
Mozilla/5.0 (Windows NT 6.3; rv:38.0) Gecko/20100101 Firefox/38.0

Reproduced this using Firefox 38 beta 3 (build ID: 20150409144858) on Windows 8.1 32-bit.
The error is displayed on youtube videos while switching to Fullscreen and back.

NS_ERROR_FAILURE: Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsITaskbarTabPreview.invalidate] WindowsPreviewPerTab.jsm:406:0
Summary: Intermittent error in console NS_ERROR_FAILURE: Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsITaskbarTabPreview.invalidate] WindowsPreviewPerTab.jsm:406:0 → Console error when switching youtube videos to fullscreen and back: NS_ERROR_FAILURE: Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsITaskbarTabPreview.invalidate] WindowsPreviewPerTab.jsm:406:0

Comment 2

4 years ago
For me it is also triggered for every frame during a window resize...
Looks clearly an easy to reproduce bug affecting at least version 38.
I'm testing 38 since beta9, still happening on candidates.

See also bug #1162155

Comment 3

4 years ago
Is anyone looking at this?
Flags: needinfo?(ryanvm)
Flags: needinfo?(dao)
Tim, is this something your team would be able to help with?
Flags: needinfo?(ryanvm) → needinfo?(ttaubert)
Sorry, don't have a lot of time to investigate this right now. Dão should be a good person though.
Flags: needinfo?(ttaubert)
Probably a widget bug? I know nothing about nsITaskbarTabPreview.invalidate.
Component: General → Widget: Win32
Flags: needinfo?(dao) → needinfo?(jmathies)
Product: Firefox → Core

Comment 7

3 years ago
(In reply to Dão Gottwald [:dao] from comment #6)
> Probably a widget bug? I know nothing about nsITaskbarTabPreview.invalidate.

No idea what the error is, would be nice to know what that result code is. I think front end should treat this as a passive error though - 

http://mxr.mozilla.org/mozilla-central/source/widget/windows/TaskbarPreview.cpp#193

184 NS_IMETHODIMP
185 TaskbarPreview::Invalidate() {
186   if (!mVisible)
187     return NS_OK;
188 
189   // DWM Composition is required for previews
190   if (!nsUXThemeData::CheckForCompositor())
191     return NS_OK;
192 
193   HWND previewWindow = PreviewWindow();
194   return FAILED(WinUtils::dwmInvalidateIconicBitmapsPtr(previewWindow))
195        ? NS_ERROR_FAILURE
196        : NS_OK;
197 }

https://msdn.microsoft.com/en-us/library/windows/desktop/dd389409%28v=vs.85%29.aspx
Flags: needinfo?(jmathies)
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1127577
You need to log in before you can comment on or make changes to this bug.