Closed Bug 1127577 Opened 5 years ago Closed 5 years ago

NS_ERROR_FAILURE in nsITaskbarTabPreview.invalidate

Categories

(Firefox :: Shell Integration, defect)

38 Branch
All
Windows 7
defect
Not set
Points:
1

Tracking

()

RESOLVED FIXED
Firefox 39
Iteration:
39.1 - 9 Mar
Tracking Status
firefox39 --- fixed

People

(Reporter: vladan, Assigned: markh)

References

Details

(Keywords: regression)

Attachments

(1 file, 1 obsolete file)

I see this error repeated many times in the Nightly error console:

NS_ERROR_FAILURE: Component returned failure code: 0x80004005 (NS_ERROR_FAILURE)[nsITaskbarTabPreview.invalidate]1 WindowsPreviewPerTab.jsm:401:0

I suspect it's caused by bug 526620
Flags: needinfo?(tellrob)
Flags: needinfo?(jmathies)
Looks like a fairly passive failure we can catch and ignore: 

http://mxr.mozilla.org/mozilla-central/source/widget/windows/TaskbarPreview.cpp#185
Flags: needinfo?(tellrob)
Flags: needinfo?(jmathies)
Flags: firefox-backlog?
Keywords: regression
Attached patch t.patch (obsolete) — Splinter Review
I see this when the taskbar is set to autohide.

Something like this?  I initially thought that if !mVisible, we should still invalidate the preview, but it appears that mVisible isn't tracking whether the taskbar itself is *currently* visible, so it seems OK.
Attachment #8567797 - Flags: review?(jmathies)
Attachment #8567797 - Flags: review?(jmathies) → review+
There are two calls in WindowsPreviewPerTab.jsm to this, one checks preview.visible first before making the call, the other doesn't. I don't think either should need to check visible first, we should remove that check as well.
Patch with requested change to WindowsPreviewPerTab.jsm, carrying r+ forward.

Try at https://treeherder.mozilla.org/#/jobs?repo=try&revision=a1259f724f0b and I'll land when it looks green.
Assignee: nobody → mhammond
Attachment #8567797 - Attachment is obsolete: true
Attachment #8568964 - Flags: review+
https://hg.mozilla.org/mozilla-central/rev/8739e8b4c207
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 39
Hi Mark, can you provide a point value.
Iteration: --- → 39.1 - 9 Mar
Flags: qe-verify?
Flags: needinfo?(mhammond)
Flags: firefox-backlog?
Flags: firefox-backlog+
Points: --- → 1
Flags: needinfo?(mhammond)
Seems like a low impact issue, so not setting it for verification.
Flags: qe-verify? → qe-verify-
Mistakenly filed against Firefox 38 and should be instead 38 Branch. Sorry for the spam. dkl
Version: Firefox 38 → 38 Branch
I'm on Firefox 38.0.5b1 x64
NS_ERROR_FAILURE: Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIInterfaceRequestor.getInterface] network-monitor.js:82:0
NS_ERROR_FAILURE: Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsITaskbarTabPreview.invalidate] WindowsPreviewPerTab.jsm:406:0

I'm getting alot freezes and some time freeze forever and I need kill firefox process.

screen of my console
http://puu.sh/hK0IL/15d690b775.png
(In reply to Gabriel from comment #10)
> I'm getting alot freezes and some time freeze forever and I need kill
> firefox process.
> 
> screen of my console http://puu.sh/hK0IL/15d690b775.png

I notice "lastpass" in the console, so assuming you are using Nightly, lastpass is almost certainly the problem - for me it makes Nightly unusable. Try disabling it and see if your problems stop. Bug 1008768 is tracking this (even though the title of that bug isn't quite up-to-date)
Hello, I just found this bug number when I found the commit that will hopefully fix this issue.
Is this targeted for 39? It would be nice to have it fixed also for 38 or 38.0.5.

Could someone please mark https://bugzilla.mozilla.org/show_bug.cgi?id=1151863 and https://bugzilla.mozilla.org/show_bug.cgi?id=1162155 as duplicates of this?
Duplicate of this bug: 1151863
Duplicate of this bug: 1162155
(In reply to Ricardo from comment #12)
> Is this targeted for 39? It would be nice to have it fixed also for 38 or
> 38.0.5.

That's right, this fix will be in Firefox 39. Firefox 38.0.5 was already released today as far as I know
You need to log in before you can comment on or make changes to this bug.