Closed Bug 1152114 Opened 5 years ago Closed 5 years ago

[e10s] Session fails to restore with e10s enabled

Categories

(Firefox :: Session Restore, defect)

34 Branch
x86_64
Linux
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 40
Tracking Status
e10s m6+ ---
firefox40 --- fixed

People

(Reporter: billm, Assigned: billm)

Details

Attachments

(1 file, 1 obsolete file)

From bug 1147156 comment 14 (where we re-enabled e10s for people who had disabled it):

Blew away my session :(

I got errors from session restore and put at https://pastebin.mozilla.org/8829148

Only disabling e10s, replacing sessionstore.js, and starting again allowed session to be restored again.

----

It sounds like Dietrich and Yoric were both affected by this. Do either of you guys still have the session that's causing this? Would you be willing to send it to me privately? We really need to fix this ASAP.
Flags: needinfo?(dteller)
Flags: needinfo?(dietrich)
Provided over email.
Flags: needinfo?(dietrich)
I can now reproduce with Dietrich's profile. No need for your profile Yoric.
Assignee: nobody → wmccloskey
Flags: needinfo?(dteller)
This looks like another case of bug 1001836. There's a WebApp installed whose localId is 0, which is invalid. That's causing a failure here:
http://mxr.mozilla.org/mozilla-central/source/dom/ipc/TabContext.cpp#325

Fabrice, would you have time to look this over with me some time Wednesday? I have the full profile on my computer if it would help. It seems like a number of Mozilla engineers are hitting this problem, and it's making it impossible for them to use e10s.
Flags: needinfo?(fabrice)
Additionally, since a bunch of users already have these bad apps installed, we're going to need to add some code that ignores them. It seems like GetAppForId(0) should always return null.
I'm wfh Wednesday. Can you send me the faulty profile?
Flags: needinfo?(fabrice)
I'll try to reduce the profile to just the webapps stuff (and make sure it's okay with Dietrich).
Flags: needinfo?(wmccloskey)
Also, let's make this bug about fixing the immediate problem for e10s. I think that should be pretty simple. I'll file another bug to figure out how these apps with localId 0 are being created.
Attached patch invalid-localid.patch (obsolete) — Splinter Review
Untested but that ensures we never return apps when passed an invalid app id.
Attachment #8589834 - Flags: feedback?(wmccloskey)
This fixes some simple variable name issues in the original patch. It fixes the issue I see with Dietrich's profile.
Attachment #8589834 - Attachment is obsolete: true
Attachment #8589834 - Flags: feedback?(wmccloskey)
Flags: needinfo?(wmccloskey)
Attachment #8589854 - Flags: feedback+
I filed bug 1152521 for figuring out why some webapps have localId 0.
Attachment #8589854 - Flags: review+
https://hg.mozilla.org/mozilla-central/rev/cbe2a9d296b8
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 40
You need to log in before you can comment on or make changes to this bug.