Closed Bug 1152192 Opened 8 years ago Closed 8 years ago

Repeatedly adding and removing an item from Reader View causes duplicates in Reading List's sidebar

Categories

(Firefox Graveyard :: Reading List, defect)

38 Branch
defect
Not set
normal

Tracking

(firefox38 affected, firefox39 unaffected, firefox40 unaffected)

RESOLVED DUPLICATE of bug 1149869
Tracking Status
firefox38 --- affected
firefox39 --- unaffected
firefox40 --- unaffected

People

(Reporter: avaida, Unassigned)

References

Details

Attachments

(2 files)

Note: this is a follow-up issue filed for Bug 1149869.

Reproducible on:
Beta 38.0b2-build1 (20150406174117)

Affected platforms:
Windows 7 (x64), Ubuntu 14.04 (x64), Mac OS X 10.9.5

Steps to reproduce:
1. Launch Firefox.
2. Open a Reader View compatible page - (e.g.) http://www.bbc.com/news/magazine-32160231
3. Click the "Enter Reader View" button from the Location Bar.
4. Click the add/remove Reading List button  several times.

Expected result:
The page in question is successfully added and removed for as many times as the user performs these actions, without any errors.

Actual result:
There are duplicates created for that page and displayed in the Reading List sidebar.
Andrei, can you please try and get some logs for this?  See https://id.etherpad.mozilla.org/readinglist-testing for details on how to arrange for success logs to appear (this particularly problem probably isn't being treated as an "error")
Flags: needinfo?(andrei.vaida)
(In reply to Mark Hammond [:markh] from comment #1)
> Andrei, can you please try and get some logs for this?  See
> https://id.etherpad.mozilla.org/readinglist-testing for details on how to
> arrange for success logs to appear (this particularly problem probably isn't
> being treated as an "error")

The only error I'm seeing (with or without FxA) each time a dupe is added in the Reading List sidebar is:
> itemNode is undefined sidebar.js:121:0

I'm attaching a success log as well. I hope that helps.
Flags: needinfo?(andrei.vaida)
Attached file success sync log
(In reply to Andrei Vaida, QA [:avaida] from comment #0)
> Note: this is a follow-up issue filed for Bug 1149869.

Is that the correct bug? I can't see the context I was expecting that led to this followup.  IIRC, the dupes go away when you restart, right?
Flags: needinfo?(andrei.vaida)
(In reply to Mark Hammond [:markh] from comment #4)
> (In reply to Andrei Vaida, QA [:avaida] from comment #0)
> > Note: this is a follow-up issue filed for Bug 1149869.
> 
> Is that the correct bug? I can't see the context I was expecting that led to
> this followup.

Sorry about that, I thought it made more sense to mention Bug 1149869 instead. The actual context that led to this follow up is Bug 1149023.

> IIRC, the dupes go away when you restart, right?

Yes, the dupes go away after restart.
Flags: needinfo?(andrei.vaida)
Flags: needinfo?(mhammond)
Sorry for the confusion here - bug 1149869 now does affect those other branches, so I've requested uplift in that bug.
Status: NEW → RESOLVED
Closed: 8 years ago
Flags: needinfo?(mhammond)
Resolution: --- → DUPLICATE
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.