[RTL][Notifications]The contact name or phone number is left-aligned in message notification.

VERIFIED FIXED in Firefox OS v2.2

Status

Firefox OS
Gaia::System
P2
normal
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: Lancy(Leave from Mozilla), Assigned: mikehenrty)

Tracking

(Depends on: 1 bug, {regression})

unspecified
2.2 S10 (17apr)
ARM
Gonk (Firefox OS)
regression
Dependency tree / graph
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [systemsfe])

Attachments

(4 attachments)

(Reporter)

Description

3 years ago
[1.Description]:
[RTL][v2.2&v3.0][Notifications]Recieve a message from another device, the contact name or phone number is left-aligned in message notification.
See attachment:Screenshot_contact name.png.

[2.Testing Steps]: 
1.Set your phone language to Arabic and insert one or two sim card to test device.
2.Recieve a message from another device.
3.Open Notification and observe the message.

[3.Expected Result]: 
3.The contact name or phone number should be right-aligned in message notification.

[4.Actual Result]: 
3.The contact name or phone number is left-aligned in message notification.

[5.Reproduction build]: 
Flame 2.2 build(Affected):
Build ID               20150407162504
Gaia Revision          ea735c21bfb0d78333213ff0376fce1eac89ead6
Gaia Date              2015-04-07 20:58:15
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/3f86ddb7f719
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150407.195227
Firmware Date          Tue Apr  7 19:52:39 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0 build (Affected):
Build ID               20150407160201
Gaia Revision          84cbd4391fb7175d5380fa72c04d68873ce77e6d
Gaia Date              2015-04-07 17:33:14
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/078128c2600a
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150407.193600
Firmware Date          Tue Apr  7 19:36:12 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,10/10

[7.TCID]: 
15559
(Reporter)

Comment 1

3 years ago
Created attachment 8589527 [details]
Screenshot_contact name.png
(Reporter)

Updated

3 years ago
QA Whiteboard: [rtl-impact]
status-b2g-v2.2: --- → affected
status-b2g-master: --- → affected
I think there is another related issue.
blocking-b2g: --- → 2.2?
Component: Gaia::SMS → Gaia::System
Triage: P2
Depends on: 883884
Priority: -- → P2
Whiteboard: MGSEI-RTL-3F → MGSEI-RTL-3F, [systemsfe]

Updated

3 years ago
blocking-b2g: 2.2? → 2.2+
Comment hidden (obsolete)

Comment 5

3 years ago
Hi Gregor,
Can you help to find someone who can fix this? Thanks!
Flags: needinfo?(whuang) → needinfo?(anygregor)
Flags: needinfo?(anygregor)
Assignee: nobody → mhenretty
Created attachment 8590451 [details]
2015-04-09-13-17-25.png

Ok this seems to be a recent regression. I've tentatively tried on a pvt build from 2 weeks ago and the notification showed up fine in RTL (see screenshot).
gaia revision="e59ac067a1d22b7a72cbebc892ec652723f2a557"
gecko revision="6ea0017e5f5111a28745ad81075d8ad3a39c6650"

Will get QA to identify when the regression happened exactly. Will ni initial tester for this. Can we get a regression-window for this please?
Flags: needinfo?(yulan.zhu)
(FWIW I just tried now on a pvt build from last week (April 2nd): no issue then either. So the regression happened between last week and yesterday). We'll need QA to investigate this more
Keywords: regressionwindow-wanted
This was caused by my patch in bug 1147011. It turns out we still need the workaround that I removed here [1] because sms does not specify a dir in the notification API and the dir=auto we added to the notification title as a workaround for improper parenthesis display in bug 1134453 causes the text to align improperly in this case. I'm working on a solution now.

1.) https://github.com/mozilla-b2g/gaia/commit/4ed7519a9dcaf1315bd90f7236241a9bb88a5a1b#diff-34ac4f93978f5ace27b51ad2f2229c91L313
Blocks: 1147011
Flags: needinfo?(yulan.zhu)
Keywords: regressionwindow-wanted → regression
Created attachment 8590578 [details] [review]
[gaia] mikehenrty:bug-1152228-override-bidi > mozilla-b2g:master
Comment on attachment 8590578 [details] [review]
[gaia] mikehenrty:bug-1152228-override-bidi > mozilla-b2g:master

Unfortunately, I had to put the workaround back in that I removed in bug 1147011. I thought I was fixing the case where the Usage app specified dir="ltr" using the notification API, but it turns out my fix was not sufficient for all cases. Greg, I'm including a fix for the lockscreen, so I'm flagging you for review as well. Thanks!
Attachment #8590578 - Flags: review?(gweng)
Attachment #8590578 - Flags: review?(alive)
Comment on attachment 8590578 [details] [review]
[gaia] mikehenrty:bug-1152228-override-bidi > mozilla-b2g:master

r=me
Attachment #8590578 - Flags: review?(alive) → review+
Target Milestone: --- → 2.2 S10 (17apr)
Blocks: 1152230
Comment on attachment 8590578 [details] [review]
[gaia] mikehenrty:bug-1152228-override-bidi > mozilla-b2g:master

For LockScreen part from CSS it looks fine.
Attachment #8590578 - Flags: review?(gweng) → review+
Keywords: checkin-needed

Updated

3 years ago
Keywords: checkin-needed

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Comment on attachment 8590578 [details] [review]
[gaia] mikehenrty:bug-1152228-override-bidi > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
bug 1147011

[User impact] if declined:
Weird notification display in RTL modes, especially for dual sim phones.

[Testing completed]:
Manual testing.

[Risk to taking this patch] (and alternatives if risky):
Notification display in RTL modes is affected by this patch. No risk to functionality. There is no alternative approach we could think of.

[String changes made]: none.
Attachment #8590578 - Flags: approval-gaia-v2.2?

Updated

3 years ago
Attachment #8590578 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
v2.2: https://github.com/mozilla-b2g/gaia/commit/f0e261c755f0b9fb86ad1603450763e7e68b0913
status-b2g-v2.2: affected → fixed
status-b2g-master: affected → fixed
Duplicate of this bug: 1154839

Comment 17

3 years ago
Created attachment 8593220 [details]
correct_notification.png

This issue has been verified passed on latest build of Flame 2.2/3.0 with the same steps in comment 0.
See attachment:correct_notification.png
Rate:0/5

Device: Flame 2.2 (pass)
Build ID               20150415162504
Gaia Revision          89a94a8b9c9087da916751697a61ba15bc0688c3
Gaia Date              2015-04-15 20:05:38
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/20e92b626530
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150415.201243
Firmware Date          Wed Apr 15 20:12:52 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0 (pass)
Build ID               20150415160205
Gaia Revision          777d01f4a2c7b41c4b02e3cf87715714ccc0590b
Gaia Date              2015-04-15 17:20:09
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/53ceefb0e1c8
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150415.192055
Firmware Date          Wed Apr 15 19:21:04 EDT 2015
Bootloader             L1TC000118D0

Updated

3 years ago
Status: RESOLVED → VERIFIED
QA Whiteboard: [rtl-impact] → [rtl-impact][MGSEI-Triage+]
status-b2g-v2.2: fixed → verified
status-b2g-master: fixed → verified

Comment 18

3 years ago
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/15559/
Flags: in-moztrap+
QA Whiteboard: [rtl-impact][MGSEI-Triage+] → [rtl-impact][MGSEI-Triage+][MGSEI-RTL-3F]
Whiteboard: MGSEI-RTL-3F, [systemsfe] → [systemsfe]
You need to log in before you can comment on or make changes to this bug.