[RTL][Notifications]The ellipsis is displayed at left side of message content in message notification.

VERIFIED FIXED in Firefox OS v2.2

Status

P2
normal
VERIFIED FIXED
4 years ago
3 years ago

People

(Reporter: yulan.zhu, Assigned: mikehenrty)

Tracking

(Depends on: 1 bug)

unspecified
2.2 S10 (17apr)
ARM
Gonk (Firefox OS)
Dependency tree / graph
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [systemsfe])

Attachments

(4 attachments)

(Reporter)

Description

4 years ago
[1.Description]:
[RTL][v2.2&v3.0][Notifications]Recieve a message with long LTR text, the ellipsis is displayed at left side of message content in message notification.
See attachment:Screenshot_ellipsis.png

[2.Testing Steps]: 
1.Set your phone language to Arabic and insert one or two sim card to test device.
2.Recieve a message with long LTR text from another device.
3.Open notification and observe the message notification.

[3.Expected Result]: 
3.The ellipsis should be displayed at right side of message content.

[4.Actual Result]: 
3.The ellipsis is displayed at left side of message content.

[5.Reproduction build]: 
Flame 2.2 build(Affected):
Build ID               20150407162504
Gaia Revision          ea735c21bfb0d78333213ff0376fce1eac89ead6
Gaia Date              2015-04-07 20:58:15
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/3f86ddb7f719
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150407.195227
Firmware Date          Tue Apr  7 19:52:39 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0 build (Affected):
Build ID               20150407160201
Gaia Revision          84cbd4391fb7175d5380fa72c04d68873ce77e6d
Gaia Date              2015-04-07 17:33:14
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/078128c2600a
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150407.193600
Firmware Date          Tue Apr  7 19:36:12 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,10/10

[7.TCID]: 
15559
(Reporter)

Comment 1

4 years ago
Created attachment 8589528 [details]
Screenshot_ellipsis.png
(Reporter)

Updated

4 years ago
QA Whiteboard: [rtl-impact]
status-b2g-v2.2: --- → affected
status-b2g-master: --- → affected
yet another manifestation of bug 883884 that we'll need to workaround using nested containers.
blocking-b2g: --- → 2.2?
Component: Gaia::SMS → Gaia::System
Triage P2. See also Bug 1152222
Priority: -- → P2
Whiteboard: MGSEI-RTL-3F → MGSEI-RTL-3F, [systemsfe]

Updated

4 years ago
blocking-b2g: 2.2? → 2.2+

Comment 4

4 years ago
Hi Gregor,
Can you help to find someone who can fix this? Thanks!
Flags: needinfo?(anygregor)
Flags: needinfo?(anygregor)
Assignee: nobody → mhenretty
Duplicate of this bug: 1152222
Target Milestone: --- → 2.2 S10 (17apr)
Created attachment 8591165 [details] [review]
[gaia] mikehenrty:bug-1152230-ellipses-sides > mozilla-b2g:master
Added a WIP patch that is based on the fix from bug 1152228.
Depends on: 1152228
Comment on attachment 8591165 [details] [review]
[gaia] mikehenrty:bug-1152230-ellipses-sides > mozilla-b2g:master

Now that bug 1152228 has landed, this one is ready for review. Alive, Greg, could you take a look at this one too?
Attachment #8591165 - Flags: review?(gweng)
Attachment #8591165 - Flags: review?(alive)
Comment on attachment 8591165 [details] [review]
[gaia] mikehenrty:bug-1152230-ellipses-sides > mozilla-b2g:master

I like simple patch.
Attachment #8591165 - Flags: review?(alive) → review+
The LockScreen part is good, but for 'notifications.js' would you mind to add or modify the existing test? Since for System app we need to submit one unit test patch per patch, at least that's I were required to review.
Flags: needinfo?(mhenretty)
Good call Greg, I added an assert to the notification dir stuff. I also needed to fix some marionette query selectors.
Flags: needinfo?(mhenretty) → needinfo?(gweng)
Comment on attachment 8591165 [details] [review]
[gaia] mikehenrty:bug-1152230-ellipses-sides > mozilla-b2g:master

Nice, thanks a lot.
Flags: needinfo?(gweng)
Attachment #8591165 - Flags: review?(gweng) → review+
Keywords: checkin-needed

Updated

4 years ago
Keywords: checkin-needed

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Comment on attachment 8591165 [details] [review]
[gaia] mikehenrty:bug-1152230-ellipses-sides > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
Probably not a regression.

[User impact] if declined:
Ellipses are displayed on the wrong side for notifications in RTL languages which LTR content.

[Testing completed]:
Manually tested, and updated some unit tests.

[Risk to taking this patch] (and alternatives if risky):
The risk is to how we display notifications, mostly to look of utility tray.

[String changes made]: none.
Attachment #8591165 - Flags: approval-gaia-v2.2?

Updated

4 years ago
Attachment #8591165 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+

Comment 15

4 years ago
Created attachment 8594629 [details]
v3.0_verified_passed.png

This issue has been verified passed on latest build of Flame 3.0 with the same steps in comment 0.
See attachment:v3.0_verified_passed.png
Rate:0/3

Device: Flame 3.0 (pass)
Build ID               20150419160202
Gaia Revision          c6b04efa0f31a584e6ee0a46dd2b64c1e3c29adc
Gaia Date              2015-04-17 21:10:53
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/a32e3b93c8d8
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150419.193329
Firmware Date          Sun Apr 19 19:33:40 EDT 2015
Bootloader             L1TC000118D0

Updated

4 years ago
QA Whiteboard: [rtl-impact] → [rtl-impact][MGSEI-Triage+]
status-b2g-master: affected → verified

Comment 17

4 years ago
Created attachment 8595813 [details]
v2.2_verified_pass.png

This issue has been verified passed on latest build of Flame 2.2 with the same steps in comment 0.
See attachment:v2.2_verified_pass.png
Rate:0/5

Device: Flame 2.2 (pass)
Build ID               20150421162504
Gaia Revision          41a85c5f9db291d4f7c0e94c8416b5115b4ee407
Gaia Date              2015-04-21 17:23:41
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/e40544535399
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150421.200455
Firmware Date          Tue Apr 21 20:05:07 EDT 2015
Bootloader             L1TC000118D0

Updated

4 years ago
Status: RESOLVED → VERIFIED
status-b2g-v2.2: fixed → verified

Comment 18

4 years ago
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/15559/
Flags: in-moztrap+
QA Whiteboard: [rtl-impact][MGSEI-Triage+] → [rtl-impact][MGSEI-Triage+][MGSEI-RTL-3F]
Whiteboard: MGSEI-RTL-3F, [systemsfe] → [systemsfe]
You need to log in before you can comment on or make changes to this bug.