File Selected Message drop down shows IMAP folders in a random order

VERIFIED DUPLICATE of bug 112301

Status

SeaMonkey
MailNews: Message Display
VERIFIED DUPLICATE of bug 112301
17 years ago
14 years ago

People

(Reporter: Brian S. Craigie, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.6+) Gecko/20011212

Folders listed when trying to file a message to an IMAP folder by clicking the
File [File selected message] button seem to be listed in a random order making
it very hard to find folders.

Updated

17 years ago
QA Contact: esther → sheelar

Comment 1

17 years ago
Olga, isn't it bug 112301 ? Or that bug refers to local folders only ?

Comment 2

17 years ago
Reporter, would you please give more details and compare with  bug 112301.
(Reporter)

Comment 3

17 years ago
Hello,

Hmmm... There doesn't really seem to be much to add.  This doesn't seem like the
same bug as 112301 which is only a problem with some characters like _ etc.

All I can say is that the folders are on a Courier IMAP server, and they appear
to be listed in no particular order in the lists provided when clicking the File
button, or Message -> Move Message, or Message -> Copy Message.

An example of the order of listing of folders is as follows:

family
YAC
apache
netscape
consumerlink
other HP
hp
Drafts
cron


As you can see, they aren't alphanumerically sorted, even taking case
sensitivity into account.  In fact I can't see any pattern to explain why they
sort that way.
They used to be sorted alphabetically, and this problem only surfaced recently.

I would have expected the above example to be sorted thus:
apache
consumerlink
cron
Drafts
family
hp
netscape
other HP
YAC

(although maybe Drafts is a special case)

Comment 4

17 years ago
I see it now - 'no rule' sorting.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

17 years ago
QA Contact: sheelar → huang
i see something a bit different using 2001.12.20.08 comm bits on linux: the
folders aren't listed randomly. rather, the ones with subfolders are at the
top... filed bug 116333 for that.

Comment 6

17 years ago
I'm seeing this in my IMAP server on the 1/6 build on Win 2000. cc'ing naving
and nhotta in case this is related to folder sorting bug fixes.  These same
folders sort fine in the folder pane however.
Status: NEW → ASSIGNED
Keywords: nsbeta1

Comment 7

17 years ago

*** This bug has been marked as a duplicate of 112301 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 8

16 years ago
Verified as dup and this bug has been fixed on bug 112301 already.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.