bitdash MPEG-DASH MSE demo's video playback gets stuck after seeking multiple times

RESOLVED WORKSFORME

Status

()

P1
normal
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: cpeterson, Unassigned)

Tracking

(Blocks: 1 bug)

unspecified
x86
macOS
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox40 affected, firefox42 verified, firefox43 verified, firefox44 verified)

Details

(URL)

(Reporter)

Description

4 years ago
STR:
1. Play the first video ("Sintel (Multilanguage & Subtitles) - SegmentTemplate") at http://www.dash-player.com/demo/streaming-server-and-encoder-support/
2. Watch the web console for the video player making XHR requests for MSE video segments.
3. Quickly seek ahead and back ~6 times in the video progress bar.

RESULT:
The video player will abort some of the XHR requests to bitcdn-global1.bitmovin.com before it seeks ahead. The aborted requests will "fail" with unexpected CORS Same-Origin errors, but subsequent XHR requests to bitcdn-global1.bitmovin.com succeed. (That is bug 1152574.) Eventually the XHR requests just stop and the video no longer plays.

If you pause and unpause the video, it still doesn't play. But if you then seek ahead again, the video will usually start playing again.

Chrome does not have any delays or get stuck no matter how many times you seek.
(Reporter)

Comment 1

4 years ago
This might be a dupe of dashif bug 1140690 or related to video bug 1112683.
See Also: → bug 1140690, bug 1112683
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1152312
(Reporter)

Comment 3

4 years ago
I can repro this bug again in Nightly 43, but *not* Aurora 42.

STR:
1. Play the second video ("Sintel (Multilanguage & Subtitles) - SegmentTemplate") at http://www.dash-player.com/demo/streaming-server-and-encoder-support/
2. Watch the web console for the video player making XHR requests for MSE video segments.
3. Quickly seek ahead about six times until you see the progress spinner (blue dots).
4. Then seek *back* earlier in the video.

RESULT:
The video stalls and XHR requests just stop. Seeking to a different position will sometimes resume the video playback.
Status: RESOLVED → REOPENED
status-firefox42: --- → unaffected
status-firefox43: --- → affected
Component: Audio/Video → Audio/Video: Playback
Resolution: DUPLICATE → ---
(Reporter)

Comment 4

4 years ago
WFM on 42–44
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
status-firefox42: unaffected → verified
status-firefox43: affected → verified
status-firefox44: --- → verified
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.