Closed Bug 1152718 Opened 5 years ago Closed 5 years ago

[Flame][Video]The Time, battery,signal icon display on the top left in video view.

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.1S unaffected, b2g-v2.2 verified, b2g-master verified)

VERIFIED FIXED
2.2 S10 (17apr)
blocking-b2g 2.2+
Tracking Status
b2g-v2.1 --- unaffected
b2g-v2.1S --- unaffected
b2g-v2.2 --- verified
b2g-master --- verified

People

(Reporter: zikui.yang, Assigned: gmarty)

References

Details

(Whiteboard: [systemsfe])

Attachments

(5 files)

[1.Description]:
[Flame][v2.2&3.0][Video]Launch Video, invoke e.me without network connection,enter settings by tapping the "No internet connection" , and back to video. Then time, battery,signal icon display on the top left in video view.
Attchment:logcat(14).txt and VIDEO0345_Compress.MP4
Happen time:17:00

[2.Testing Steps]: 
Precondition:There is no internet network connection
1.Launch Video
2.Drag notification bar
3.Tap Search to invoke E.me
4.Input some words 
5.Tap "No internet connection" to enter Settings
6.Tap Done->Tap close to return Video


[3.Expected Result]: 
6.The Time, battery,signal icon should hide in video view.

[4.Actual Result]: 
6.The Time, battery,signal icon display on the top left in video view.

[5.Reproduction build]: 
Flame 2.2: Affected
Build ID               20150408002503
Gaia Revision          ea735c21bfb0d78333213ff0376fce1eac89ead6
Gaia Date              2015-04-07 20:58:15
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/43041c78052b
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2

Flame 3.0:   Affected
Build ID               20150408160203
Gaia Revision          a290b11627ec2b7c25980f5687a98da86641cfe4
Gaia Date              2015-04-08 08:26:08
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/2c92a7df87c9
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
E.me issue?
Flags: needinfo?(hcheng)
I think it is a window management issue.
Alive, could you take a look?
Component: Gaia::Video → Gaia::System::Window Mgmt
Flags: needinfo?(hcheng) → needinfo?(alive)
Flags: needinfo?(alive)
Whiteboard: [systemsfe]
Looks like a legacy statusbar issue.
Flags: needinfo?(mhenretty)
Component: Gaia::System::Window Mgmt → Gaia::System
blocking-b2g: --- → 2.2?
qawanted to see if this is a regression.
Flags: needinfo?(mhenretty)
Keywords: qawanted
Hi Michael,
This problem cannot be reproduced on Flame 2.1 and 2.1s (On Flame 2.0, it doesn't support invoking E.me from Notification bar.). So it is a regression issue. 
See attachment: Flame2.1_video.mp4
Rate:0/5
Device: 
Flame 2.1 (Unaffected)
Build ID               20150412001204
Gaia Revision          bbe983b4e8bebfec26b3726b79568a22d667223c
Gaia Date              2015-04-09 13:52:48
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/a1b2434ad001
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150412.034733
Firmware Date          Sun Apr 12 03:47:44 EDT 2015
Bootloader             L1TC000118D0

Flame 2.1s (Unaffected)
ild ID               20150412001204
Gaia Revision          276c56f6cd07a34dd2731a70a4d798253749359c
Gaia Date              2015-04-09 20:05:15
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1s/rev/360f6a04fb8c
Gecko Version          34.0
Device Name            scx15_sp7715ea
Firmware(Release)      4.4.2
Firmware(Incremental)  122
Firmware Date          Thu Feb  5 12:42:58 CST 2015
QA Whiteboard: [MGSEI-Triage+]
Keywords: qawanted
Can we get a regression window for 2.2?
Keywords: qawanted
QA Contact: ychung
b2g-inbound Regression Window:

Last Working Environmental Variables:
Device: Flame 3.0
BuildID: 20150227061344
Gaia: b3fe0b0741252e18fdceded00595bd559e6c2bf1
Gecko: 337a83bd43ea
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

First Broken Environmental Variables:
Device: Flame 3.0
BuildID: 20150227062844
Gaia: 640712b2b5773ece064a4958cf812a3ff348ed06
Gecko: 79e9b035ae8d
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Last Working Gaia First Broken Gecko: Issue does NOT reproduce 
Gaia: b3fe0b0741252e18fdceded00595bd559e6c2bf1
Gecko: 79e9b035ae8d

First Broken Gaia Last Working Gecko: Issue DOES reproduce
Gaia: 640712b2b5773ece064a4958cf812a3ff348ed06
Gecko: 337a83bd43ea

https://github.com/mozilla-b2g/gaia/compare/b3fe0b0741252e18fdceded00595bd559e6c2bf1...640712b2b5773ece064a4958cf812a3ff348ed06

Caused by bug 1128618
QA Whiteboard: [MGSEI-Triage+] → [QAnalyst-Triage?][MGSEI-Triage+]
Flags: needinfo?(ktucker)
QA Contact: ychung
Guillaume, can you take a look at this please? This might have been caused by the work done for bug 1128618.
Blocks: 1128618
QA Whiteboard: [QAnalyst-Triage?][MGSEI-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
Flags: needinfo?(ktucker) → needinfo?(gmarty)
Assignee: nobody → gmarty
blocking-b2g: 2.2? → 2.2+
Comment on attachment 8593341 [details] [review]
[gaia] gmarty:Bug-1152718-The-Time-battery-signal-icon-display-on-the-top-left-in-video-view > mozilla-b2g:master

Etienne, here is a patch for the issue. Can you please review it?
Flags: needinfo?(gmarty)
Attachment #8593341 - Flags: review?(etienne)
Comment on attachment 8593341 [details] [review]
[gaia] gmarty:Bug-1152718-The-Time-battery-signal-icon-display-on-the-top-left-in-video-view > mozilla-b2g:master

All good!
Attachment #8593341 - Flags: review?(etienne) → review+
Keywords: checkin-needed
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Guillaume, could you please help uplift to 2.2 since it is a 2.2 blocker?
Flags: needinfo?(gmarty)
Comment on attachment 8593341 [details] [review]
[gaia] gmarty:Bug-1152718-The-Time-battery-signal-icon-display-on-the-top-left-in-video-view > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Status bar
[User impact] if declined: Full screen apps may get the status bar icons displayed after a web activity. Bad UX.
[Testing completed]: This patch is unit tested, manual testing is needed too.
[Risk to taking this patch] (and alternatives if risky): The patch itself is quite small and fully tested, so risk is low.
[String changes made]: None.
Flags: needinfo?(gmarty)
Attachment #8593341 - Flags: approval-gaia-v2.2?(bbajaj)
Attachment #8593341 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+
Flags: needinfo?(hcheng)
Needs rebasing for v2.2 uplift.
Flags: needinfo?(gmarty)
Target Milestone: --- → 2.2 S10 (17apr)
verified with below builds...
*2.2
Build ID               20150426002504
Gaia Revision          265ca0bc9408c21fc4b25a259fcee7fb642cd06b
Gaia Date              2015-04-24 19:13:28
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/1908685d798d
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150426.043030
Firmware Date          Sun Apr 26 04:30:42 EDT 2015
Bootloader             L1TC000118D0

*master
Build ID               20150426010201
Gaia Revision          b4c949cdc780893897c9b45c1adea46e2eb694ff
Gaia Date              2015-04-24 16:13:40
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/37d60e3b8be6
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150426.045825
Firmware Date          Sun Apr 26 04:58:37 EDT 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
Flags: needinfo?(hcheng)
You need to log in before you can comment on or make changes to this bug.