[Windows Management] The header area will overlap the notification bar icons when picking a Gallery or Video app attachment for MMS or Email

VERIFIED FIXED in 2.2 S7 (6mar)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: jmitchell, Assigned: gmarty)

Tracking

({qablocker, regression, smoketest})

unspecified
2.2 S7 (6mar)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [3.0-Daily-Testing][systemsfe])

Attachments

(7 attachments)

(Reporter)

Description

4 years ago
Description:
When you add an attachment from the video or gallery app when you enter the picker screen the header area will overlap the notification bar icons
Notes: This also occurs on the gallery preview page - when you take a screen-shot and click on the received notification the picture title (xxxxx.png) overlaps the icons

Repro Steps:
1) Update a Flame to 20150202010229
2) Open SMS app
3) Select Paper-clip 
4) Select Gallery or Video

Actual:
The 'Select' header overlaps the notification bar icons area

Expected:
The headers will have its own distinct area separate from the notification bar.

Environmental Variables:
Device: Flame 3.0
Build ID: 20150202010229
Gaia: 740c7c2330d08eb9298597e0455f53d4619bbc1a
Gecko: 940118b1adcd
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0


Repro frequency: 6/6
See attached: Screenshot, Logcat
---------------------------------------------------------------------------------------
This issue does not occur in 2.2 

Device: Flame 2.2 (KK - Nightly - Full Flash)
Build ID: 20150202002507
Gaia: d6141fa3208f224393269e17c39d1fe53b7e6a05
Gecko: be206fa2fb60
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2)
Firmware Version: v18d-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Device: Flame 2.2 (KK - Nightly - Full-Flashed)
Build ID: 20150202002507
Gaia: d6141fa3208f224393269e17c39d1fe53b7e6a05
Gecko: be206fa2fb60
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2)
Firmware Version: v18d
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
(Reporter)

Comment 1

4 years ago
(Reporter)

Comment 2

4 years ago
(Reporter)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
(Reporter)

Updated

4 years ago
Summary: [Windows Management] The header area will overlap the notification bar icons when picking a Gallery or Video app attachment for MMS → [Windows Management] The header area will overlap the notification bar icons when picking a Gallery or Video app attachment for MMS or Email
(Reporter)

Comment 3

4 years ago
This also occurs with picking an attachment for email
[Blocking Requested - why for this release]:
Visual regression of a core feature.

Requesting a window.
blocking-b2g: --- → 3.0?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
QA Contact: bzumwalt

Comment 5

4 years ago
Triage: blocking
Assignee: nobody → alive
blocking-b2g: 3.0? → 3.0+
Regression-Window:

Last working Central build:
Device: Flame 3.0
BuildID: 20150129152731
Gaia: 8238eeacc7030b2cdbf7ab4eba2f36779b702599
Gecko: 29b05d283b00
Version: 38.0a1 (3.0)
Firmware: V18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

First broken Central build:
Device:  Flame 3.0
BuildID: 20150130090036
Gaia: 45475198737a504d81932a9c90002902054fce23
Gecko: cdd62a8caf30
Version: 38.0a1 (3.0)
Firmware: V18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0


Working Gaia with Broken Gecko issue does NOT occur:
Gaia: 8238eeacc7030b2cdbf7ab4eba2f36779b702599
Gecko: cdd62a8caf30

Working Gecko with Broken Gaia issue DOES occur:
Gaia: 45475198737a504d81932a9c90002902054fce23
Gecko: 29b05d283b00
 

Central Pushlog:
https://github.com/mozilla-b2g/gaia/compare/8238eeacc7030b2cdbf7ab4eba2f36779b702599...45475198737a504d81932a9c90002902054fce23


Unable to provide B2G-Inbound window as testing is blocked by bug https://bugzilla.mozilla.org/show_bug.cgi?id=1127304

B2G-Inbound window occurs somewhere within builds blocked by that issue:
20150129053233 - 20150129153131
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Hi Howie, Just a note, I found v2.2 is also affected, we also need 2.2+, thank you.

http://mozilla-twqa.github.io/Gaiatest-Reports/2015/02/20150208002500-v2.2-flame/smoketest.html
Build ID               20150208162504
Gaia Revision          e827781324cbde91d2434b388f5dead3303a85ee
Gaia Date              2015-02-06 20:54:14
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/0552759956d3
Gecko Version          37.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150208.201049
Firmware Date          Sun Feb  8 20:11:02 EST 2015
Bootloader             L1TC000118D0


first fail
Device firmware (base)	L1TC000118D0
Device firmware (date)	01 Feb 2015 17:31:31
Device firmware (incremental)	eng.cltbld.20150201.043120
Device firmware (release)	4.4.2
Device identifier	flame
Gaia date	30 Jan 2015 11:46:29
Gaia revision	d6141fa3208f
Gecko build	20150201002504
Gecko revision	f7414413e3a5
Gecko version	37.0a2

last working
Device firmware (base)	L1TC000118D0
Device firmware (date)	29 Jan 2015 17:29:53
Device firmware (incremental)	eng.cltbld.20150129.042943
Device firmware (release)	4.4.2
Device identifier	flame
Gaia date	29 Jan 2015 14:34:56
Gaia revision	6e494f1d2676
Gecko build	20150129003432
Gecko revision	5e6fac01a72f
Gecko version	37.0a2
Duplicate of this bug: 1131485
What's the regression bug? Is it too hard to back it out? Please make sure we are going forward in days since this is a smoketest blocker, thanks.
Flags: needinfo?(alive)
Flags: needinfo?(alive)
Nomming based on comment 7.
blocking-b2g: 3.0+ → 2.2?
Guillaume, you're the statusbar guru these days. Can you give us a hand?
Assignee: alive → gmarty
Whiteboard: [3.0-Daily-Testing] → [3.0-Daily-Testing][systemsfe]
Regression window provided in comment 6 and comment 7
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
(Assignee)

Comment 15

4 years ago
I'm working on this PR, but I'm pretty sure this is not the right way to do as we want to eliminate state classes on the screen element.
I want to discuss this with Alive or Etienne before requesting r+.
blocking-b2g: 2.2? → 2.2+
(In reply to Guillaume Marty [:gmarty] from comment #15)
> I'm working on this PR, but I'm pretty sure this is not the right way to do
> as we want to eliminate state classes on the screen element.
> I want to discuss this with Alive or Etienne before requesting r+.

The patch looks strange :/ My questions:
* Do we show #statusbar in a normal app? I guess we are only showing moz-element of the minimized it in appWindow.titlebar? And real statusbar is somewhere else?
* If hiding #statusbar really fixes the issue, could we do that in activityopened event and hide it if we see evt.detail.getTopMostWindow().isFullScreen() ?
(In reply to Alive Kuo@Paris~2/17 [:alive][NEEDINFO!] from comment #16)
> * If hiding #statusbar really fixes the issue, could we do that in
> activityopened event and hide it if we see
> evt.detail.getTopMostWindow().isFullScreen() ?

OK, I think this works -
listens to topmostwindowchanged -> this.element.classList.toggle('fullscreen', Service.query('getTopMostWindow').isFullScreen());

And we could save some codes here also because topmostwindowchanged covers it
https://github.com/mozilla-b2g/gaia/blob/v2.2/apps/system/js/statusbar.js#L579

Lemme know if you have problem!
(Assignee)

Comment 18

4 years ago
Comment on attachment 8563279 [details] [review]
[gaia] gmarty:Bug-1128618-header-area-will-overlap-the-notification-bar-icons-when-picking-Gallery-Video-app > mozilla-b2g:master

Thanks Alive for the feedback. I implemented your suggestion and added some unit tests. How does it look?
Attachment #8563279 - Flags: review?(alive)
Comment on attachment 8563279 [details] [review]
[gaia] gmarty:Bug-1128618-header-area-will-overlap-the-notification-bar-icons-when-picking-Gallery-Video-app > mozilla-b2g:master

Thanks!
Attachment #8563279 - Flags: review?(alive) → review+
Duplicate of this bug: 1132563
Hi Marty, We need this for V2.2, could you help to uplift, thanks.

Set verifyme for master.
Flags: needinfo?(gmarty)
Keywords: verifyme
(Assignee)

Comment 22

4 years ago
This hasn't landed on master yet because some tests are failing. I've worked on it, now waiting on Gaia-try.
I'll request uplifting approval once it has landed.
Flags: needinfo?(gmarty)
(Assignee)

Comment 23

4 years ago
Landed in https://github.com/mozilla-b2g/gaia/commit/640712b2b5773ece064a4958cf812a3ff348ed06
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Comment 24

4 years ago
Comment on attachment 8563279 [details] [review]
[gaia] gmarty:Bug-1128618-header-area-will-overlap-the-notification-bar-icons-when-picking-Gallery-Video-app > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Activity
[User impact] if declined: When a fullscreen activity opens, the status bar is still displayed on top of it resulting in a bad UX.
[Testing completed]: Unit and marionette tested, manual testing is needed too
[Risk to taking this patch] (and alternatives if risky): This patch is well tested so risk is medium to low.
[String changes made]: None
Attachment #8563279 - Flags: approval-gaia-v2.2?(bbajaj)
Attachment #8563279 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+

Comment 25

4 years ago
This issue still exist on flame 2.2&3.0,refer to picture and logcat(Happen time 10:33)
FLame 2.2:
Build ID               20150227002521
Gaia Revision          eb6a5ac9081d3962198e0f4520b0743d716d7a27
Gaia Date              2015-02-26 17:25:22
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/c8a38dcfbebc
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Flame3.0:
Build ID               20150227010229
Gaia Revision          7512026a377271a0cade12d70846557f0bc7781c
Gaia Date              2015-02-26 19:06:40
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/c7968255c1ea
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Flags: needinfo?(whsu)
Keywords: verifyme

Comment 26

4 years ago

Comment 27

4 years ago
Posted file logcat(2).txt

Updated

4 years ago
Flags: needinfo?(whsu)

Comment 28

4 years ago
Please ignore comment 25 26 27,I will use proper build to verification later.
(In reply to Elie from comment #28)
> Please ignore comment 25 26 27,I will use proper build to verification later.

Yes, please wait until patch is merged into v2.2.
Thanks.
Duplicate of this bug: 1132334
This issue is verified fixed for the latest Nightly 3.0 and 2.2 builds.

Actual Results:  The status bar is not shown when selecting from the video or gallery app.
	
Environmental Variables:
Device: Flame 3.0 KK (Full Flash) (319 MB)
BuildID: 20150303010233
Gaia: c8ed1085a67490a1ecd7f275e5de9487e1b93b1d
Gecko: 0b3c520002ad
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Environmental Variables:
Device: Flame 2.2 KK (Full Flash) (319 MB)
BuildID: 20150303002527
Gaia: 3d188c414e30acc392253d5389a42352fcfbc183
Gecko: c89aad487aa5
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Depends on: 1144593
You need to log in before you can comment on or make changes to this bug.