Language packs should be hidden in rocketbar search

VERIFIED FIXED in 2.2 S10 (17apr)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: aryx, Assigned: kgrandon)

Tracking

unspecified
2.2 S10 (17apr)
All
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [systemsfe], URL)

Attachments

(4 attachments)

+++ This bug was initially created as a clone of Bug #1097633 +++

+++ This bug was initially created as a clone of Bug #1064735 +++

B2G 2.2 20150409002503 on Flame (v18D base image)

Language packs for gaia (see Bug 1107341) are contained within an app. A language pack is not used for anything else and a user cannot interact with it. Hence, it should be hidden in the rocketbar search.

Steps to reproduce:
1. Go to Setting > Languages
2. Tap on the item to install more languages.
3. Marketplace should be opened. The offered language packs likely depend on the gaia branch you use. I got offered an Italian language pack and installed it.
4. Open the rocketbar search.
5. Type 'ita'.
Actual result:
Italian language pack shown in list of results. Tapping on it opens the root folder of the app and shows the file structure.
Expected result:
Language pack not found by search.
blocking-b2g: 2.2? → 2.2+
Assignee: nobody → kgrandon
(Assignee)

Comment 1

4 years ago
Hmm, we're supposed to already be doing this here: Hmm, this is supposed to be fixed here: https://github.com/mozilla-b2g/gaia/blob/373140b939e61a6fec28e205dad7b6e8ff427294/apps/search/js/providers/local_apps.js#L68

Adding qawanted - can we do branch checks on 2.2 and 3.0? Thanks!
Status: NEW → ASSIGNED
Keywords: qawanted
QA Contact: ktucker
This issue reproduces on the  Flame 3.0 and Flame 2.2

Language packs are shown in Rocketbar search results.

Device: Flame 3.0 (Full Flash)(KK)(319mb)
BuildID: 20150409010203
Gaia: 5dfd0460eb6e616205154b0d219aa5123bf1abb3
Gecko: 8f57f60ee58a
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Device: Flame 2.2
BuildID: 20150409002503 (Full Flash)(KK)(319mb)
Gaia: ea735c21bfb0d78333213ff0376fce1eac89ead6
Gecko: 0efd5cdbe224
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

----------------------------------------

Please note that once the user returns home, installed language packs are not shown in the search results. It only appears when performing a Rocketbar search on the language pack install screen.
QA Whiteboard: [QAnalyst-Triage+]
Flags: needinfo?(archaeopteryx)
Keywords: qawanted
I confirm that the language pack is later gone from the app search results in the rocketbar (e.g. after a restart).
Flags: needinfo?(archaeopteryx)
(Assignee)

Comment 4

4 years ago
(In reply to Archaeopteryx [:aryx] from comment #3)
> I confirm that the language pack is later gone from the app search results
> in the rocketbar (e.g. after a restart).

Oh, that's very helpful, I have an idea of what this is then. Thanks!
(Assignee)

Comment 5

4 years ago
Hmm, I'm actually not as sure as I thought I was here.

Adding qawanted here - can we have a screenshot or video please? I'm having trouble reproducing this.
Keywords: qawanted
For the record, the language pack can be installed from Settings > App permissions. I also failed to reproduce it once with the same steps (after the install, I press the home button and then scroll to the top and tap the rocketbar).
If you have trouble reproducing this on Flame 3.0 then do the following:

1. Tap on "Settings".
2. Tap on "Language".
3. Tap on "Get More Languages". 
4. Install Deutsch then tap on the rocketbar on the same page and type "Deu".
5. If the issue does not occur then install Francais and type "Fra" in the rocketbar.
6. If it still doesn't occur install Polski and type "Pol" in the rocketbar. 

This is much easier to reproduce on 2.2

Video Attached.
Target Milestone: --- → 2.2 S10 (17apr)
(Assignee)

Comment 9

4 years ago
As far as I can tell the role is not set to "langpack" when mozApps gets the oninstall event. This might be a new issue as I believe this might be the first time that we can install apps of a "hidden" role.

Fabrice - any ideas here? I am pretty sure that this is a mozApps bug, but I'm fine implementing a fix in gaia if we can think of one.
Assignee: kgrandon → nobody
Status: ASSIGNED → NEW
Component: Gaia::Search → DOM: Apps
Flags: needinfo?(fabrice)
Product: Firefox OS → Core
Whiteboard: [systemsfe]
at oninstall with a packaged app, you only have a mini-manifest (the .updateManifest) and there is no role in it. We don't have the full manifest yet at this point, so there's not much we can do.
You need to wait for the downloadapplied event to get the full manifest.
Flags: needinfo?(fabrice)
(Assignee)

Comment 11

4 years ago
Thanks for the info. Is there a spec somewhere with the mini-manifest details that you can point me to? Can we add 'role' to it?
Flags: needinfo?(fabrice)
There's no real spec. All we need the app name, the dev info and the package_path. It's ok to add new fields, we don't filter anything out on the platform side.

I guess you would have to check with the marketplace team how the validate manifests mostly.
Flags: needinfo?(fabrice)
(Assignee)

Comment 13

4 years ago
Well, sounds like a gaia workaround would work best for this, maybe in the future we can see about enforcing the addition of role to the mini-manifest.
Assignee: nobody → kgrandon
Status: NEW → ASSIGNED
Component: DOM: Apps → Gaia::Search
Product: Core → Firefox OS
Whiteboard: [systemsfe]
(Assignee)

Comment 15

4 years ago
Comment on attachment 8592343 [details] [review]
[gaia] KevinGrandon:bug_1152772_downloaded_event_role > mozilla-b2g:master

Dale or Ben - could either of you guys give this a review? This seems to fix the problem for me. Thanks!
Attachment #8592343 - Flags: review?(dale)
Attachment #8592343 - Flags: review?(bfrancis)
Comment on attachment 8592343 [details] [review]
[gaia] KevinGrandon:bug_1152772_downloaded_event_role > mozilla-b2g:master

This looks great, cheers
Attachment #8592343 - Flags: review?(dale) → review+
(Assignee)

Comment 17

4 years ago
Comment on attachment 8592343 [details] [review]
[gaia] KevinGrandon:bug_1152772_downloaded_event_role > mozilla-b2g:master

Thanks for the review!
Attachment #8592343 - Flags: review?(bfrancis)
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Flags: needinfo?(hcheng)
Please uplift to v2.2, thanks.
Flags: needinfo?(hcheng) → needinfo?(kgrandon)
Keywords: verifyme
(Assignee)

Comment 20

4 years ago
Comment on attachment 8592343 [details] [review]
[gaia] KevinGrandon:bug_1152772_downloaded_event_role > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Surfaced due to langpack implementation.
[User impact] if declined: Poor UX when using langpacks + search.
[Testing completed]: Manual and unit testing.
[Risk to taking this patch] (and alternatives if risky): Low risk, contained within search app.
[String changes made]: None.
Flags: needinfo?(kgrandon)
Attachment #8592343 - Flags: approval-gaia-v2.2?(bbajaj)
Attachment #8592343 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+
This bug has been successfully verified on latest Nightly Flame v3.0 and user build.
See attachment: verified_v3.0.mp4
Reproduce rate: 0/8

STR:
1. Tap on "Settings" and connect a wifi.
2. Go to "Language".
3. Tap on "Get More Languages". 
4. Install Deutsch then tap on the rocketbar on the same page and type "Deu".
**Can't search any language pack.
5. Install Francais and type "Fra" in the rocketbar.
**Can't search any language pack.
6. Install Polski and type "Pol" in the rocketbar. 
**Can't search any language pack.
7.Go to Homscreen->Rocketbar,search "lan".
**Can't search any language pack.

----------------------------------------------------------------------------------------------
Device: Flame 3.0 build(Pass)
Build ID               20150416160206
Gaia Revision          3cd0a9facce26c2acc7be3755a17131a6358e33f
Gaia Date              2015-04-16 16:33:22
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/51e3cb11a258
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150416.191700
Firmware Date          Thu Apr 16 19:17:10 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0 user build(Pass)
Build ID               20150416160206
Gaia Revision          3cd0a9facce26c2acc7be3755a17131a6358e33f
Gaia Date              2015-04-16 16:33:22
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/51e3cb11a258
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150416.192613
Firmware Date          Thu Apr 16 19:26:24 EDT 2015
Bootloader             L1TC000118D0
Shally, please help verify 2.2.
Flags: needinfo?(lixia)
This bug has been successfully verified on latest Nightly Flame v2.2. 

Actual results: After installing Italiano,can't search "Italiano Language Packs" in Rocketbar.
See attachment: verified_v2.2.mp4
Reproduce rate: 0/5

Device: Flame 2.2 build(Pass)
Build ID               20150419002502
Gaia Revision          c15a2b6d3a783813959c2b3bffd2a131f4270b9e
Gaia Date              2015-04-17 17:49:32
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/cc02ee38b252
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150419.040848
Firmware Date          Sun Apr 19 04:08:59 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 2.2 user build(Pass)
Build ID               20150419002502
Gaia Revision          c15a2b6d3a783813959c2b3bffd2a131f4270b9e
Gaia Date              2015-04-17 17:49:32
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/cc02ee38b252
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150419.040054
Firmware Date          Sun Apr 19 04:01:05 EDT 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
Flags: needinfo?(lixia)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.