Closed Bug 1152866 Opened 4 years ago Closed 4 years ago

[e10s] Pointer is locked, but still visible on three.js demo

Categories

(Core :: DOM: Events, defect)

x86
Linux
defect
Not set

Tracking

()

RESOLVED WORKSFORME
Tracking Status
e10s m8+ ---

People

(Reporter: azakai, Unassigned)

References

(Blocks 1 open bug)

Details

On

http://threejs.org/examples/#misc_controls_pointerlock

Clicking will lock the pointer, and after bug 1085567 it returns the right movement amounts, however the mouse cursor is still visible. On non-e10s and on chrome the cursor vanishes properly.
Blocks: e10s, gecko-games
I only see this problem in full screen. The cursor is properly hidden in http://mdn.github.io/pointer-lock-demo/. In Em-DOSBox it is hidden when normally displayed in a tab but not hidden in full screen.
azakai, is your profile free of addon interference?
Flags: needinfo?(azakai)
Yes, no addons or plugins are involved.
Flags: needinfo?(azakai)
Does this still reproduce this Alon? I tried it in Linux and it worked for me.
Flags: needinfo?(azakai)
Works for me too.
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(azakai)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.