[e10s] After opening the web page in new tab, drag and drop onto the contents area is not working

VERIFIED FIXED in Firefox 40

Status

()

Core
Drag and Drop
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: Alice0775 White, Assigned: smaug)

Tracking

({reproducible, site-compat})

40 Branch
mozilla40
x86_64
All
reproducible, site-compat
Points:
---

Firefox Tracking Flags

(e10s?, firefox40 fixed)

Details

(Whiteboard: [bugday-20150729])

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Build Identifier:
https://hg.mozilla.org/integration/mozilla-inbound/rev/c6d230ecf1a5
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0 ID:20150409080331

Bug 936092 landed in m-i, however,

After opening the web page in new tab, drag and drop onto the contents area is not working.
Drag and drop a file onto <input type=file> is not working.

I tested with newly created profile.

Reproducible: sometimes

Steps To Reproduce:
1. Open e10s window
2. Open any page in new tab
   ex. about:home, https://developer.mozilla.org/En/Code_snippets
3. Attempt to drag & drop html, jpg, png. xpi file to the content area
4. Attempt to drag & drop a bookmark from Library to the content area

Actual Reslts:
No thing happens. 

Expected Results:
D&D should be performed successfully like non-e10s

* drag & drop a bookmark from Bookmarks toolbar and Sidebar seems OK

Comment 1

3 years ago
Clarification;
Step 2 above is two steps - i.e. first open new tab, then visit site.
If you open directly in new tab D&D works.

Alternative steps;
Type in address about:newtab (or any non-remote address)
Type in address about:home in same tab (or visit any remote address)
Try D&D (fails)
(Assignee)

Comment 2

3 years ago
This is WFM on linux and Windows, e10s enabled.
(Reporter)

Comment 3

3 years ago
I can still reproduce on ubuntu14.04 and Wndows7 with e10s.

https://hg.mozilla.org/mozilla-central/rev/2c9708e6b54d
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0 ID:20150413030203

https://hg.mozilla.org/mozilla-central/rev/2c9708e6b54d
Mozilla/5.0 (X11; Linux i686; rv:40.0) Gecko/20100101 Firefox/40.0 ID:20150413030203


:smang, did you should follow str in comment#0?

Steps To Reproduce:
1. Open e10s window --- (there is about:home tab only)
2. Open any page in new tab --- (enter url and middle+ click reload button etc)
   ex. about:home, https://developer.mozilla.org/En/Code_snippets
3. Attempt to drag & drop html, jpg, png. xpi file to the content area
4. Attempt to drag & drop a bookmark from Library to the content area
(Assignee)

Comment 4

3 years ago
I assume we're somehow missing to creating the drag session in the child process, but why...

Anyone who can reproduce this, do you see any related warnings in the terminal when using a debug build?
(Assignee)

Comment 5

3 years ago
And yes, I did follow the STR exactly. No luck reproducing.
(Reporter)

Comment 6

3 years ago
[Parent 4536] WARNING: No docshells for remote frames!: file c:\builds\
moz2_slave\m-cen-w32-d-000000000000000000\build\src\dom\base\nsFrameLoader.cpp, line 492
[Parent 4536] WARNING: No docshells for remote frames!: file c:\builds\moz2_slave\m-cen-w32-d-000000000000000000\build\src\dom
\base\nsFrameLoader.cpp, line 492
[Parent 4536] WARNING: No docshells for remote frames!: file c:\builds\moz2_slave\m-cen-w32-d-000000000000000000\build\src\dom
\base\nsFrameLoader.cpp, line 492
[Parent 4536] WARNING: NS_ENSURE_TRUE(mMutable) failed: file c:\builds\moz2_slave\m-cen-w32-d-000000000000000000\build\src\net
werk\base\nsSimpleURI.cpp, line 264
[Parent 4536] WARNING: No docshells for remote frames!: file c:\builds\moz2_slave\m-cen-w32-d-000000000000000000\build\src\dom
\base\nsFrameLoader.cpp, line 492
[Parent 4536] WARNING: No docshells for remote frames!: file c:\builds\moz2_slave\m-cen-w32-d-000000000000000000\build\src\dom
\base\nsFrameLoader.cpp, line 492
[Parent 4536] WARNING: Enabling vsync compositor
: file c:\builds\moz2_slave\m-cen-w32-d-000000000000000000\build\src\gfx\layers\ipc/CompositorParent.cpp, line 483
[Parent 4536] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80520012: file c:\builds\moz2_slave\m-cen-w32-d-00000000
0000000000\build\src\netwerk\base\nsFileStreams.cpp, line 205
[Parent 4536] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80520012: file c:\builds\moz2_slave\m-cen-w32-d-00000000
0000000000\build\src\netwerk\base\nsFileStreams.cpp, line 492
[Parent 4536] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80520012: file c:\builds\moz2_slave\m-cen-w32-d-00000000
0000000000\build\src\netwerk\base\nsFileStreams.cpp, line 205
[Parent 4536] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80520012: file c:\builds\moz2_slave\m-cen-w32-d-00000000
0000000000\build\src\netwerk\base\nsFileStreams.cpp, line 492
[Parent 4536] WARNING: No docshells for remote frames!: file c:\builds\moz2_slave\m-cen-w32-d-000000000000000000\build\src\dom
\base\nsFrameLoader.cpp, line 492
(Reporter)

Comment 7

3 years ago
100% reproducible for me.
Of course, I tested with newly created profile.
Keywords: reproducible
OS: Windows 7 → All
(Assignee)

Comment 8

3 years ago
Can you dnd text from external program to textarea in e10s-FF when this issue happens?
(Reporter)

Comment 9

3 years ago
(In reply to Olli Pettay [:smaug] from comment #8)
> Can you dnd text from external program to textarea in e10s-FF when this
> issue happens?

Yes , I can reproduce.
STR:
  1. Open this page in new tab
  2. D&D from a selected text on wordpad.exe to input/textarea on this page.

Actual Results: 
  Nothing happens.
(Reporter)

Comment 10

3 years ago
I can also reproduce the problem on ubuntu. D&D from selected text on gedit to input/textarea on this page.
(Assignee)

Comment 11

3 years ago
I've managed to reproduce the issue once on a newly created profile. After restarting the issue was gone. Investigating
(Assignee)

Comment 12

3 years ago
Created attachment 8591815 [details] [diff] [review]
v1

This is similar to the "drop" case.
Assignee: nobody → bugs
Attachment #8591815 - Flags: review?(enndeakin)

Updated

3 years ago
Attachment #8591815 - Flags: review?(enndeakin) → review+
(Assignee)

Comment 13

3 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/f3ce723bd0b9

If there are other issues with e10s+dnd, could you file new bugs, thanks
(well, assuming the patch fixes your issue, not only the one I managed to reproduce).
https://hg.mozilla.org/mozilla-central/rev/f3ce723bd0b9
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox40: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla40
Duplicate of this bug: 1153878
Duplicate of this bug: 1153878
WordPress developers say DnD still doesn't work on e10s-enabled Firefox 40. Any ideas?

https://core.trac.wordpress.org/ticket/32438
Keywords: site-compat
QA Whiteboard: [good first verify][verify in Nightly only]
works in debian 9 (stretch testing)
Verified fixed using Windows 7 32 bit.
Build identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0

[bugday-20150729]

Updated

3 years ago
Status: RESOLVED → VERIFIED

Updated

3 years ago
Whiteboard: [bugday-20150729]
You need to log in before you can comment on or make changes to this bug.