Contact Last Name is repeated in Name field when viewing an attached vcard with Last Name and without Name fields

VERIFIED FIXED in Firefox OS master

Status

VERIFIED FIXED
4 years ago
3 years ago

People

(Reporter: oteo, Assigned: hola)

Tracking

unspecified
FxOS-S5 (21Aug)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.2 affected, b2g-master verified)

Details

Attachments

(3 attachments, 1 obsolete attachment)

(Reporter)

Description

4 years ago
Created attachment 8590503 [details]
2015-04-09-23-22-49.png

STR:
1) Launch Contacts.
2) Create a contact without Name, but with Last Name fields (e.g. last Name= Oteo)
3) Launch Message app, create a message.
4) Add that contact as attachment.
5) Tap the attached contact and select view option


Actual Result:
Contact detail is shown (with form view) but name field is not empty, and last name is shown instead in that field. So name and last name fields are repeated (e.g. Name=Oteo, Last Name=Oteo). See file attached 

Expected Result: 
Contact detail should be shown (with form view) with Name field empty.

Note: If after reproducing the bug, the user closes the contact details form screen, pressing "X" button, and sends the message. The message is received correctly in the other device, without Name field.

In case user press "Done" button, "Duplicates founds" screen appears to give the user the option to merge the "Oteo Oteo" contact with the already included in the Agenda "Oteo" what it's really weird.

Note: this is a Contacts issue, the bug can be reproduced when receiving and trying to view a vcard file from Mail application with Last Name and without Name

Environmental variables:
flame master (3.0 version)
Build ID: 20150409064841
Gecko: 6febe17
Gaia: cdf5276
Platform version: 40.0a1

Environmental variables:
flame master (2.2 version)
Build ID: 20150409063108
Gecko: 980e301
Gaia: ea735c2
Platform version: 37.0
(Reporter)

Comment 1

4 years ago
Adrian, could you have a look at it when you have time? Thanks a lot!
Flags: needinfo?(hola)
(Reporter)

Updated

4 years ago
status-b2g-v2.2: --- → affected
status-b2g-master: --- → affected
(Reporter)

Updated

4 years ago
See Also: → bug 1152237
(Assignee)

Comment 2

4 years ago
I'm working on it!
Assignee: nobody → hola
Flags: needinfo?(hola)
(Reporter)

Updated

4 years ago
Status: NEW → ASSIGNED
Created attachment 8591790 [details] [review]
[gaia] ADLR-es:duplicate-name-vcard > mozilla-b2g:master
(Assignee)

Comment 4

4 years ago
Comment on attachment 8591790 [details] [review]
[gaia] ADLR-es:duplicate-name-vcard > mozilla-b2g:master

Minimal change, with no side effects as far as I know. All tests are green.
Attachment #8591790 - Flags: review?(francisco)
Comment on attachment 8591790 [details] [review]
[gaia] ADLR-es:duplicate-name-vcard > mozilla-b2g:master

Redirecting to sergi,since he owns sdcard code.
Attachment #8591790 - Flags: review?(francisco) → review?(sergi.mansilla)
(Reporter)

Comment 6

3 years ago
Francisco, this revision is taking longer, is Sergi still working on the project?
Perhaps we could have a look at the patch and rebase it, now we are merging the open vs import activities
Flags: needinfo?(francisco)
Agree, it's been a while without knowing from Sergi.

We can still merge it, so will reassign the review to myself.
Flags: needinfo?(francisco)
Attachment #8591790 - Flags: review?(sergi.mansilla) → review?(francisco)
Created attachment 8648724 [details] [review]
[gaia] arcturus:bug-1152986 > mozilla-b2g:master
Attachment #8591790 - Attachment is obsolete: true
Attachment #8591790 - Flags: review?(francisco)
Landed:

https://github.com/mozilla-b2g/gaia/commit/3e450f495a2a72ffc89ff3e0485a087e8c0deae3

(had to create a new pr, since the previous one was done against a really old gaia)
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Reporter)

Updated

3 years ago
status-b2g-master: affected → fixed
Target Milestone: --- → FxOS-S5 (21Aug)
This bug has been verified as "pass" on the latest build of Flame KK 2.5 and Aires KK 2.5 by the STR in comment 0, and the design of "View" screen is changed on the latest master build.

Actual results: Showing the ".vcf" contact name and "Import all" icon on the "View" screen , if you tap "Import all" icon, this contact in message will be merged with the contact saved in Contact app. The contact shows normally with last name in contact app,  which is not repeated in Name field.

See attachment: verified_FlameKK_v2.5.3gp
Reproduce rate: 0/10


Device: Flame KK 2.5 (Pass)
Build ID               20150820150207
Gaia Revision          c6705f739fb605031eb2a0b943ba55c64bee5a03
Gaia Date              2015-08-20 14:36:40
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/095988abdc560bf8ba07a94a425c6922a3e9bfd6
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150820.183055
Firmware Date          Thu Aug 20 18:31:07 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK 2.5(Pass)
Build ID               20150820204657
Gaia Revision          c6705f739fb605031eb2a0b943ba55c64bee5a03
Gaia Date              2015-08-20 14:36:40
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/095988abdc560bf8ba07a94a425c6922a3e9bfd6
Gecko Version          43.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150820.200928
Firmware Date          Thu Aug 20 20:09:36 UTC 2015
Bootloader             s1
QA Whiteboard: [MGSEI-Triage+]
status-b2g-master: fixed → verified
Created attachment 8650920 [details]
verified_FlameKK_v2.5.3gp
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.