Closed Bug 1152237 Opened 5 years ago Closed 4 years ago

[Flame][Message]Device will enter contacts list page when you tap the .vcf (without name and last name) to view.

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

(tracking-b2g:backlog, b2g-v2.2 affected, b2g-master affected)

RESOLVED INVALID
tracking-b2g backlog
Tracking Status
b2g-v2.2 --- affected
b2g-master --- affected

People

(Reporter: liuke, Unassigned)

References

Details

(Keywords: verifyme)

Attachments

(2 files)

[1.Description]:
[Flame v2.2 & v3.0][Message]Device can't enter details page when you tap the .vcf to view.
Found time:10:16
See attachment:1016.mp4 and logcat_1016.txt

[2.Testing Steps]: 
1.Launch Contacts.
2.Create a contact without name, then save it.
3.Launch Message, create a message.
4.Add the contact as attachment.
5.Tap the contact to view.

[3.Expected Result]: 
5.It will enter contact details page.

[4.Actual Result]: 
5.The device can't enter the details page, it still displays contact list page.

[5.Reproduction build]: 
Flame 2.2 version(Affected):
Build ID               20150407162504
Gaia Revision          ea735c21bfb0d78333213ff0376fce1eac89ead6
Gaia Date              2015-04-07 20:58:15
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/3f86ddb7f719
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150407.195227
Firmware Date          Tue Apr  7 19:52:39 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0 version(Affected):
Build ID               20150407160201
Gaia Revision          84cbd4391fb7175d5380fa72c04d68873ce77e6d
Gaia Date              2015-04-07 17:33:14
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/078128c2600a
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150407.193600
Firmware Date          Tue Apr  7 19:36:12 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
Attached file logcat_1016.txt
Attached video 1016.MP4
Looks like a Contacts activity issue.
blocking-b2g: --- → 2.2?
Component: Gaia::SMS → Gaia::Contacts
ni to Johan to check whether step2 of the STR is necessary to reproduce.
if it needs the contact w/o a name to reproduce, we would consider it as a corner case.
Flags: needinfo?(jlorenzo)
I've been checking the bug and it needs step 2. So it's necessary to have a contact without name and last name to be able to reproduce the bug.

Although I agree that it could be a corner case, what I've seen is that when tapping on the attached contact to be viewed and the contact list is shown instead of the contact details page (with form view), there is no way to go back to the message to be able to continue editing it or send it.

It's necessary to kill the Messaging application to be able to access the draft message again, what it's annoying. 

Environmental variables:
flame master (3.0 version)
Build ID: 20150409064841
Gecko: 6febe17
Gaia: cdf5276
Platform version: 40.0a1

Environmental variables:
flame master (2.2 version)
Build ID: 20150409063108
Gecko: 980e301
Gaia: ea735c2
Platform version: 37.0

Adrian, could you be so kind of having a look at it?
Flags: needinfo?(hola)
As Julien said in comment 3, this is a Contacts issue, the bug can be reproduced when receiving and trying to view a vcard file from Mail application without name and last name.
See Also: → 1152986
Summary: [Flame][Message]Device will enter contacts list page when you tap the .vcf to view. → [Flame][Message]Device will enter contacts list page when you tap the .vcf (without name and last name) to view.
I checked master and have the same conclusion as Maria: If a contact has either a first or a last name or both, the bug doesn't reproduce. I share her point of view about the annoyance: if you fall into this (by inadvertence for instance), the only way to go back to the action of writing a message is by killing the Message app.

I see 2 type of contacts that can provoke this issue: the one with only a phone number, or the one with only an email address. Having such contacts in the phonebook seems like a use case to me. Hence, a user might fall into this have no clue on how to continue writing his message.
Flags: needinfo?(jlorenzo)
triage: tracking-b2g:+ because it's a corner case.
blocking-b2g: 2.2? → ---
tracking-b2g: --- → +
[Tracking Requested - why for this release]:
Priority: -- → P1
This bug is caused because the vCard reader follows the spec[1] and treats vCards without name as not valid, as stated in the code: https://github.com/mozilla-b2g/gaia/blob/master/shared/js/contacts/import/utilities/vcard_reader.js#L239-L240

So to fully adhere to the spec, we should always export a vCard with name, maybe setting phone or other info available as name when exporting.

[1] http://tools.ietf.org/html/rfc2426#section-3.1.1
Flags: needinfo?(hola)
Right now, I am not able to reproduce this bug.

After landing the merging of #open and #import activities (see bug 1184075) the behavior has changed

It does not mind if the contact has or not name or surname (step 2) because, for every contact,
when tapping the contact to be viewed (step 5) device will enter import page.

Expected Result: 
5.It will enter contact details page.

Actual Result: 
5.The device can't enter the details page, it displays import page.

This issue has already been reported in bug 1192180 so, from my point of view, this bug should be invalid and the issue should be handled in bug 1192180.

As we are not sure about how we are going to proceed, in case the pre-rendering is not in time for 2.5 and we had to do roll back of the separation views, I am not going to close this bug and I will set ni to Francisco to confirm it when the decision is made.

Environmental Variables (8/31):
flame master (2.5 version)
Build ID: 20150831063701
Gecko: d6c213f
Gaia: 31e595f
Platform version: 43.0a1
Flags: needinfo?(francisco)
See Also: → 1184075, 1192180
+1 to close as invalid and continue the work on bug 1192180
Flags: needinfo?(francisco)
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → INVALID
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.