Closed Bug 1153387 Opened 5 years ago Closed 5 years ago

Sorting by hits in a filterlist in ABP takes three times as long with shims

Categories

(Firefox :: Extension Compatibility, defect)

x86_64
Windows 7
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1164014

People

(Reporter: elbart, Unassigned)

References

Details

Recent Nightly
Recent ABP-dev build
EasyList filterlist

Sorting in the EasyList filterlist by hits takes three times as long with e10s-shims[1] than without, regardless of e10s being enabled or not.

Benchmark on my machine:
extensions.interposition.enabled true : 16s
extensions.interposition.enabled false:  5s

comparison: 
Firefox 24.8.1 with ABP 2.6.6: 3s
Firefox 31.6.1 with ABP 2.6.9: 3s


Regression-range for non-e10s:
Last good revision: 0e631971b841 (2014-11-02)
First bad revision: 0b81c10a9074 (2014-11-03)
Pushlog: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=0e631971b841&tochange=0b81c10a9074
Bug 1063156 - Enable e10s shims by default, even when browser.tabs.remote.autostart pref is false.

Regression range for e10s:
Last good revision: 095d2a9c2be5 (2014-07-15)
First bad revision: 869971ad9fd6 (2014-07-16)
Pushlog: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=095d2a9c2be5&tochange=869971ad9fd6
Bug 1031609 - Initial compatibility shims for e10s
Blocks: e10s-abp, 1031609
See Also: → 1162392
Last bad   06-09
First good 06-10

Now it's as fast with shims as it was before; bug 1162392 still applies.
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1164014
You need to log in before you can comment on or make changes to this bug.