Tabs in reader mode forget their title after a restart

RESOLVED DUPLICATE of bug 1160556

Status

()

RESOLVED DUPLICATE of bug 1160556
4 years ago
4 years ago

People

(Reporter: aleth, Unassigned)

Tracking

39 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
Open a page in reader mode, switch to a different tab, and restart.
After the restart, the restored reader mode tab has lost its title. Instead, an about-reader URL is shown.
(Reporter)

Updated

4 years ago
Component: Reading List → Reader Mode
Product: Firefox → Toolkit
(Reporter)

Comment 1

4 years ago
On second thoughts, should this bug actually be in the session restore component?
Flags: needinfo?(gijskruitbosch+bugs)

Comment 2

4 years ago
I don't know. Tim, any idea why this doesn't Just Work ?
Flags: needinfo?(gijskruitbosch+bugs) → needinfo?(ttaubert)
Can't reproduce with a trunk build. Any more details you can give? Does it happen with any URL or just some articles?
Flags: needinfo?(ttaubert)
Flags: needinfo?(aleth)
(Reporter)

Comment 4

4 years ago
It does not seem to happen when I restart a session with only a few tabs open.

When there are many tabs to be restored, so startup takes O(seconds), it happens, but not consistently and not necessarily for all reader-mode tabs. So there is probably some async issue involved. The exact URL doesn't seem to make a difference.

I've noticed the about-reader URL *also* briefly but noticeably appears as the title when clicking on a restored tab with the correct title, while the page is being loaded.
(Reporter)

Updated

4 years ago
Flags: needinfo?(aleth)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1160556
You need to log in before you can comment on or make changes to this bug.