Closed Bug 1153518 Opened 5 years ago Closed 5 years ago

[e10s] Location bar retains invisible selection and does not permit text drop

Categories

(Firefox :: Address Bar, defect)

defect
Not set
Points:
2

Tracking

()

VERIFIED FIXED
Firefox 41
Tracking Status
e10s m8+ ---
firefox41 --- verified

People

(Reporter: ke5trel, Assigned: enndeakin)

References

Details

Attachments

(1 file, 2 obsolete files)

Steps:

e10s Nightly - now that drag and drop has been fixed (Bug 936092).
1. Highlight plain text in an e10s page.
2. Drag and drop into the location bar.
3. Attempt to repeat.

non-e10s Nightly, FF37, FF24
1. Enter text into the searchbar and highlight it.
2. Drag and drop into the location bar.
3. Attempt to repeat.

Actual results:

Dropping text into the location bar fails after either the first or second successful drop. The cursor shows a blocked symbol indicating drop is not possible. 

Expected results:

There should be no limit to how many times text can be dropped into the location bar. 


Only seems to happen for text dragged from the searchbar or an e10s page, text dragged from elsewhere works normally.

A second drop is sometimes allowed and seems to be for when the page has been visited previously.

Loading a new page resets the location bar and allows text to be dropped again. It can also be reset by dropping in a url and stopping before the page changes.
This is being caused by an invisible selection in the location bar which does not allow dropping text onto it.

Revised steps, focusing on e10s:

1. Make a partial selection inside location bar and remember its position.
2. Make a text selection within document and try to drag it into the location bar where the partial selection was made.
3. While still dragging, move the cursor across the now invisible partial selection and note how the cursor icon changes.

Expected results:

Should always be able to drop text anywhere in the location bar.

Actual results:

Dropping is not possible in selected parts of the location bar but it is not clear where, as any selection is only visible when the location bar has focus. 

This wasn't a problem with non-e10s because the location bar selection was not being retained like it is now.
Blocks: e10s
tracking-e10s: --- → ?
OS: Windows 8.1 → All
Hardware: x86_64 → All
Summary: Dragging and dropping text into the location bar fails after the first or second time → [e10s] Location bar retains invisible selection and does not permit text drop
Assignee: nobody → enndeakin
Status: UNCONFIRMED → ASSIGNED
Points: --- → 2
Ever confirmed: true
Attached patch Potential fix (obsolete) — Splinter Review
Attached patch Updated patch (obsolete) — Splinter Review
Attachment #8621809 - Attachment is obsolete: true
Attachment #8621973 - Flags: review?(ehsan)
Comment on attachment 8621973 [details] [diff] [review]
Updated patch

Review of attachment 8621973 [details] [diff] [review]:
-----------------------------------------------------------------

Can you please add a test case?  Thanks!

::: editor/libeditor/nsEditorEventListener.cpp
@@ +993,5 @@
> +  TabParent* tp = TabParent::GetFrom(sourceContent);
> +  if (tp) {
> +    return true;
> +  }
> +  

Nit: trailing whitespace.
Attachment #8621973 - Flags: review?(ehsan) → review+
(In reply to :Ehsan Akhgari (not reading bugmail, needinfo? me!) from comment #4)
> Comment on attachment 8621973 [details] [diff] [review]
> Updated patch
> 
> Review of attachment 8621973 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> Can you please add a test case?  Thanks!
> 

We don't have a means of testing drag and drop between processes/applications.
(In reply to Neil Deakin from comment #5)
> (In reply to :Ehsan Akhgari (not reading bugmail, needinfo? me!) from
> comment #4)
> > Comment on attachment 8621973 [details] [diff] [review]
> > Updated patch
> > 
> > Review of attachment 8621973 [details] [diff] [review]:
> > -----------------------------------------------------------------
> > 
> > Can you please add a test case?  Thanks!
> > 
> 
> We don't have a means of testing drag and drop between
> processes/applications.

Ugh, yeah, ok.
Attached patch For checkinSplinter Review
Attachment #8621973 - Attachment is obsolete: true
Please make sure the attached patch includes commit information when requesting checkin.
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/0467588b07fe
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 41
Flags: qe-verify+
QA Contact: andrei.vaida
Reproduced the bug on Nightly 41.0a1 (2015-05-28) with e10s enabled, using the steps from Comment 0 & Comment 1.

This is verified fixed on Aurora 41.0a2 (2015-08-05) using Windows 10 x64 (10240), Ubuntu 14.04 (x86) and Mac OS X 10.9.5.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.