Closed Bug 1153586 Opened 5 years ago Closed 5 years ago

[Not e10s] Clicking <select> doesn't close the drop-down menu when it's open

Categories

(Core :: Layout: Form Controls, defect)

37 Branch
x86_64
Windows 7
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla40
Tracking Status
e10s - ---
firefox40 --- fixed

People

(Reporter: _+bugzilla, Assigned: mats)

References

()

Details

(Keywords: regression, testcase, Whiteboard: [STR at comment 3])

Attachments

(1 file, 1 obsolete file)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:37.0) Gecko/20100101 Firefox/37.0
Build ID: 20150402191859

Steps to reproduce:

Click on any dropdown list (combobox) on a web site to open it. Then click again on the header (not on the dropdown list) to close it again.


Actual results:

The popup remains open.


Expected results:

The popup should close again like it did in the past and does on other native controls on all platforms.
What is a "header" in this context? And can you please provide a specific example to reproduce this?
Which platforms did you test this on?
Flags: needinfo?(nospam)
You don't need to go far. The issue also happens here in Bugzilla and affects every <select> HTML element. Click on it to open it. Then click the exact same spot again to close it, but it won't close. I've tested with at least a dozen websites, I'm sure you'll find tons more.

The header is the part that's always visible. Not sure what it's officially called. The dropdown or popup is the part that only appears when the list is open. This thing should close when clicking on the header but it doesn't.

I've only tested this with Firefox on Windows 7, but I know that native combobox controls do close on Windows, and IIRC they also behave so on Linux and OS X.
Flags: needinfo?(nospam)
Steps to reproduce:
1. http://www.w3schools.com/html/tryit.asp?filename=tryhtml_elem_select
2. Click “Volvo”.
3. Click “Volvo”.

Actual results:
The drop-down menu quickly opens again, although it's already open.

Expected results:
The drop-down menu should close.


The issue doesn't occur in the latest Nightly with e10s enabled. It does occur when right-clicking the tab and choosing Open in new non-e10s window. It also occurs in Aurora, Beta and Release.

Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:40.0) Gecko/20100101 Firefox/40.0
Built from https://hg.mozilla.org/mozilla-central/rev/eb3a1c0262e4

Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:39.0) Gecko/20100101 Firefox/39.0
Built from https://hg.mozilla.org/releases/mozilla-aurora/rev/d0eda02ebe76

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0
Built from https://hg.mozilla.org/releases/mozilla-beta/rev/4526b85aa607

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:37.0) Gecko/20100101 Firefox/37.0
Built from https://hg.mozilla.org/releases/mozilla-release/rev/42b937b0039b
Status: UNCONFIRMED → NEW
Component: Untriaged → Layout: Form Controls
Ever confirmed: true
Keywords: testcase
Product: Firefox → Core
Summary: Dropdown list remains open when clicking again, should close again → [Not e10s] Clicking <select> doesn't close the drop-down menu when it's open
Whiteboard: [STR at comment 3]
Attached patch fix (obsolete) — Splinter Review
https://treeherder.mozilla.org/#/jobs?repo=try&revision=302adccdf3a9
Assignee: nobody → mats
Attachment #8593104 - Flags: review?(enndeakin)
Duplicate of this bug: 1156482
Attachment #8593104 - Flags: review?(enndeakin) → review+
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/11df38318e9c
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla40
Thank you for fixing this thing. I'm not familiar with how those fixes are actually used now. Will we have to wait until late August for this bug to go away in the public releases of Firefox? Or is there a chance that this can be used sooner, like with the next update that's released whenever that is? I'd just like to see this fixed before I get used to the permanent feeling that Firefox has it wrong.
QA Whiteboard: [good first verify]
Duplicate of this bug: 1186972
Depends on: 1194733
Depends on: 1197347
You need to log in before you can comment on or make changes to this bug.