Closed Bug 1153589 Opened 5 years ago Closed 5 years ago

Turn on containerless scrolling for root scroll frames on B2G

Categories

(Core :: Layout, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla41
Tracking Status
firefox41 --- fixed

People

(Reporter: kats, Unassigned)

References

Details

Attachments

(1 file)

Attached patch PatchSplinter Review
+++ This bug was initially created as a clone of Bug #1137890 +++

+++ This bug was initially created as a clone of Bug #1123921 +++

Try run in bug 1137890 shows that enabling containerless-root on B2G passes all tests. Local testing also showed no strange/broken behaviour, so I think we're good to turn it on.
Attachment #8591280 - Flags: review?(tnikkel)
Comment on attachment 8591280 [details] [diff] [review]
Patch

Ship it!
Attachment #8591280 - Flags: review?(tnikkel) → review+
Comment on attachment 8591280 [details] [diff] [review]
Patch

My bad, I tested this more and realized it does actually break behaviour in the browser for some pages (e.g. people.mozilla.com/~kgupta/grid.html) when zoomed.
Attachment #8591280 - Flags: review+ → review-
The clipping change from bug 1147038 does fix half of the problem I was seeing, but the scrollbars are still mispositioned. Hopefully fixing bug 1133905 will take care of this.
Depends on: 1147038, 1133905
Depends on: 1163259
Depends on: 1164767
Comment on attachment 8591280 [details] [diff] [review]
Patch

This should be good now.
Attachment #8591280 - Flags: review- → review+
https://hg.mozilla.org/mozilla-central/rev/b769ef24faed
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla41
This is causing a smoke test blocker. Please see bug 1166326. We may need this backed out.
QA Whiteboard: [QAnalyst-Triage+]
Whiteboard: [backout-asap]
Backed out in
https://hg.mozilla.org/integration/mozilla-inbound/rev/e7e537fd67ec

The sheriff assured me this would make the next nightly.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Whiteboard: [backout-asap]
https://hg.mozilla.org/mozilla-central/rev/4cb3a97de6ee
Status: REOPENED → RESOLVED
Closed: 5 years ago5 years ago
Resolution: --- → FIXED
This seems to cause the regression to youtube video app's video playback. When I scroll the youtube video app's list during video playback, video's rendering position is not correct.
(In reply to Sotaro Ikeda [:sotaro] from comment #12)
> This seems to cause the regression to youtube video app's video playback.
> When I scroll the youtube video app's list during video playback, video's
> rendering position is not correct.

I am going to check it by local back-out.
(In reply to Sotaro Ikeda [:sotaro] from comment #12)
> This seems to cause the regression to youtube video app's video playback.
> When I scroll the youtube video app's list during video playback, video's
> rendering position is not correct.

mstange said that bug 1148582 seems to fix it.
This is the "clip not moving with async scroll" issue. I haven't checked which patches in bug 1148582 will actually fix it, I just know that we're expecting that bug to take care of all our clipping problems.
(In reply to Sotaro Ikeda [:sotaro] from comment #13)
> (In reply to Sotaro Ikeda [:sotaro] from comment #12)
> > This seems to cause the regression to youtube video app's video playback.
> > When I scroll the youtube video app's list during video playback, video's
> > rendering position is not correct.
> 
> I am going to check it by local back-out.

The local back-out fixed the problem.
(In reply to Sotaro Ikeda [:sotaro] from comment #12)
> This seems to cause the regression to youtube video app's video playback.
> When I scroll the youtube video app's list during video playback, video's
> rendering position is not correct.

kats, is it expected regression until bug 1148582 fix?
Flags: needinfo?(bugmail.mozilla)
Redirecting to tn, since he's the one actually working on this.
Flags: needinfo?(bugmail.mozilla) → needinfo?(tnikkel)
The landing for this is causing a smoke test blocker. Please see bug 1170611. We may need this backed out.
Whiteboard: [backout-asap]
Backed out in
https://hg.mozilla.org/integration/mozilla-inbound/rev/e0515cb0cb5a
Status: RESOLVED → REOPENED
Flags: needinfo?(tnikkel)
Resolution: FIXED → ---
(In reply to Markus Stange [:mstange] from comment #15)
> This is the "clip not moving with async scroll" issue. I haven't checked
> which patches in bug 1148582 will actually fix it, I just know that we're
> expecting that bug to take care of all our clipping problems.

It doesn't appear to be related to bug 1148582. There is only one actively scrolling scrollframe involved, and only one set of metrics.
(In reply to Timothy Nikkel (:tn) from comment #21)
> There is only one actively
> scrolling scrollframe involved, and only one set of metrics.

But two clips: The video ImageLayer has its own overflow:hidden clip, and then there is the clip of the actively scrolling scrollframe - during scrolling, we want to move the overflow:hidden clip but not the clip that clips the video to the scrollframe.
Oh right, forgot about non-scrolling clips.
Depends on: 1170764
Whiteboard: [backout-asap]
Depends on: 1172310
https://hg.mozilla.org/mozilla-central/rev/dc07aa95d2c9
Status: REOPENED → RESOLVED
Closed: 5 years ago5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.