[BT APIv2] NFC can not be enabled in BT APIv2 build

RESOLVED WORKSFORME

Status

Firefox OS
Bluetooth
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: gasolin, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
In nightly build NFC works ok, But in BT APIv2 build

Open Settings > enable NFC 

The NFC state is keeping transparent and can't be toggled.
The status bar icon is not shown
Not sure how BT APIv2 build differs from regular master but this sounds similar to Bug 1143528 (which was caused by Bug 1109592). 

Thomas do you think this is a similar issue?
Flags: needinfo?(tzimmermann)
See Also: → bug 1143528
BTv2 is quite different from v1. So it might require additional changes to NFC.

Did NFC on BTv2 work before (e.g., last week), or did you just test this for the first time?
Flags: needinfo?(tzimmermann) → needinfo?(kmioduszewski)
Redirecting to Fred, since he's experiencing this issue. I don't have BTv2 build yet (not sure how to build it).

Fred could you respond to Thomas question from comment 2?
Flags: needinfo?(kmioduszewski) → needinfo?(gasolin)
Hi All,

I have flashed full image from latest PVT build, then replace gecko with the patch enabling BTv2 based on master.
NFC can be enable/disable through settings.

[1] https://pvtbuilds.mozilla.org/pvt/mozilla.org/b2gotoro/nightly/mozilla-central-flame-kk-eng/2015/04/2015-04-12-16-02-03/
(Reporter)

Comment 5

3 years ago
With jocelyn's latest PVT build and gecko with BTv2 patch, I can use NFC to share web url between devices.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(gasolin)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.