[Music] Playing a single song from the grid view and then hitting track-forward will sometimes encounter a second track with a 0 second timecode, unknown title but same album art.

VERIFIED DUPLICATE of bug 1148342

Status

defect
VERIFIED DUPLICATE of bug 1148342
4 years ago
4 years ago

People

(Reporter: jmitchell, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.1 unaffected, b2g-v2.2 affected, b2g-master verified)

Details

(Whiteboard: [3.0-Daily-Testing], )

Attachments

(1 attachment)

Reporter

Description

4 years ago
Description:
In the music app the initial screen is the 'grid view'. If you tap on a song it will begin to play. If there are multiple songs from the same album they will play back to back but if it is a single song (or when the album is over) it will cycle back to the grid view when this song is over. 
Sometimes hitting track forward will proceed to a play screen with the same album art, but the title will change to 'unknown', the track time will be 00:00 thru --:--, pause/play will have no effect, Star ratings can not be interacted with. Hitting track forward again will return to the grid view.

This does not occur when hitting track-forward on a song with multiple songs in its album. 

Repro Steps:
1) Update a Flame to 20150413010203
2) Launch Music
3) From the grid view play a song that does not have other songs in it's album (avoid 'Unknown' as those will group together in one album)
4) Hit track forward
5) Repeat launching a song and hitting track forward until bug repro's 


Actual:
app advances to unplayable track with same art but unknown title and 00:00 time


Expected:
app will advance back to the grid view



Environmental Variables:
Device: Flame 3.0 (KK - Nightly - Full Flash - 319mem)
Build ID: 20150413010203
Gaia: 3c68964cb9fdba7cf0f6829b7f44562acaf1f1d7
Gecko: 0a46652bd992
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0




Repro frequency: 7/10   
See attached: Logcat, video clip: http://youtu.be/0WN0-ZSnOyw
Reporter

Comment 1

4 years ago
This issue also reproduces in Flame KK 2.2

Device: Flame 2.2 (KK - Nightly - Full Flash - 319mem)
Build ID: 20150413002502
Gaia: cec00d643f517ffd96cde559cd3bbd43ab85816c
Gecko: 5005522fd68e
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

---------------------------------------------------------------------------------------

This issue does NOT reproduce in Flame KK 2.1

Actual results - hitting track forward on the single song will advance back to the grid view

Device: Flame 2.1 (KK - Nightly - Full Flash - 319mem)
Build ID: 20150413001204
Gaia: bbe983b4e8bebfec26b3726b79568a22d667223c
Gecko: a1b2434ad001
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 34.0 (2.1)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: regression
[Blocking Requested - why for this release]:
Functional regression of a core feature.

Requesting a window.
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
QA Contact: ychung
Unable to get a regression window as the repro rate drops down significantly to 1/30. I was able to reproduce this issue as early as the following build, but it was after over 30 attempts.

Environmental Variables:
Device: Flame 2.2
BuildID: 20150105162039
Gaia: 4ceeff19086b2a2955f044ad923dcfa63a293de3
Gecko: 72d7ae169b09
Version: 37.0a1 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Contact: ychung
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)

Updated

4 years ago
See Also: → 1150322
See Also: → 1149090
See Also: → 1148342
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1148342

Comment 5

4 years ago
Removing from nom. Dup of a 2.2 blocker.
blocking-b2g: 2.2? → ---
Reporter

Comment 6

4 years ago
Verified fixed by the patch in bug 1148342

Actual results: Hitting track forward moves the user back to the grid and does not encounter a second track of 00:00

Device: Flame 3.0 (KK - Nightly - Full Flash - 319mem)
Build ID: 20150424010200
Gaia: 0c5e2ee1173f3c53379ef3cd10de714836258fe8
Gecko: 22a157f7feb7
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.