Crash in Ringtone Settings while stability testing

RESOLVED WORKSFORME

Status

defect
--
critical
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: ggrisco, Unassigned)

Tracking

({crash})

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+)

Details

(Whiteboard: [b2g-crash][caf-crash 578][caf priority: p3][CR 821334], crash signature)

Attachments

(4 attachments)

Reporter

Description

4 years ago
Crash during stability test with following signature:

[@ mozilla::MediaStreamGraphImpl::AddBlockingRelatedStreamsToSet | mozilla::MediaStreamGraphImpl::AddBlockingRelatedStreamsToSet | mozilla::MediaStreamGraphImpl::RecomputeBlocking | mozilla::MediaStreamGraphImpl::UpdateGraph ]

Seems related to bug 1152439
Whiteboard: [CR 821334]
Whiteboard: [CR 821334] → [caf priority: p1][CR 821334]
Whiteboard: [caf priority: p1][CR 821334] → [b2g-crash][caf-crash 578][caf priority: p1][CR 821334]
Keywords: crash

Comment 6

4 years ago
Steven, could you help investigate this?
blocking-b2g: 2.2? → 2.2+
Flags: needinfo?(slee)

Comment 7

4 years ago
It looks like MSG accesses an invalid memory address. Greg, can you apply the following patch and see if it can catch some information? Thanks.

https://bug1150923.bugzilla.mozilla.org/attachment.cgi?id=8589477
Flags: needinfo?(slee) → needinfo?(ggrisco)
See Also: → 1150923
Reporter

Comment 8

4 years ago
(In reply to StevenLee[:slee] from comment #7)
> It looks like MSG accesses an invalid memory address. Greg, can you apply
> the following patch and see if it can catch some information? Thanks.
> 
> https://bug1150923.bugzilla.mozilla.org/attachment.cgi?id=8589477

Hi Steven, we have landed this patch already and it is built into AU 126 and later (you can see it listed under 'patches' in comment 3).  I didn't see the comment in the logs, but maybe that's because the message is logged well before the crash time.  I tried to look for full logs, but it doesn't looked like we collected it for this crash.  I've asked our tester to collect the full logs next time the crash is seen so we can see if it has the info you're looking for.
Flags: needinfo?(ggrisco)
Reporter

Comment 9

4 years ago
I'm still waiting for the issue to be reproduced by test team and will update this bug once logs become available.
Whiteboard: [b2g-crash][caf-crash 578][caf priority: p1][CR 821334] → [b2g-crash][caf-crash 578][caf priority: p3][CR 821334]
Reporter

Comment 10

4 years ago
There must have been a mystery fix, we are not seeing this since AU 126.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.