Closed Bug 1154215 Opened 5 years ago Closed 4 years ago

Marionette-webapi test fails due to "TimeoutException: Connection timed out"

Categories

(Firefox OS Graveyard :: Emulator, defect)

x86_64
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1207039

People

(Reporter: edgar, Assigned: edgar)

References

Details

https://treeherder.mozilla.org/logviewer.html#?job_id=6478398&repo=try

Snippet of the log with debugging enabled in devtools:
> 04-13 16:10:11.151 I/Gecko   (   44): 1428941411160	Marionette	DEBUG	conn162 -> ({"to":"0","sessionId":"{dd0804eb-1131-487c-85dc-7cdf52bde4ce}","name":"setScriptTimeout","parameters":{"ms":"60000"}})
> 04-13 16:10:11.171 I/Gecko   (   44): 1428941411174	Marionette	DEBUG	conn162 client <- ({"from":"0","ok":true})
> 04-13 16:10:11.181 I/GeckoDump(   44): DBG-SERVER: Writing JSON packet

// Connection timed out in client due to no response from server over 360s.

> 04-13 16:16:11.340 I/GeckoDump(   44): DBG-SERVER: Data available: 4096
> 04-13 16:16:11.350 I/GeckoDump(   44): DBG-SERVER: Creating a new packet from incoming
> 04-13 16:16:11.350 I/GeckoDump(   44): DBG-SERVER: Starting delimited read for : up to 200 bytes
> 04-13 16:16:11.350 I/GeckoDump(   44): DBG-SERVER: Header read: 7446:
> 04-13 16:16:11.360 I/GeckoDump(   44): DBG-SERVER: Found packet header successfully: 7446:
> 04-13 16:16:11.360 I/GeckoDump(   44): DBG-SERVER: Header matches JSON packet
> 04-13 16:16:11.370 I/GeckoDump(   44): DBG-SERVER: Existing packet incomplete, keep reading
> 04-13 16:16:11.370 I/GeckoDump(   44): DBG-SERVER: Reading JSON packet
> 04-13 16:16:11.370 I/GeckoDump(   44): DBG-SERVER: Reading JSON data: _l: 7446 dL: 0 sA: 7446
> 04-13 16:16:11.410 I/GeckoDump(   44): DBG-SERVER: Got: {
> 04-13 16:16:11.410 I/GeckoDump(   44):   "to": "0",
> 04-13 16:16:11.410 I/GeckoDump(   44):   "sessionId": "{dd0804eb-1131-487c-85dc-7cdf52bde4ce}",
> 04-13 16:16:11.410 I/GeckoDump(   44):   "name": "executeJSScript",
> 04-13 16:16:11.410 I/GeckoDump(   44):   "parameters": {
> 04-13 16:16:11.410 I/GeckoDump(   44):     "scriptTimeout": null,
> 04-13 16:16:11.410 I/GeckoDump(   44):     "specialPowers": true,
> 04-13 16:16:11.410 I/GeckoDump(   44):     "script": "/* Any copyright is dedicated to the Public Domain.\n * http://creativecommons.org/publicdomain/zero/1.0/ */\n\nMARIONETTE_TIMEOUT = 60000; ...

// Receiving "executeJSScript" message from client after client time out?

> 04-13 16:16:11.531 I/Gecko   (   44): 1428941771535	Marionette	INFO	Closed connection conn162
Looks like the message from client was blocked somewhere, same as bug 1153709.
See Also: → 1153709
I added more log in nsSocketTransport2.cpp trying to debug this, but I cannot reproduce this issue after applying the debug patch (over 130+ retriggers, https://treeherder.mozilla.org/#/jobs?repo=try&revision=74365e5cb51a&exclusion_profile=false). :(
Blocks: 1081529
Depends on: 1207039
Blocks: 1212262
I didn't see same issue (comment #0) any more with applying the fix patch of bug 1207039: https://treeherder.mozilla.org/#/jobs?repo=try&revision=8ccd09f7dfa4&exclusion_profile=false&group_state=expanded
Assignee: nobody → echen
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1207039
You need to log in before you can comment on or make changes to this bug.