Thunderbird fails because it opens too many files

RESOLVED DUPLICATE of bug 800279

Status

Thunderbird
Untriaged
RESOLVED DUPLICATE of bug 800279
3 years ago
3 years ago

People

(Reporter: Mitar, Unassigned)

Tracking

31 Branch
x86
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:37.0) Gecko/20100101 Firefox/37.0
Build ID: 20150402191859

Steps to reproduce:

It seems I have too many remote and local folders (around 20 GB of messages) and Thunderbird started having issues because default number of file handlers allowed per program on Mac OS X seems not to be enough.

My Mail directory contains 400 files/directories, my ImapMail directory contains 300 files/directories. (find . | wc -l)


Actual results:

I start Thunderbird and soon it starts throwing random errors that it cannot open various files. For example, the most common is that it cannot open the address book file.


Expected results:

It should work.

I know that it is the issue of file handlers because as I workaround I modified:

/Applications/Thunderbird.app/Contents/MacOS/thunderbird

To the following:

#!/bin/bash
ulimit -n 2048
exec /Applications/Thunderbird.app/Contents/MacOS/thunderbird-orig

And things work now (thunderbird-orig is the original thunderbird executable file).

I think Thunderbird should raise the file descriptor limit by itself, or it should not fail so badly when it reaches the limit. There is no clear message why is that happening. The issue is that it simply starts misbehaving. And one also gets scared that data is not being stored correctly.

Comment 1

3 years ago
Mitar, thanks for reporting this.  There are indeed known issues in this area.

Version 38 may have something which helps. Can you tell us please if using the beta from http://www.mozilla.org/en-US/thunderbird/channel/ helps with ulimit left to default (256 iirc) ?
Flags: needinfo?(mmitar)
(Reporter)

Comment 2

3 years ago
You are talking about bug 845952 work? Because this would also be great. Because I am hitting the 4 GB limit with few mailboxes and I already had to split them artificially up into multiple folders.
Flags: needinfo?(mmitar)
(Reporter)

Updated

3 years ago
Flags: needinfo?(mmitar)

Comment 3

3 years ago
(In reply to Mitar from comment #2)
> You are talking about bug 845952 [4GB] work? 

nope. nothing related to folder size.
Let's continue instead in your bug 800279
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(mmitar)
Resolution: --- → DUPLICATE
Duplicate of bug: 800279
(Reporter)

Comment 4

3 years ago
Oh, I already reported this one. :-) Thanks for finding it out.
You need to log in before you can comment on or make changes to this bug.