Closed Bug 1154346 Opened 7 years ago Closed 7 years ago

Account Manager tell: Invalid Account

Categories

(Thunderbird :: Account Manager, defect)

39 Branch
x86_64
Windows 8.1
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1152989

People

(Reporter: lussnig, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0
Build ID: 20150411030207

Steps to reproduce:

I use "39.0a2 (2015-04-12)" and try to edit my account settings "Option" -> "Account Settings"





Actual results:

I get for both SMTP folders and for "Local Account" the error "Invalid Account".
None is editable. But mail retrival and sending works fine.

From the Javascript Error Console:

Timestamp: 14.04.2015 18:29:37
Error: 	Error accessing account ***@***.net:
	[Exception... "Component returned failure code: 0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE) 
	[nsIJSCID.getService]"  nsresult: "0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE)"  
	location: "JS frame :: chrome://messenger/content/AccountManager.js :: at_build :: line 1568"  data: no]
	Source File: chrome://messenger/content/AccountManager.js
	Line: 1583



Expected results:

I expect to see the account settings and can edit them.
I did some updates and the problem still happen with "39.0a2 (2015-04-13)" and "39.0a2 (2015-04-14)".
Try with Help->restart with addons disabled.
Thanks it works now. It was an outdated enigmail plugin version.
So lets say it was my fault not to update it :-(
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
Thanks for pursuing the problem. On the other hand, we should not have shot down the whole account editing in the Account manager due to a problem with an extension. I solve that in bug 1152989.
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 1152989
You need to log in before you can comment on or make changes to this bug.