Intermittent cache-put.https.html | Cache.put called with simple Request and Response - promise_test: Unhandled rejection with value: object "[Exception... "File error: Is locked" nsresult: "0x80520..."

RESOLVED DUPLICATE of bug 1151974

Status

()

RESOLVED DUPLICATE of bug 1151974
4 years ago
4 years ago

People

(Reporter: RyanVM, Assigned: bkelly)

Tracking

({intermittent-failure})

Trunk
x86
Linux
intermittent-failure
Points:
---

Firefox Tracking Flags

(firefox40 affected)

Details

(Reporter)

Description

4 years ago
07:14:18 INFO - TEST-START | /service-workers/cache-storage/worker/cache-put.https.html
07:14:19 INFO - PROCESS | 2242 | WARNING: content window passed to PrivateBrowsingUtils.isWindowPrivate. Use isContentWindowPrivate instead (but only for frame scripts).
07:14:19 INFO - PROCESS | 2242 | pbu_isWindowPrivate@resource://gre/modules/PrivateBrowsingUtils.jsm:25:14
07:14:19 INFO - PROCESS | 2242 | nsBrowserAccess.prototype.openURI@chrome://browser/content/browser.js:15369:21
07:14:19 INFO - PROCESS | 2242 | __marionetteFunc@dummy file:19:30
07:14:19 INFO - PROCESS | 2242 | @dummy file:28:3
07:14:19 INFO - PROCESS | 2242 | executeWithCallback@chrome://marionette/content/listener.js:724:5
07:14:19 INFO - PROCESS | 2242 | executeAsyncScript@chrome://marionette/content/listener.js:617:3
07:14:20 INFO - TEST-UNEXPECTED-FAIL | /service-workers/cache-storage/worker/cache-put.https.html | Cache.put called with simple Request and Response - promise_test: Unhandled rejection with value: object "[Exception... "File error: Is locked" nsresult: "0x80520..."
07:14:20 INFO - cache_test@https://web-platform.test:8443/service-workers/cache-storage/resources/test-helpers.js:33:1
07:14:20 INFO - @https://web-platform.test:8443/service-workers/cache-storage/script-tests/cache-put.js:10:1
07:14:20 INFO - TEST-UNEXPECTED-FAIL | /service-workers/cache-storage/worker/cache-put.https.html | Cache.put called with Request and Response from fetch() - promise_test: Unhandled rejection with value: object "[Exception... "File error: Is locked" nsresult: "0x80520..."
07:14:20 INFO - cache_test@https://web-platform.test:8443/service-workers/cache-storage/resources/test-helpers.js:33:1
07:14:20 INFO - @https://web-platform.test:8443/service-workers/cache-storage/script-tests/cache-put.js:20:1
07:14:20 INFO - TEST-UNEXPECTED-FAIL | /service-workers/cache-storage/worker/cache-put.https.html | Cache.put with Request without a body - promise_test: Unhandled rejection with value: object "[Exception... "File error: Is locked" nsresult: "0x80520..."
07:14:20 INFO - cache_test@https://web-platform.test:8443/service-workers/cache-storage/resources/test-helpers.js:33:1
07:14:20 INFO - @https://web-platform.test:8443/service-workers/cache-storage/script-tests/cache-put.js:44:1
07:14:20 INFO - TEST-PASS | /service-workers/cache-storage/worker/cache-put.https.html | Cache.put with Response without a body
07:14:20 INFO - TEST-FAIL | /service-workers/cache-storage/worker/cache-put.https.html | Cache.put with Request containing a body - promise_test: Unhandled rejection with value: object "TypeError: Invalid request method POST."
07:14:20 INFO - cache_test@https://web-platform.test:8443/service-workers/cache-storage/resources/test-helpers.js:33:1
07:14:20 INFO - @https://web-platform.test:8443/service-workers/cache-storage/script-tests/cache-put.js:70:1
07:14:20 INFO - TEST-PASS | /service-workers/cache-storage/worker/cache-put.https.html | Cache.put with a Response containing an empty URL
07:14:20 INFO - TEST-PASS | /service-workers/cache-storage/worker/cache-put.https.html | Cache.put with an empty response body
07:14:20 INFO - TEST-PASS | /service-workers/cache-storage/worker/cache-put.https.html | Cache.put with HTTP 500 response
07:14:20 INFO - TEST-PASS | /service-workers/cache-storage/worker/cache-put.https.html | Cache.put called twice with matching Requests and different Responses
07:14:20 INFO - TEST-PASS | /service-workers/cache-storage/worker/cache-put.https.html | Cache.put called twice with request URLs that differ only by a fragment
07:14:20 INFO - TEST-PASS | /service-workers/cache-storage/worker/cache-put.https.html | Cache.put with request URLs containing embedded credentials
07:14:20 INFO - TEST-PASS | /service-workers/cache-storage/worker/cache-put.https.html | Cache.put with a string request
07:14:20 INFO - TEST-PASS | /service-workers/cache-storage/worker/cache-put.https.html | Cache.put with an invalid response
07:14:20 INFO - TEST-PASS | /service-workers/cache-storage/worker/cache-put.https.html | Cache.put with a non-HTTP/HTTPS request
07:14:20 INFO - TEST-PASS | /service-workers/cache-storage/worker/cache-put.https.html | Cache.put with a relative URL
07:14:20 INFO - TEST-PASS | /service-workers/cache-storage/worker/cache-put.https.html | Cache.put with a non-GET request
07:14:20 INFO - TEST-PASS | /service-workers/cache-storage/worker/cache-put.https.html | Cache.put with a null response
07:14:20 INFO - TEST-PASS | /service-workers/cache-storage/worker/cache-put.https.html | Cache.put with a used request body
07:14:20 INFO - TEST-FAIL | /service-workers/cache-storage/worker/cache-put.https.html | Cache.put with a used response body - assert_false: [https://fetch.spec.whatwg.org/#concept-body-consume-body] The text() method should not set "body passed" flag. expected false got true
07:14:20 INFO - @https://web-platform.test:8443/service-workers/cache-storage/script-tests/cache-put.js:316:1
07:14:20 INFO - Promise*@https://web-platform.test:8443/service-workers/cache-storage/script-tests/cache-put.js:315:12
07:14:20 INFO - Promise*create_temporary_cache@https://web-platform.test:8443/service-workers/cache-storage/resources/test-helpers.js:14:1
07:14:20 INFO - cache_test/<@https://web-platform.test:8443/service-workers/cache-storage/resources/test-helpers.js:34:14
07:14:20 INFO - Test.prototype.step@https://web-platform.test:8443/resources/testharness.js:1295:20
07:14:20 INFO - promise_test@https://web-platform.test:8443/resources/testharness.js:452:25
07:14:20 INFO - cache_test@https://web-platform.test:8443/service-workers/cache-storage/resources/test-helpers.js:33:1
07:14:20 INFO - @https://web-platform.test:8443/service-workers/cache-storage/script-tests/cache-put.js:310:1
07:14:20 INFO - TEST-OK | /service-workers/cache-storage/worker/cache-put.https.html | took 1935ms
Flags: needinfo?(ehsan)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Updated

4 years ago
Assignee: nobody → bkelly
Status: NEW → ASSIGNED
Flags: needinfo?(ehsan)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
I suspect this one has the same root cause as bug 1151974.  We are getting overlapping Context execution.
(Assignee)

Updated

4 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1151974
You need to log in before you can comment on or make changes to this bug.