Closed Bug 1154429 Opened 4 years ago Closed 4 years ago

[Window Management][Messages] Attachment and Send buttons are difficult to hit when keyboard is invoked

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.2+, b2g-v2.0 affected, b2g-v2.1 affected, b2g-v2.2 verified, b2g-master verified)

VERIFIED FIXED
2.2 S11 (1may)
blocking-b2g 2.2+
Tracking Status
b2g-v2.0 --- affected
b2g-v2.1 --- affected
b2g-v2.2 --- verified
b2g-master --- verified

People

(Reporter: pcheng, Assigned: etienne)

References

Details

(Keywords: regression, Whiteboard: [3.0-Daily-Testing])

Attachments

(1 file)

Description:
This seems to be a re-occurrence of bug 1063043. I flashed back to a central 9/17/2014 build and confirmed that the issue was indeed fixed at that time.

STR:
1) Open Messages and tap to create a new message
2) Tap message body field to put focus there
3) Tap on paper clip (attachment) icon

Expected: Attachment sources menu opens

Actual: After closer examination I found the detection area is closer to the message body field; if you tap over to the body field it will open the attachment menu as expected. If you tap anywhere close to the outer edge it will dismiss the keyboard or it just does nothing at all. The same goes for the Send button.

This is caused by the edge gesturing feature, which is mentioned in bug 1063043 as well. If I turn off the feature I no longer encounter this bug.

See video:
https://www.youtube.com/watch?v=Pqg9Gqr3QMQ

Note: At the time of the video I wasn't aware of the edge gesturing feature causing issue so all my attempts were fail attempts.

Device: Flame 3.0 Master (full flashed 319MB mem)
BuildID: 20150414072436
Gaia: c8cb0c0ebb8dd1f5c0c9037e38f8e4b237beb77b
Gecko: 388f5861dc7d
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0 Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0
This issue also occurs on all branches.

Device: Flame 2.2
BuildID: 20150414002504
Gaia: 73645b097720f3ca594a14d288b87d3885d7fc9d
Gecko: 85ea1be9ac7d
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Device: Flame 2.1
BuildID: 20150414001210
Gaia: bbe983b4e8bebfec26b3726b79568a22d667223c
Gecko: 3e3cbe35bce3
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 34.0 (2.1) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Device: Flame 2.0
BuildID: 20150414000204
Gaia: 84898cadf28b1a1fcd03b726cff658de470282f0
Gecko: de92ad41847a
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 32.0 (2.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

----

Marking regression in Central(2.2) because I confirmed it was fixed at the time bug 1063043 was fixed.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regression
Whiteboard: [3.0-Daily-Testing]
Eric, can you take a look at this please?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(echang)
Keywords: regression
Legacy issue, but user experience is not good, suggest to fix or backlog. Ni RD.
Flags: needinfo?(echang) → needinfo?(schung)
From description Pi Wei mentioned it's still reproducible when edge gesture is on, and it seems still affected by edge swip feature per my testing. Hi Etienne, not sure if patch for Bug 1063043 should solve this issue already, or it's still have some room for improvement, could you please provide some comment about this? Thanks!
Flags: needinfo?(schung) → needinfo?(etienne)
Looks like this a a regression from bug 1112524 :/
Sending a patch.
Assignee: nobody → etienne
Flags: needinfo?(etienne)
Blocks: 1112524
Comment on attachment 8593933 [details] [review]
[gaia] etiennesegonzac:bug-1154429 > mozilla-b2g:master

embarrassing :/
Attachment #8593933 - Flags: review?(alive)
This is a regression from bug 1112524 that was uplifted to 2.2, we should probably get this one too.
blocking-b2g: --- → 2.2?
blocking-b2g: 2.2? → 2.2+
Keywords: regression
Comment on attachment 8593933 [details] [review]
[gaia] etiennesegonzac:bug-1154429 > mozilla-b2g:master

I love simple patch
Attachment #8593933 - Flags: review?(alive) → review+
Keywords: checkin-needed
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Comment on attachment 8593933 [details] [review]
[gaia] etiennesegonzac:bug-1154429 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): bug 1112524
[User impact] if declined: button at the edges of the screen won't work properly
[Testing completed]: edge gestures + STR from this bug + STR from bug 1112524
[Risk to taking this patch] (and alternatives if risky): low
[String changes made]: none
Attachment #8593933 - Flags: approval-gaia-v2.2?
Attachment #8593933 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
This issue is verified fixed on the latest Nightly Flame 3.0 and 2.2 builds.

Actual Results: The user can user the attatchment and send buttons easily when the keyboard is active.

Environmental Variables:
Device: Flame 3.0
BuildID: 20150423010203
Gaia: 9d4f756aa35cb7f030a92f3c1f65fb55254ddd1d
Gecko: 0b202671c9e2
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Environmental Variables:
Device: Flame 2.2
BuildID: 20150423002502
Gaia: b838d0e7c163e66660dcb6e387d8339944a7a30e
Gecko: 8dce56574f28
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.