send button doesn't work when keyboard is open

RESOLVED FIXED

Status

Firefox OS
Gaia::System::Window Mgmt
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: dietrich, Assigned: etienne)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Flame, nightly, Sept 4

This happens to me constantly and drives me crazy.

STR:

1. type a text message
2. hit send button

Expected: message is sent, keyboard hides

Actual: keyboard hides. message is not sent. have to hit send button *again* to send.
Hey Dietrich,

Thanks for reporting this! I have just two quick questions for you:

1. What area of send button do you usually use to send? Center, top/bottom left, top/bottom right and etc.

2. Does it work better for you if you turn off "Edge swipe navigation" in Settings?

Thanks!
Flags: needinfo?(dietrich)
(Reporter)

Comment 2

3 years ago
(In reply to Oleg Zasypkin [:azasypkin] from comment #1)
> 1. What area of send button do you usually use to send? Center, top/bottom
> left, top/bottom right and etc.

Heh, it's a *tiny* space. I don't know, and it should Just Work™.

> 2. Does it work better for you if you turn off "Edge swipe navigation" in
> Settings?

I'll try to survive with this turned off for a while ;)
Flags: needinfo?(dietrich)
(In reply to Dietrich Ayala (:dietrich) from comment #2)
> (In reply to Oleg Zasypkin [:azasypkin] from comment #1)
> > 2. Does it work better for you if you turn off "Edge swipe navigation" in
> > Settings?
> 
> I'll try to survive with this turned off for a while ;)

Thanks! Please let me know if it makes a difference. I see that tapping on the areas near the app window edges stopped working correctly after bug 1011087. Just want to be sure that it's your case :)
Created attachment 8486254 [details]
GitHub brach URL (fluff app)

In the meantime, let's ask Etienne if we can do anything here...

Etienne, looks like after patch for bug 1011087 we started to observe strange behaviour in SMS app - when keyboard is open and user taps on send\attach button (tap area is close to window edges) then keyboard is closed, but click isn't fired on the target buttons. Please see Fluff demo app in the attachment with simple app that demonstrates the issue (just tap on input to show keyboard and then tap on button to see click target).

If simplify, basically we see the following:

Case #1:
------------------------------
|           RED              |
|                            |
|                            |
|        CONTAINER           |
|----------------------------|
|*  BUTTON |INPUT|  BUTTON  *|
------------------------------

Case #2 (keyboard is shown):
------------------------------
|           RED              |
|                            |
|        CONTAINER           |
|----------------------------|
|*  BUTTON |INPUT|  BUTTON  *|
|-----------------------------
|         KEYBOARD           |
------------------------------

If we tap on buttons eg. in the middle for both cases click target is actual _BUTTON_ (we're listening for "click" event on body and analyze "e.target"). But if we tap on buttons in "*" areas then in Case #1 click target is actual _BUTTON_, but in Case #2 click target is _RED CONTAINER_. I suspect that tap on "*" areas is recognized as attempt to swipe from edges, but _RED CONTAINER_ as click target in this case is more than strange :)

Could you please help to understand\resolve this?

Thanks!
Flags: needinfo?(etienne)
(Assignee)

Comment 5

3 years ago
The touch events "captured then forwarded" by the edge swipe zone are delayed a bit, and we're being raced by the resize of the app window. By the time they reach the app the button isn't here anymore :)

So definitely an edge_swipe_detector bug, but definitely fixable since we're being a little bit too quick to dismiss the keyboard.

Will upload a patch today.
Thanks again for the best edge swipe bug report ever :)
Assignee: nobody → etienne
Component: Gaia::SMS → Gaia::System::Window Mgmt
Flags: needinfo?(etienne)
(Assignee)

Comment 6

3 years ago
Created attachment 8487194 [details] [review]
Gaia PR
Attachment #8487194 - Flags: review?(21)
Comment on attachment 8487194 [details] [review]
Gaia PR

nit: there is an extra line break
Attachment #8487194 - Flags: review?(21) → review+
(In reply to Etienne Segonzac (:etienne) from comment #5)
> The touch events "captured then forwarded" by the edge swipe zone are
> delayed a bit, and we're being raced by the resize of the app window. By the
> time they reach the app the button isn't here anymore :)
> 
> So definitely an edge_swipe_detector bug, but definitely fixable since we're
> being a little bit too quick to dismiss the keyboard.
> 
> Will upload a patch today.
> Thanks again for the best edge swipe bug report ever :)

Thanks for the explanation and quick fix! :)
(Assignee)

Comment 9

3 years ago
https://github.com/mozilla-b2g/gaia/commit/77381099e5e5e180e480a9684f921e2f1b06bcf8
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Reporter)

Comment 10

3 years ago
<3 <3 <3
Duplicate of this bug: 1097539
You need to log in before you can comment on or make changes to this bug.