[Camera] Crash while stability testing, maybe in camera

RESOLVED DUPLICATE of bug 1152407

Status

()

defect
--
major
RESOLVED DUPLICATE of bug 1152407
4 years ago
4 months ago

People

(Reporter: ggrisco, Unassigned)

Tracking

({crash})

unspecified
ARM
Gonk (Firefox OS)
Points:
---

Firefox Tracking Flags

(blocking-b2g:2.2+)

Details

(Whiteboard: [b2g-crash][caf-crash 475][caf priority: p1][CR 822154], crash signature)

Attachments

(10 attachments)

Reporter

Description

4 years ago
Saw the folloowing crash signature while running stability test:

[@ xpcObjectHelper::xpcObjectHelper | mozilla::dom::WrapNativeISupportsParent | mozilla::dom::PromiseBinding::Wrap | mozilla::dom::quota::QuotaManager::AbortCloseStoragesForProcess ]

From the logs, looks like camera was being used at time of crash.  cafbot will upload the logs.
Whiteboard: [CR 822154]
Whiteboard: [CR 822154] → [caf priority: p1][CR 822154]
Whiteboard: [caf priority: p1][CR 822154] → [b2g-crash][caf-crash 475][caf priority: p1][CR 822154]
Keywords: crash
Looks like this starts here:
http://mxr.mozilla.org/mozilla-b2g37_v2_2/source/dom/quota/QuotaManager.cpp#1767

It looks like that particular line has been in the tree for a while. Dave, do you know anything about the QuotaManager? Any idea what might be going on here?
Flags: needinfo?(dhylands)
blocking-b2g: 2.2? → 2.2+

Comment 8

4 years ago
Hi! Becker,

Please also help to take a look. Thanks

--
Keven
Flags: needinfo?(behsieh)

Updated

4 years ago
See Also: → 1152407

Updated

4 years ago
Component: Gaia::Camera → Stability
Summary: Crash while stability testing, maybe in camera → [Camera] Crash while stability testing, maybe in camera
I'm not familiar with the QuotaManager, but it looks like ContentParent::ShutDownProcess calls it explicitly:

https://dxr.mozilla.org/mozilla-central/source/dom/ipc/ContentParent.cpp#1636

Because this is failing during a stability test, I'm going to guess that there is some type of race happening where the quota manage is trying to close a storage that hasn't been completely opened or something like that.
Flags: needinfo?(dhylands)
I can not comment whether it was relative to camera from such limited information.
in current log from attached,I didn't see any camera error.
is this easy to reproduce.?
is it possible we can set environment here to reproduce this issue?
Flags: needinfo?(behsieh)
is this easy to reproduce.?
is it possible we can set environment here to reproduce this issue?
Flags: needinfo?(ggrisco)
Reporter

Comment 12

4 years ago
(In reply to becker hsieh{:behsieh} from comment #11)
> is this easy to reproduce.?
> is it possible we can set environment here to reproduce this issue?

This crash was found with monkey test and has only been seen once or twice so far, so it seems difficult to reproduce.
Flags: needinfo?(ggrisco)
is it possible we could set the same environment with you to reproduce this issue?
Flags: needinfo?(ggrisco)
Reporter

Comment 14

4 years ago
To reproduce the environment you would need to setup some monkey test and run overnight/weekend.  So far we've only seen this crash on AU 129 (it did not reproduce on AU 132).  Maybe if it reproduces on next build we'll have more information to go on.
Flags: needinfo?(ggrisco)

Comment 18

4 years ago
Jan,

Is this issue due to the same root cause as bug 1152407?

Thanks,
Mike
Flags: needinfo?(Jan.Varga)
Reporter

Comment 25

4 years ago
This has become one of the top hitters affecting mtbf stability numbers.
Flags: needinfo?(mlee)

Comment 26

4 years ago
Jan,
Please confirm if this issue has the same root cause and solution as bug 1152407. If so can we mark this as a duplicate of it?

Andrew,
If this issue has a different root cause than bug 1152407 which Jan is working on, please have someone else on the DOM team look into this.


As you can see from CAF's (Greg) comment 25, this issue is significantly impacting reaching fxOS 2.2 MTBF goals.


Thanks!
Mike
Component: Stability → DOM
Flags: needinfo?(mlee) → needinfo?(overholt)
Product: Firefox OS → Core
I think it's the same root cause.
Flags: needinfo?(Jan.Varga)

Comment 28

4 years ago
Thanks Jan. Marking as a duplicate of bug 1152407 per comment 27.
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(overholt)
Resolution: --- → DUPLICATE
Duplicate of bug: 1152407
No longer blocks: CAF-v2.2-metabug
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.