On Desktop, only enable APZ for E10S windows

RESOLVED FIXED in Firefox 40

Status

()

Core
Panning and Zooming
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: dvander, Assigned: kats)

Tracking

unspecified
mozilla40
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(e10s-, firefox40 fixed)

Details

Attachments

(2 attachments, 1 obsolete attachment)

None of the Desktop platforms receive input off the main thread, so they effectively require E10S. That may change for some platforms, but not right now.

Updated

3 years ago
tracking-e10s: --- → -
Try run: https://treeherder.mozilla.org/#/jobs?repo=try&revision=e944fc5e8702

If this sticks I'll follow up with a backout after the next m-c merge.
(And do a m.d.platform post)
Blocks: 1086162
No longer blocks: 1154459
No longer blocks: 1086162
Blocks: 1157746
Blocks: 1143856
Assignee: dvander → bugmail.mozilla
Summary: On Desktop, only enable APZ for E10S → On Desktop, only enable APZ for E10S windows
Created attachment 8596761 [details] [diff] [review]
Part 1 - Rename a flag
Created attachment 8596764 [details] [diff] [review]
Part 2 - Disable APZ on non-e10s windows

I need to test these patches on all platforms still.
Created attachment 8597256 [details] [diff] [review]
Part 2 - Disable APZ on non-e10s windows on desktop
Attachment #8596764 - Attachment is obsolete: true
Attachment #8597256 - Flags: review?(mstange)
Attachment #8597256 - Flags: review?(dvander)
Attachment #8596761 - Flags: review?(wmccloskey)
I tested this on OSX, Linux, and Windows, with e10s enabled and disabled by default, using "open new e10s window" and "open new non-e10s window". Works as intended (i.e. APZ enabled in all e10s windows but not otherwise).
Attachment #8597256 - Flags: review?(dvander) → review+
Attachment #8597256 - Flags: review?(mstange) → review+
Comparing the dxr search results of "electrolysis" and "e10s" seems to indicate that e10s is the preferred name.
I'm always unsure how to camelcase e10s :)
Comment hidden (offtopic)

Updated

3 years ago
Depends on: 1158470
No longer depends on: 1158470
Comment on attachment 8596761 [details] [diff] [review]
Part 1 - Rename a flag

Review of attachment 8596761 [details] [diff] [review]:
-----------------------------------------------------------------

Let's call it mMultiProcessWindow. We use gMultiProcessBrowser for similar things in the frontend. Also, I don't like to use codenames in source code.
Attachment #8596761 - Flags: review?(wmccloskey) → review+
https://hg.mozilla.org/mozilla-central/rev/666f287e0dab
https://hg.mozilla.org/mozilla-central/rev/91110ad64d32
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-firefox40: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla40

Comment 14

3 years ago
I am really doubt about decision of this bug.
Why it was needed? As result we have bug 1162009.

Updated

3 years ago
Blocks: 1162009
No longer blocks: 1162009
Depends on: 1162179
You need to log in before you can comment on or make changes to this bug.