[Flame][Dialer]"No network connection" will pop up after user executes an offline code.

VERIFIED FIXED

Status

VERIFIED FIXED
4 years ago
3 years ago

People

(Reporter: xiongfuchao, Assigned: gsvelto)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.5+, b2g-v2.2 affected, b2g-master verified)

Details

Attachments

(4 attachments)

(Reporter)

Description

4 years ago
Created attachment 8593267 [details]
video_1623.mp4

[1.Description]:
[Flame][v2.2 & v3.0][Dialer]After user MO a call without network and then executes an offline command, "No network connection" will pop up.
Found time:16:23
See attachment:logcat_1623.txt & video_1623.mp4

[2.Testing Steps]: 
Prerequisite:Device without a SIM card.
1.Open dialer.
2.MO a call.
3.Input found contacts command such as "123#".

[3.Expected Result]: 
3.Notifacation "Confirmation title" should appear.

[4.Actual Result]: 
3.Notifacation "No network connection" appears.

[5.Reproduction build]: 
Flame 2.2 version(Affected):
Build ID               20150415162504
Gaia Revision          89a94a8b9c9087da916751697a61ba15bc0688c3
Gaia Date              2015-04-15 20:05:38
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/20e92b626530
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150415.201243
Firmware Date          Wed Apr 15 20:12:52 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0 version(Affected):
Build ID               20150415160205
Gaia Revision          777d01f4a2c7b41c4b02e3cf87715714ccc0590b
Gaia Date              2015-04-15 17:20:09
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/53ceefb0e1c8
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150415.192055
Firmware Date          Wed Apr 15 19:21:04 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test

[8.Note]:
If user not do step 2 ,notifacation is "Confirmation title"
(Reporter)

Comment 1

4 years ago
Created attachment 8593271 [details]
logcat_1623.txt
(Reporter)

Updated

4 years ago
status-b2g-v2.2: --- → affected
status-b2g-master: --- → affected
See Also: → bug 1061130
Issue 1. No SIM inserted, Enter 1#, popup of "confirmation title" appears; String looks weird for user.
Issue 2. No SIM inserted, Enter a number and tap 'Dial', "no network connection" appears, then enter 1#, popup of "no network connection" appears, the message is not consistent with issue 1.
NI EPM Wesley.
Flags: needinfo?(whuang)
These issues happen in the case w/o sim card inserted. 
It doesn't actually break functionality but the message isn't clear enough.
Proposing to backlog it. 
NI to Carrie for clarifying expected behavior.
tracking-b2g: --- → backlog
Flags: needinfo?(whuang) → needinfo?(cawang)
If the SIM is not inserted, we display the string "No network connection" is the expected behavior? I don't really understand the special case here. Does it mean if user insert a contact command, he can dial offline? Thanks.
Flags: needinfo?(cawang) → needinfo?(echang)
Sorry for a mistake in comment 4. It should be "If the SIM is not inserted, we display the string "No network connection" is the expected behavior."
I think we should we should display the same message for both cases, for me, the issue 1 might be a empty string issue, "Confirmation title" looks meaningless for user.
Flags: needinfo?(echang) → needinfo?(cawang)
Hi Eric, 

If there is no SIM inserted, can we search a contact with the code? If not, then I agree that we should just display the string "No network connection". If yes, then we can directly display the result. 
Thanks!
Flags: needinfo?(cawang) → needinfo?(echang)
The 1# is used for locating contact in SIM, maybe the "No network connection" is the way to go.
Flags: needinfo?(echang)
Comms triage: A user shouldn't see the default message. We need to fix this issue before the next release.
blocking-b2g: --- → 3.0+
tracking-b2g: backlog → ---
(Assignee)

Comment 10

3 years ago
OK, this is not the right scenario for displaying the "No network connection" string because 123# is not a number but a short dialing code so it should fail only if the SIM card is absent but is unaffected by the state of the network. I'll post a patch that displays the correct message (no SIM card is present) in this particular scenario.
Assignee: nobody → gsvelto
Status: NEW → ASSIGNED
Created attachment 8651747 [details] [review]
[gaia] gabrielesvelto:bug-1155104-fix-speed-dial-no-sim > mozilla-b2g:master
(Assignee)

Comment 12

3 years ago
Comment on attachment 8651747 [details] [review]
[gaia] gabrielesvelto:bug-1155104-fix-speed-dial-no-sim > mozilla-b2g:master

When no SIM is present getIccById returns null, so I'm detecting that, rejecting the promise and showing a sensible error message. I've added a unit-test to cover this case.
Attachment #8651747 - Flags: review?(drs)
Comment on attachment 8651747 [details] [review]
[gaia] gabrielesvelto:bug-1155104-fix-speed-dial-no-sim > mozilla-b2g:master

This adds additional divergence to the work in bug 1081161, so we should note that there. Otherwise, looks good! I'm liking the new (correct) style of unit testing that you're doing, too.
Attachment #8651747 - Flags: review?(drs) → review+
(Assignee)

Comment 14

3 years ago
(In reply to Doug Sherk (:drs) from comment #13)
> This adds additional divergence to the work in bug 1081161, so we should
> note that there. Otherwise, looks good! I'm liking the new (correct) style
> of unit testing that you're doing, too.

Thanks for the review! About bug 1081161, we might want to re-evaluate post 2.5 what to do with it in the light of a new potential direction. I've spent some time in Whistler speaking with Etienne and other people from the system app (where the callscreen effectively lives, and where the emergency call app used to live) and we've come to the conclusion that all the reasons why those apps were split have gone away and it might actually make more sense to bring them back together, possibly after the dialer/contacts split. Still there's a lot more studying to do before moving in that direction.
(Assignee)

Comment 15

3 years ago
I see tons of orange in the try-run, will re-trigger it before merging.
(Assignee)

Comment 16

3 years ago
OK, I must have re-triggered the try run 10 times but I still get orange here and there; I can't seem to be able to get a green run and I really don't want to land w/o it.
(Assignee)

Comment 17

3 years ago
Merged to gaia/master b0a2e884a7fe5836cb0180757e44d79e53060f2b

https://github.com/mozilla-b2g/gaia/commit/b0a2e884a7fe5836cb0180757e44d79e53060f2b
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-b2g-master: affected → fixed
Resolution: --- → FIXED
This bug has been verified as "pass" on the latest build of Arise KK v2.5&Flame KK v2.5 by the STR in comment 0.
 
Actual results: Notification "No SIM card to load contacts from" always appears after inputting found contacts command such as "123#" without SIM card.

See attachment: Verified_Flame_KK_v2.5.3gp

Reproduce rate: 0/10

Device: Flame KK v2.5(Pass)
Build ID               20150929150202
Gaia Revision          f345f6a015709beeb2ca3955cab077fcaa959d3b
Gaia Date              2015-09-29 03:53:51
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/ccee6614fd9d18a31f263fbcfe9676b224d851aa
Gecko Version          44.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150929.201052
Firmware Date          Tue Sep 29 20:11:01 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK v2.5(Pass)
Build ID               20150930005445
Gaia Revision          1bc0b19527777ffee494962b48db4be857b07d64
Gaia Date              2015-09-29 20:01:07
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/891ee0d0ba3ec42b6484cf0205b3c95e21c58f74
Gecko Version          44.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150930.001258
Firmware Date          Wed Sep 30 00:13:06 UTC 2015
Bootloader             s1
Status: RESOLVED → VERIFIED
QA Whiteboard: [MGSEI-Triage+]
status-b2g-master: fixed → verified
Created attachment 8667744 [details]
Verified_Flame_KK_v2.5.3gp
You need to log in before you can comment on or make changes to this bug.