Closed Bug 1155106 Opened 5 years ago Closed 4 years ago

[Message]When you are editing mesage, if we long press the screen, tool bar won't appear and cursor will jump to another line .

Categories

(Core :: DOM: Selection, defect, P4)

ARM
Gonk (Firefox OS)
defect

Tracking

()

RESOLVED WONTFIX
Tracking Status
b2g-v2.2 --- affected
b2g-master --- affected

People

(Reporter: yi.zou, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [v2.2-nexus-5-l])

Attachments

(2 files)

Attached video 1700.mp4
[1.Description]:
[Nexus5 2.2&3.0][Flame 2.2&3.0][Message] Launch message app and input words in the first line. Then tap Enter and jump to another line. Long press the screen , you will find that cursor will jump to another line and tool bar won't appear.
Time:17:00
See attachment logcat_1700.txt and 1700.mp4

[2.Testing Steps]: 
1.Launch message app.
2.Input words in the first line.
3.Tap Enter and jump to another line.
4.Long press the screen .

[3.Expected Result]: 
4.Cursor will not jump to another line and tool bar will appear.

[4.Actual Result]: 
4.Cursor will jump to another line and tool bar won't appear.

[5.Reproduction build]: 
Flame 2.2 version(Affected):
Build ID               20150415162504
Gaia Revision          89a94a8b9c9087da916751697a61ba15bc0688c3
Gaia Date              2015-04-15 20:05:38
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/20e92b626530
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150415.201243
Firmware Date          Wed Apr 15 20:12:52 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0 version(Affected):
Build ID               20150415160205
Gaia Revision          777d01f4a2c7b41c4b02e3cf87715714ccc0590b
Gaia Date              2015-04-15 17:20:09
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/53ceefb0e1c8
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150415.192055
Firmware Date          Wed Apr 15 19:21:04 EDT 2015
Bootloader             L1TC000118D0

N5 2.2 version(Affected):
Build ID               20150415162504
Gaia Revision          89a94a8b9c9087da916751697a61ba15bc0688c3
Gaia Date              2015-04-15 20:05:38
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/20e92b626530
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150415.200855
Firmware Date          Wed Apr 15 20:09:09 EDT 2015
Bootloader             HHZ12f

N5 3.0 version(Affected):
Build ID               20150415160205
Gaia Revision          777d01f4a2c7b41c4b02e3cf87715714ccc0590b
Gaia Date              2015-04-15 17:20:09
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/53ceefb0e1c8
Gecko Version          40.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150415.192113
Firmware Date          Wed Apr 15 19:21:33 EDT 2015
Bootloader             HHZ12f

[6.Reproduction Frequency]: 
Always Recurrence,10/10

[7.TCID]: 
Free Test
Attached file logcat_1700.txt
Hi George, it looks like the selection could not select anything properly on the empty new line. Is that a expected behavior for text selection?
Flags: needinfo?(gduan)
Sorry, I have no idea about this.

Hi Omega, can you check if it's expected ? https://bugzilla.mozilla.org/attachment.cgi?id=8593270
Flags: needinfo?(gduan) → needinfo?(ofeng)
The utility bubble should show up, @Peter, could you help on this?
Flags: needinfo?(ofeng) → needinfo?(pchang)
Actually gecko did select the frame(the scroll frame inside message editing field) but with collapsed flag, therefore, the utility bubble didn't show up. There may be some space to improve the selectword logic but it's risk in current time frame to make this change.


I/PRLog   ( 2354): -1225096876[b424a080]: SelectionCarets (b2c913d0): HandleEvent:276 : SelectWord from NS_MOUSE_MOZLONGTAP
I/PRLog   ( 2354): -1225096876[b424a080]: SelectionCarets (b2c913d0): SelectWord:642 : Frame=HTMLScroll(div)(1)@b1d2a410, ptInFrame=(180, 7880)
Flags: needinfo?(pchang)
Component: Gaia::SMS → Selection
Product: Firefox OS → Core
howie, how do you think in comment 5?
Flags: needinfo?(hochang)
only happens in empty new line, let's improve it in the next release
Flags: needinfo?(hochang)
Priority: -- → P4
Blocks: AccessibleCaret
No longer blocks: CopyPasteLegacy
Duplicate of this bug: 1236002
I don't see the possibility to polish this behavior for Gaia anymore.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.