Always getting signed out when accessing google+ from e10s window

RESOLVED DUPLICATE of bug 1123756

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 1123756
3 years ago
3 years ago

People

(Reporter: anaran, Unassigned)

Tracking

(Blocks: 1 bug)

40 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:40.0) Gecko/20100101 Firefox/40.0
Build ID: 20150416030209

Steps to reproduce:

Access Google+, e.g. via
https://plus.google.com/u/0/?tab=cX


Actual results:

Signed out
You were signed out of Google. Please sign back in to continue.

I always get signed out immediately after signin.



Expected results:

I can access Google+ fine from non-e10s windows and would like the same for e10s.
(Reporter)

Comment 1

3 years ago
I can't seem to find a way to set component correctly for e10s.
What am I missing?
Component: Untriaged → WinQual Reports
Blocks: 653064
Component: WinQual Reports → General
Adrian,

please attach your about:support

Also , try to test under e10s with all of your addons disabled
Flags: needinfo?(adrian.aichner)
(Reporter)

Comment 3

3 years ago
(In reply to [:tracy] Tracy Walker - QA Mentor from comment #2)
> Adrian,
> 
> please attach your about:support
> 
> Also , try to test under e10s with all of your addons disabled

This was pretty inconvenient.

First I started with add-ons disabled, e10s was also off, even thought it shows check in Options.

Second time I also chose [Refresh Nightly], took a long time (minutes), then was not able to restore tabs (embarrasing in its own words).

In that Instance of Firefox e10s is on, only two add-ons are installed and both off.

I do not get signed out when I visit
https://plus.google.com

Here, finally, is about:support:

Application Basics
------------------

Name: Firefox
Version: 40.0a1
Build ID: 20150421030209
Update Channel: nightly
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:40.0) Gecko/20100101 Firefox/40.0
Multiprocess Windows: 1/1 (default: true)

Crash Reports for the Last 3 Days
---------------------------------

Report ID: bp-d0680152-84bc-405e-b516-275442150419
Submitted: 2 days ago

All Crash Reports (including 4 pending crashes in the given time range)

Extensions
----------

Name: McAfee Security Scan Plus
Version: 1.0
Enabled: false
ID: {e4f94d1e-2f53-401e-8885-681602c0ddd8}

Name: Microsoft .NET Framework Assistant
Version: 0.0.0
Enabled: false
ID: {20a82645-c095-46ed-80e3-08825760534b}

Graphics
--------

Adapter Description: NVIDIA Quadro NVS 140M
Adapter Drivers: nv4_disp
Adapter RAM: Unknown
Asynchronous Pan/Zoom: none
Device ID: 0x0429
DirectWrite Enabled: false (0.0.0.0)
Driver Date: 1-7-2011
Driver Version: 6.14.12.6658
GPU #2 Active: false
GPU Accelerated Windows: 1/1 Direct3D 9 (OMTC)
Subsys ID: 01fe1028
Vendor ID: 0x10de
WebGL Renderer: Google Inc. -- ANGLE (NVIDIA Quadro NVS 140M Direct3D9 vs_3_0 ps_3_0)
windowLayerManagerRemote: true
AzureCanvasBackend: skia
AzureContentBackend: cairo
AzureFallbackCanvasBackend: cairo
AzureSkiaAccelerated: 0

Important Modified Preferences
------------------------------

browser.cache.disk.capacity: 358400
browser.cache.disk.filesystem_reported: 1
browser.cache.disk.smart_size.first_run: false
browser.cache.frecency_experiment: 4
browser.download.importedFromSqlite: true
browser.places.smartBookmarksVersion: 7
browser.sessionstore.upgradeBackup.latestBuildID: 20150421030209
browser.startup.homepage_override.buildID: 20150421030209
browser.startup.homepage_override.mstone: 40.0a1
dom.apps.reset-permissions: true
dom.mozApps.used: true
extensions.lastAppVersion: 40.0a1
media.gmp-gmpopenh264.lastUpdate: 1429646728
media.gmp-gmpopenh264.version: 1.3
media.gmp-manager.buildID: 20150421030209
media.gmp-manager.lastCheck: 1429646726
network.cookie.prefsMigrated: true
network.predictor.cleaned-up: true
places.history.expiration.transient_current_max_pages: 93898
plugin.disable_full_page_plugin_for_types: application/pdf
privacy.sanitize.migrateFx3Prefs: true

Important Locked Preferences
----------------------------

JavaScript
----------

Incremental GC: true

Accessibility
-------------

Activated: false
Prevent Accessibility: 0

Library Versions
----------------

NSPR
Expected minimum version: 4.10.8
Version in use: 4.10.8

NSS
Expected minimum version: 3.19 Basic ECC Beta
Version in use: 3.19 Basic ECC Beta

NSSSMIME
Expected minimum version: 3.19 Basic ECC Beta
Version in use: 3.19 Basic ECC Beta

NSSSSL
Expected minimum version: 3.19 Basic ECC Beta
Version in use: 3.19 Basic ECC Beta

NSSUTIL
Expected minimum version: 3.19 Beta
Version in use: 3.19 Beta

Experimental Features
---------------------
Flags: needinfo?(adrian.aichner)
(Reporter)

Comment 4

3 years ago
My long list of installed add-ons is now gone, all I see in troubleshooting is:

Extensions
Name 	Version 	Enabled 	ID
McAfee Security Scan Plus	1.0	false	{e4f94d1e-2f53-401e-8885-681602c0ddd8}
Microsoft .NET Framework Assistant	0.0.0	false	{20a82645-c095-46ed-80e3-08825760534b}

The Firefox profile list order also got shuffled around so that the one I usually start is not in first position.

So I had to search for the right one on disk.

The browsing history suggests I am now using the right one.

But how do I restore the long list of add-ons I had installed before going through your request to restart with add-ons disabled?
Flags: needinfo?(twalker)
(Reporter)

Comment 5

3 years ago
I was able to recover by creating a new firefox profile (without starting firefox).

Then I copied contents of
C:\Dokumente und Einstellungen\AichnerAd\Desktop\Old Firefox Data\xwlwa1jh.default-1385301407992
to
C:\Dokumente und Einstellungen\AichnerAd\Anwendungsdaten\Mozilla\Firefox\Profiles\fyunwfyo.restored-good-profile

Add-on data is allback, jetpack and other extensions.

My Punchcard app indexeddb data is still there.

I feel lucky.
(Reporter)

Updated

3 years ago
Flags: needinfo?(twalker)
Adrian,  

It almost looks like you did a browser reset.  Anyway, sorry you ended up having to jump through some hoops to get back to original state.  

At this point, do you continue to experience this bug?
Flags: needinfo?(adrian.aichner)
(Reporter)

Comment 7

3 years ago
(In reply to [:tracy] Tracy Walker - QA Mentor from comment #6)
> Adrian,  
> 
> It almost looks like you did a browser reset.  Anyway, sorry you ended up

Oh, it's only called a "Refresh" and I like refreshments.

I would prefer the old name. Let's call a reset a reset.

> having to jump through some hoops to get back to original state.

Well, I learned something alog the way.

> 
> At this point, do you continue to experience this bug?

Yes.

Are you saying you can log into g+ in a nightly firefox with e10s enabled?
Flags: needinfo?(adrian.aichner)
(In reply to Adrian Aichner [:anaran] from comment #7)

> Are you saying you can log into g+ in a nightly firefox with e10s enabled?

Yes, I can login to g+.  Which adds to why this is particularly puzzling.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1123756
You need to log in before you can comment on or make changes to this bug.