Google+ is unusable in E10S mode

RESOLVED WORKSFORME

Status

()

Firefox
General
P2
normal
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: Marcin Juszkiewicz, Unassigned)

Tracking

38 Branch
x86_64
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(e10s+)

Details

(Whiteboard: [needs testing] triaged)

Attachments

(4 attachments)

(Reporter)

Description

3 years ago
Each time Firefox nightly forces me to use E10S I have to disable it because Google+ page does not work.

Browser starts, loads Google+ with all information (and me logged in) and then popup appears "you have to login first". After button press I landed at Google login page, logged in and got Google+ page with all information (and me logged in) and then popup appears...
(Reporter)

Updated

3 years ago
Blocks: 516752
Flags: needinfo?(lhenry)
Marcin, is this still happening? I can't reproduce it in the current Nightly. Thanks.
Flags: needinfo?(marcin)
(Reporter)

Comment 2

3 years ago
Strange. In my normal profile it still logs me out. In fresh clean one it works.
Flags: needinfo?(marcin)
Marcin, sorry this got past me. I can still see Google Plus with a clean profile.  

If this still isn't working on the current Nightly, can you save (and attach to this bug) the contents of about:support?  Thanks!
Flags: needinfo?(lhenry)
Flags: needinfo?(marcin)
(Reporter)

Comment 4

3 years ago
Created attachment 8569971 [details]
Troubleshooting Information.xhtml

Current nightly behaves the same with my browser profile.
Flags: needinfo?(marcin)
Can you try disabling all of your add-ons and see if the problem still persists?
Flags: needinfo?(marcin)
(Reporter)

Comment 6

3 years ago
Restarted in 'safe mode' and it works. Will check which addon broke it then.
Flags: needinfo?(marcin)
Note that safe-mode is not a great test, since safe-mode also disabled e10s. You need to manually disable your add-ons to check that it's an add-on issue with e10s enabled.

Updated

3 years ago
Flags: needinfo?(marcin)
(Reporter)

Comment 8

3 years ago
Created attachment 8572469 [details]
Troubleshooting Information.xhtml in e10s with all add-ons disabled

Disabled all add-ons by hand, restarted browser, went to http://plus.google.com/ and got proper content with "Wylogowałeś się z Google. Zaloguj się z powrotem, aby kontynuować." ("You have been logged out from Google. Login to continue" kind) message on top.

Pressing "Zaloguj się" ("Login") button refreshes page and gives me "logged out" message again.
Flags: needinfo?(marcin)

Updated

3 years ago
QA Contact: jbecerra
I went through the list of preferences in comment #8 which seemed interesting, the ones related to privacy, and I was able to reproduce the problem twice. However, I'm not sure yet what is triggering it.

1. Under my Privacy preferences I have "Tell sites that I do not want to be tracked" checked.
2. I have selected "Never remember history"

I have also toggled my preferences in about:config to match:


privacy.cpd.cookies	false
privacy.cpd.formdata	false
privacy.cpd.history	false
privacy.cpd.sessions	false
privacy.donottrackheader.enabled	true
privacy.donottrackheader.value	1
privacy.sanitize.migrateFx3Prefs	true
privacy.sanitize.timeSpan	0

I remember seeing the problem after toggling one of these two last:

privacy.donottrackheader.value	1
privacy.sanitize.timeSpan to 0

But if I restart or logout the browser after this, I am no longer able to reproduce the problem. This is as close as I got.

Reporter, could you try creating a new profile and see if you are able to reproduce the problem using that fresh profile?
Flags: needinfo?(marcin)
Mistakenly filed against Firefox 38 and should be instead 38 Branch. Sorry for the spam. dkl
Version: Firefox 38 → 38 Branch
(Reporter)

Comment 11

3 years ago
I am using 40.0a1 (2015-04-19).

Fresh profile works fine.

Enabled "privacy.donottrackheader.enabled" and it was still ok. Set "privacy.sanitize.timeSpan" to 0 and still fine.

Next was "privacy.cpd.cookies" to "false". then "privacy.cpd.sessions" to "false" (restarted browser after each change). Still fine.

My profile does not work.
Flags: needinfo?(marcin)
Marcin,

Since fresh profile works, this seems attributed to one of your addons. Need to sort out which one(s).
Flags: needinfo?(marcin)
(Reporter)

Comment 13

3 years ago
Tracy: check comment #8 where I had all addons disabled and issue was still present.

I can make a copy of profile and check one by one but not this week.
Flags: needinfo?(marcin)
(Reporter)

Comment 14

3 years ago
Created attachment 8595550 [details]
Troubleshooting Information.xhtml in e10s, profile without any addons

Doing check without addons is quick so done it today.
(Reporter)

Comment 15

3 years ago
just to be clear: still fails
Blocks: 905436
tracking-e10s: --- → +
Mike, is it possible a disabled addon could still be in play here?  Marcin reports this works fine in fresh profile with e10s. But in his everyday profile with all addons disabled, he still suffers from this bug.
Flags: needinfo?(mconley)
A disabled add-on doesn't have any of its scripts run - but any prefs that an add-on might have flipped will still be flipped, regardless of the state of the add-on.

So you can enable an add-on, it sets a bunch of prefs, you disable the add-on, and unless the add-on is designed to revert state, your prefs stay changed.

The list of prefs under about:support is a whitelist of prefs, and does not contain the entire list of changed preferences for privacy reasons.

Marcin - would it be possible for you to privately email your prefs.js to either Tracy or myself? We can then apply it to a new profile and see if we can reproduce your issue.

You can find your prefs.js by going to about:support, and in the first table, next to the "Profile Folder" entry, click "Show Folder".

In the folder that your OS opens, there should be a prefs.js.

Let us know if that's something you'd be interested in doing.
Flags: needinfo?(mconley) → needinfo?(marcin)
(Reporter)

Comment 19

3 years ago
Mike: sent you prefs.js
Flags: needinfo?(marcin)
Hrm, Marcin, I don't appear to have received it.

Could you please try re-sending it?
Flags: needinfo?(marcin)
(Reporter)

Comment 21

3 years ago
resent to mconley@mozilla.com
Flags: needinfo?(marcin)
Thanks - it got tossed in my spam folder. I have it now.
No luck reproducing with that prefs.js, I'm afraid.

Hrm.

Updated

3 years ago
Duplicate of this bug: 1165778
I can also reproduce this issue (bug 1165778). If you want, I can dump my about:support and (scrubbed) prefs.js.
Current Nightly's have e10s enabled during safe mode. Can either Marcin or strugee attempt to reproduce this bug on Nightly in Safe Mode as a sanity check?
Flags: needinfo?(marcin)
(Reporter)

Comment 27

3 years ago
happens still in 42.0a1 (2015-07-27)
Flags: needinfo?(marcin)

Updated

3 years ago
Duplicate of this bug: 1193717

Comment 29

3 years ago
At tracy's request, here's my about:support minus print.* entries

Application Basics
------------------

Name: Firefox
Version: 42.0a1
Build ID: 20150728232743
Update Channel: default
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:42.0) Gecko/20100101 Firefox/42.0
Multiprocess Windows: 2/2 (default: true)
Safe Mode: false

Crash Reports for the Last 3 Days
---------------------------------

All Crash Reports

Extensions
----------

Name: Classic Theme Restorer
Version: 1.3.7
Enabled: true
ID: ClassicThemeRestorer@ArisT2Noia4dev

Name: HTTPS-Everywhere
Version: 5.0.5
Enabled: true
ID: https-everywhere@eff.org

Name: Privacy Badger Firefox
Version: 0.2.6
Enabled: true
ID: jid1-MnnxcxisBPnSXQ@jetpack

Name: Tab Stats
Version: 0.0.6.1
Enabled: true
ID: tabstats@glandium.org

Name: Blank Your Monitor + Easy Reading
Version: 1.9.13.1-signed
Enabled: false
ID: bym@savetheworld.org

Name: Gecko Profiler
Version: 1.16.1
Enabled: false
ID: jid0-edalmuivkozlouyij0lpdx548bc@jetpack

Name: Lightbeam
Version: 1.2.1.1-signed
Enabled: false
ID: jid1-F9UJ2thwoAm5gQ@jetpack

Name: Noise Control
Version: 16
Enabled: false
ID: jid1-hUBct1DNfZQIeQ@jetpack

Name: SQLite Manager
Version: 0.8.3.1-signed
Enabled: false
ID: SQLiteManager@mrinalkant.blogspot.com

Name: Ubuntu Modifications
Version: 3.1
Enabled: false
ID: ubufox@ubuntu.com

Name: Ubuntu Online Accounts
Version: 0.5
Enabled: false
ID: online-accounts@lists.launchpad.net

Name: Unity Desktop Integration
Version: 3.0.2
Enabled: false
ID: webapps-team@lists.launchpad.net

Name: Unity Websites integration
Version: 2014.08.06.beta
Enabled: false
ID: {2e1445b0-2682-11e1-bfc2-0800200c9a66}

Name: User Agent Switcher
Version: 0.7.3.1-signed
Enabled: false
ID: {e968fc70-8f95-4ab9-9e79-304de2a71ee1}

Name: YouTube ALL HTML5
Version: 3.0.0
Enabled: false
ID: jid1-qj0w91o64N7Eeg@jetpack

Graphics
--------

Adapter Description: X.Org -- Gallium 0.4 on AMD RV730
Asynchronous Pan/Zoom: none
Device ID: Gallium 0.4 on AMD RV730
Driver Version: 3.0 Mesa 10.1.3
GPU Accelerated Windows: 0/2 Basic (OMTC)
Supports Hardware H264 Decoding: false
Vendor ID: X.Org
WebGL Renderer: X.Org -- Gallium 0.4 on AMD RV730
windowLayerManagerRemote: true
AzureCanvasBackend: skia
AzureContentBackend: cairo
AzureFallbackCanvasBackend: none
AzureSkiaAccelerated: 0
CairoUseXRender: 1

Important Modified Preferences
------------------------------

accessibility.typeaheadfind.flashBar: 0
browser.cache.disk.capacity: 358400
browser.cache.disk.filesystem_reported: 1
browser.cache.disk.hashstats_reported: 1
browser.cache.disk.smart_size_cached_value: 358400
browser.cache.disk.smart_size.first_run: false
browser.cache.disk.smart_size.use_old_max: false
browser.cache.frecency_experiment: 2
browser.display.use_document_colors: true
browser.download.importedFromSqlite: true
browser.fixup.domainwhitelist.10.0.0.20: true
browser.places.smartBookmarksVersion: 7
browser.sessionstore.upgradeBackup.latestBuildID: 20150728232743
browser.startup.homepage_override.buildID: 20150728232743
browser.startup.homepage_override.mstone: 42.0a1
browser.tabs.remote.autostart: true
browser.urlbar.trimURLs: false
browser.urlbar.userMadeSearchSuggestionsChoice: true
dom.apps.reset-permissions: true
dom.event.contextmenu.enabled: false
dom.mozApps.used: true
extensions.lastAppVersion: 42.0a1
font.internaluseonly.changed: false
gfx.canvas.azure.backends: skia
media.gmp-gmpopenh264.lastUpdate: 1432639878
media.gmp-gmpopenh264.path: /home/nemo/.mozilla/firefox/zuj5w8zx.tmp/gmp-gmpopenh264
media.gmp-gmpopenh264.version: 1.4
media.gmp-manager.buildID: 20150728232743
media.gmp-manager.lastCheck: 1439399669
network.cookie.prefsMigrated: true
network.http.referer.spoofSource: true
network.predictor.cleaned-up: true
places.database.lastMaintenance: 1439408746
places.history.expiration.transient_current_max_pages: 104858
plugin.importedState: true
plugin.soname.list: libXt.so:libXext.so
plugin.state.flash: 1
plugin.state.npwrapper.nppdf: 0
privacy.cpd.offlineApps: true
privacy.cpd.siteSettings: true
privacy.donottrackheader.enabled: true
privacy.donottrackheader.value: 1
privacy.sanitize.migrateFx3Prefs: true
privacy.sanitize.timeSpan: 0
security.disable_button.openDeviceManager: false
storage.vacuum.last.index: 1
storage.vacuum.last.places.sqlite: 1437249023

Important Locked Preferences
----------------------------

JavaScript
----------

Incremental GC: true

Accessibility
-------------

Activated: false
Prevent Accessibility: 0

Library Versions
----------------

NSPR
Expected minimum version: 4.10.9 Beta
Version in use: 4.10.9 Beta

NSS
Expected minimum version: 3.19.2 Basic ECC
Version in use: 3.19.2 Basic ECC

NSSSMIME
Expected minimum version: 3.19.2 Basic ECC
Version in use: 3.19.2 Basic ECC

NSSSSL
Expected minimum version: 3.19.2 Basic ECC
Version in use: 3.19.2 Basic ECC

NSSUTIL
Expected minimum version: 3.19.2
Version in use: 3.19.2

Experimental Features
---------------------

Name: Invisible test of the experiment branching system.
ID: experiment-branch-test-nightly@experiments.mozilla.org
Description: An experiment using branches just to test whether branches get saved correctly.
Active: false
End Date: 1409668577193
Homepage:

Sandbox
-------

Seccomp-BPF (System Call Filtering): true
Seccomp Thread Synchronization: true
User Namespaces: true
Media Plugin Sandboxing: true
Thanks nemo!

fortunately, there are only a few add-ons that both nemo and marcin had installed at the time of their reports:

Classic Theme Restorer
Privacy Badger Firefox
User Agent Switcher

We had started to believe an addon was changing a pref that is causing this bug. Even if the addon is disabled, that changed pref remains. Privacy Badger Firefox seem to be the conspicuous one here. but which pref is it changing?  But is it an add-on or a coincidental set of prefs the users have set?

I looked at both Marcin's and Nemo's about:support reports and this is what jumps out at me for one reason or another:

In Marcin's
network.http.referer.spoofSource: true
browser.fixup.domainwhitelist.192.168.0.12: true
security.disable_button.openCertManager: false

In Nemo's
network.negotiate-auth.delegation-uris: .redhat.com
network.negotiate-auth.trusted-uris: .redhat.com
browser.fixup.domainwhitelist.10.0.0.20: true
security.disable_button.openDeviceManager: false

both 
browser.places.smartBookmarksVersion: 7
privacy.donottrackheader.value: 1

Comment 31

3 years ago
FWIW, I have this issue without having ever installed Classic Theme Restorer (but with Privacy Badger and User Agent Switcher), so I don't think that's to blame.

Comment 32

3 years ago
(In reply to T. Read from comment #31)
> FWIW, I have this issue without having ever installed Classic Theme Restorer
> (but with Privacy Badger and User Agent Switcher), so I don't think that's
> to blame.

Can you post the information as above? The preferences from about:support.
Flags: needinfo?(thjread)

Comment 33

3 years ago
Created attachment 8662203 [details]
Troubleshooting Information.xhtml

Here's my about:support
Flags: needinfo?(thjread)

Comment 34

3 years ago
(BTW, I've disabled e10s at the moment, but I don't think I've changed anything else.)

Comment 35

2 years ago
I'm also seeing this bug with e10s enabled on Firefox 46 beta6 (Linux x64).  I also had User Agent Switcher installed but removed it to see if it helped and it did not.  In the past (over six months ago) I likewise had Privacy Badger installed but removed it.

One curiosity and potential data point is that when I tried e10s previously with Firefox 46 beta1 (or possibly beta3) it experienced similar problems also with Facebook and Amazon.com where it mentioned that I needed to enable cookies.  With F46 B6 however I am only seeing the issue with Google+.  I am not sure whether the issue happened with Google plus on F46 b1 as I did not use G+ in the short window that I tried it.  I suspect that the issue has to do with cookies in some way?

I will attempt to create a new profile, install my current extensions one by one and configure them as usual, then restart in an attempt to isolate this.  If there is a developer or bug helper actively working on this I can also email my about:support info.

Comment 36

2 years ago
Starting with a new profile and then manually copying over the needed files for to get my old cookies, passwords, sessions, form data, history and bookmarks seems to have resolved it.  I don't believe any current extension is causing the issue as the first thing I did when I started with a brand new profile was to attempt to add extensions one by one to test them.  I did this for my current extensions and even for a few I ran in the past and I could not duplicate it on the new profile.

I notice there are a lot of remnants in the profile directory and prefs,js related to old extensions.  It might be possible that some old version of an extension made some change and did not clean it up properly.  I'm not sure, just glad it works now.  I'll report back if it happens again.

Comment 37

2 years ago
test because it's such a major bug, but it seems like it may have been resolved.  can try with my dirty profile and then ask softvision if it doesn't reproduce.
Flags: needinfo?(sescalante)
Priority: -- → P2
Whiteboard: [needs testing] triaged

Comment 38

2 years ago
i just tried and couldn't reproduce with latest version - closing but sending for more testing on different platforms to see if it can be repro'd again.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(sescalante)
Resolution: --- → WORKSFORME

Comment 39

2 years ago
It was an issue with the original Google+ page. With the expanded roll-out of the new version (http://www.androidpolice.com/2016/08/30/google-web-preview-now-default-look-google-classic-going-away/) the problem for e10s users should go away.
You need to log in before you can comment on or make changes to this bug.