Closed Bug 1155626 Opened 5 years ago Closed 5 years ago

crash in mozilla::gfx::DrawTargetD2D1::Init(mozilla::gfx::IntSizeTyped<mozilla::gfx::UnknownUnits> const&, mozilla::gfx::SurfaceFormat)

Categories

(Core :: Graphics, defect, critical)

x86
Windows 8
defect
Not set
critical

Tracking

()

RESOLVED FIXED
mozilla40
Tracking Status
firefox40 --- fixed
thunderbird_esr38 40+ fixed

People

(Reporter: petruta.rasa, Assigned: nsilva)

References

Details

(Keywords: crash, Whiteboard: [gfx-noted])

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is 
report bp-c66e60bd-ecee-4ff9-b018-4099a2150417.
=============================================================
Encountered this crash signature after navigating on google maps and switching several times between earth and maps view. After a while the browser was unusable, I couldn't switch from a tab to another. Resizing the browser allowed the other tabs to be opened, but repeating those steps again caused the browser crash.

Another comments in this report mention graphic card install/update.

Graphics
Adapter Description	Intel(R) HD Graphics
Adapter Drivers	igdumdim32 igd10iumd32 igd10iumd32
Adapter RAM	Unknown
Device ID	0x0152
Direct2D Enabled	true
DirectWrite Enabled	true (6.2.9200.16581)
Driver Date	10-31-2013
Driver Version	10.18.10.3345
GPU #2 Active	false
GPU Accelerated Windows	1/1 Direct3D 11 (OMTC)
Subsys ID	00000000
Vendor ID	0x8086
WebGL Renderer	Google Inc. -- ANGLE (Intel(R) HD Graphics Direct3D11 vs_5_0 ps_5_0)
windowLayerManagerRemote	true
AzureCanvasBackend	direct2d 1.1
AzureContentBackend	direct2d 1.1
AzureFallbackCanvasBackend	cairo
AzureSkiaAccelerated	0
Black screen on google maps: http://i.imgur.com/faQywLn.png 

After updating the driver, I couldn't reproduce the google maps black screen issue.
Driver Date	12-18-2014
Driver Version	10.18.10.4061
Looks like whatever maps/earth (and gecko underneath) is doing is causing the driver to reset the D3D11 device and fail to create a new D2D1 device.
Whiteboard: [gfx-noted]
Attachment #8594736 - Flags: review?(bas) → review+
https://hg.mozilla.org/mozilla-central/rev/6fe88b38363e
Assignee: nobody → nsilva
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla40
#17 crasher in TB 38.1.0 so we should consider taking this in our branch.
You need to log in before you can comment on or make changes to this bug.