crash in mozilla::gfx::DrawTargetD2D1::Init(mozilla::gfx::IntSizeTyped<T> const&, mozilla::gfx::SurfaceFormat)

RESOLVED DUPLICATE of bug 1155626

Status

()

Core
Graphics
--
critical
RESOLVED DUPLICATE of bug 1155626
3 years ago
3 years ago

People

(Reporter: ashughes, Unassigned)

Tracking

({crash, topcrash-win})

unspecified
x86
Windows NT
crash, topcrash-win
Points:
---

Firefox Tracking Flags

(firefox38- affected, firefox38.0.5 affected, firefox39 affected, firefox40 unaffected, firefox41 unaffected)

Details

(crash signature)

(Reporter)

Description

3 years ago
This bug was filed from the Socorro interface and is 
report bp-61d4b332-111f-4e77-86c4-f19262150626.
=============================================================
0 	xul.dll 	mozilla::gfx::DrawTargetD2D1::Init(mozilla::gfx::IntSizeTyped<mozilla::gfx::UnknownUnits> const&, mozilla::gfx::SurfaceFormat) 	gfx/2d/DrawTargetD2D1.cpp
1 	xul.dll 	mozilla::gfx::DrawTargetD2D1::CreateSimilarDrawTarget(mozilla::gfx::IntSizeTyped<mozilla::gfx::UnknownUnits> const&, mozilla::gfx::SurfaceFormat) 	gfx/2d/DrawTargetD2D1.cpp
2 	xul.dll 	gfxContext::PushNewDT(gfxContentType) 	gfx/thebes/gfxContext.cpp
3 	xul.dll 	gfxContext::PushGroup(gfxContentType) 	gfx/thebes/gfxContext.cpp
4 	xul.dll 	gfxContext::PushGroupAndCopyBackground(gfxContentType) 	gfx/thebes/gfxContext.cpp
=============================================================
More reports: https://crash-stats.mozilla.com/report/list?product=Firefox&signature=mozilla%3A%3Agfx%3A%3ADrawTargetD2D1%3A%3AInit%28mozilla%3A%3Agfx%3A%3AIntSizeTyped%3CT%3E+const%26%2C+mozilla%3A%3Agfx%3A%3ASurfaceFormat%29

Product breakdown:
* Firefox 38: 14670 crashes in the last week (1.97% @ #5)
* Firefox 39: 380 crashes in the last week (0.12% @ #74) 
* Firefox 40: 0 crashes reported in the last week
* Firefox 41: 0 crashes reported in the last week

GPU Breakdown:
* 77.32% crash with Intel
** 19.352% Intel Ivy Bridge integrated graphics
** 12.958% Intel Haswell-ULT integrated graphics 
** 10.913% Intel Haswell integrated graphics
* 14.24% crash with AMD
** 0.757% AMD Radeon HD 8210
** 0.641% AMD Radeon HD 7640G
** 0.620% AMD Radeon HD 8400
* 8.44% crash with NVidia
** 0.866% NVidia GeForce GTX 970
** 0.457% NVidia GeForce GT 640
** 0.307% NVidia GeForce GTX 980
 
16 comments mention that crashes were occurring during or soon after updating a driver (particularly NVidia), so this might be a driver reset bug.
(Reporter)

Comment 1

3 years ago
[Tracking Requested - why for this release]: nominating to track since this is a topcrash for Firefox 38. Volume on other branches may be due to test audiences not running affected hardware.
status-firefox38: --- → affected
status-firefox38.0.5: --- → affected
status-firefox39: --- → affected
status-firefox40: --- → unaffected
status-firefox41: --- → unaffected
tracking-firefox38: --- → ?
Keywords: topcrash-win
This should be fixed in bug 1155626, riding 40.  Not sure uplift is warranted?
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1155626
tracking-firefox38: ? → -
You need to log in before you can comment on or make changes to this bug.