[Settings] Data Connection toggle ignores current settings when set from Utility Tray

VERIFIED FIXED in 2.2 S11 (1may)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: pcheng, Assigned: arthurcc)

Tracking

({regression})

unspecified
2.2 S11 (1may)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [3.0-Daily-Testing])

Attachments

(3 attachments)

Posted file logcat of issue
Description:
In Settings > Cellular & Data, the Data Connection toggle remains unchanged if Data is being turned on/off from notification tray.

STR:
1) Go to Settings > Cellular & Data
2) Pull down notification tray, and turn on or off cell data
3) Observe the Data Connection toggle

Expected: Data Connection toggle should reflect current setting

Actual: Data Connection toggle ignores the change made at step 2

Attaching a logcat.

Repro rate: 5/5

See video:
https://www.youtube.com/watch?v=fdZVNF0bkdE

Device: Flame 3.0 Master (full flashed 319MB KK)
BuildID: 20150417010203
Gaia: 3cd0a9facce26c2acc7be3755a17131a6358e33f
Gecko: 51e3cb11a258
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0
(Reporter)

Comment 1

4 years ago
This issue also reproduces on 2.2.

Device: Flame 2.2
BuildID: 20150417002504
Gaia: d50b8a3919a7b4d8d289f150d3b9bed704ebafa9
Gecko: 5ebf32030512
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

----

This issue does NOT occur on v2.1. Data connection toggle correctly reflects current settings from Utility Tray.

Device: Flame 2.1
BuildID: 20150417001203
Gaia: bbe983b4e8bebfec26b3726b79568a22d667223c
Gecko: c54aa1be51d6
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 34.0 (2.1) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regression
Whiteboard: [3.0-Daily-Testing]
This is a regression and broken functionality so nominating this 2.2?
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
(Reporter)

Updated

4 years ago
QA Contact: pcheng
(Reporter)

Comment 3

4 years ago
b2g-inbound regression window:

Last Working Environmental Variables:
Device: Flame
BuildID: 20141222183228
Gaia: 7ae741bc9a365c90747b4c87573a4ecd913a6fa5
Gecko: e3fb73728b1a
Version: 37.0a1 (2.2 Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

First Broken Environmental Variables:
Device: Flame
BuildID: 20141222190228
Gaia: 7fa66f7c4909935aa7167388e1d3a0b6c1d6cd5b
Gecko: a3a90dede624
Version: 37.0a1 (2.2 Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Last Working Gaia & First Broken Gecko - issue does NOT repro
Gaia: 7ae741bc9a365c90747b4c87573a4ecd913a6fa5
Gecko: a3a90dede624

Last Working Gecko & First Broken Gaia - issue DOES repro
Gaia: 7fa66f7c4909935aa7167388e1d3a0b6c1d6cd5b
Gecko: e3fb73728b1a

Gaia pushlog:
https://github.com/mozilla-b2g/gaia/compare/7ae741bc9a365c90747b4c87573a4ecd913a6fa5...7fa66f7c4909935aa7167388e1d3a0b6c1d6cd5b

Caused by Bug 1103896.
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Arthur, can you take a look at this please? This looks to have been caused by the work done for bug 1103896.
Blocks: 1103896
Flags: needinfo?(ktucker) → needinfo?(arthur.chen)
Assignee: nobody → arthur.chen
Flags: needinfo?(arthur.chen)
Comment on attachment 8594610 [details] [review]
[gaia] crh0716:1155835 > mozilla-b2g:master

EJ, would you mind take a look at this simple patch? Thanks.

I removed the settings key binding during the refactoring but forgot to update the checked state when settings changes.
Attachment #8594610 - Flags: review?(ejchen)
Comment on attachment 8594610 [details] [review]
[gaia] crh0716:1155835 > mozilla-b2g:master

good catch ! r+
Attachment #8594610 - Flags: review?(ejchen) → review+
Thanks, EJ!
Keywords: checkin-needed
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED

Comment 10

4 years ago
regression blocking.
blocking-b2g: 2.2? → 2.2+
Comment on attachment 8594610 [details] [review]
[gaia] crh0716:1155835 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Bug 1103896
[User impact] if declined: Bad user experience
[Testing completed]: Testing on the device
[Risk to taking this patch] (and alternatives if risky): Low. The patch adds a missing line of code updating the state.
[String changes made]: None
Attachment #8594610 - Flags: approval-gaia-v2.2?
This issue is verified fixed on Flame Master.

Result: Data Connection toggle changes in the notification tray also changes the toggle in Settings screen.

Environmental Variables:
Device: Flame 3.0 (KK, 319mb, full flash)
Build ID: 20150422010202
Gaia: 15134b080b5f406e5aa36f5136c17dafb4e31f64
Gecko: 946ac85af8f4
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

======================================
Leaving verifyme for 2.2 uplift & verification.
Status: RESOLVED → VERIFIED
Flags: needinfo?(ktucker)
Keywords: verifyme
Attachment #8594610 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
According to the STR of Comment 0,this bug has been successfully verified on latest Nightly Flame v2.2.

Actual results: When Data Connection toggle changes in the utility tray, Data Connection also changes the toggle in Cellular & Data screen at the same time .
See attachment: verified_v2.2.MP4
Reproduce rate: 0/6

Device: Flame 2.2 build(Pass)
Build ID               20150423002502
Gaia Revision          b838d0e7c163e66660dcb6e387d8339944a7a30e
Gaia Date              2015-04-23 02:32:46
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/8dce56574f28
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150423.035703
Firmware Date          Thu Apr 23 03:57:16 EDT 2015
Bootloader             L1TC000118D0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.