[l10n][First Time Experience]Bengali India: The "out of 26" is displayed with truncation on "Import contacts" view.

VERIFIED DUPLICATE of bug 1157157

Status

Mozilla Localizations
bn-IN / Bengali (India)
VERIFIED DUPLICATE of bug 1157157
3 years ago
3 years ago

People

(Reporter: Shine(Leave from Mozilla), Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.1 affected, b2g-v2.2 verified)

Details

(Whiteboard: LocRun2.2)

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
Created attachment 8595846 [details]
out of 26.png

[1.Description]:
[110n][v2.1&v2.2][First Time Experience]Bengali India: On "Import Contacts" screen, tap on "Facebook" and login to an account.Then tap the "x" to cancel the import, the "out ot 26"  is displayed with truncation on "Import contacts" view.

See attachment: out of 26.png

[2.Testing Steps]: 
1. After flashing the phone or reset, select "Bengali India" language.
2. Tap "Next" until reaching the "Select a network" screen.
3. Connect to a network and then tap "Next" until reaching the "Import Contacts" screen 
4. Tap on "Facebook" and login to an account with at least 2 Friends 
5. Tap the "x" to cancel the import, observe the message in the facebook section.

[3.Expected Result]: 
5. The "out ot 26" should not be truncated.

[4.Actual Result]: 
5. The "out ot 26" is displayed with truncation.

[5.Reproduction build]: 
Device: Flame 2.2 user (Affected)
Build ID               20150421002501
Gaia Revision          828dd03a0e3b140d74b2e49355197df4d91d9227
Gaia Date              2015-04-20 18:28:39
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/36f72a3efb9b
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150421.042925
Firmware Date          Tue Apr 21 04:29:36 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 2.1 user (Affected)
Build ID               20150421001205
Gaia Revision          bbe983b4e8bebfec26b3726b79568a22d667223c
Gaia Date              2015-04-09 13:52:48
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/b85d4f4a6d61
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150421.040717
Firmware Date          Tue Apr 21 04:07:27 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
12257

[8. Note]:
This same problem  in different language need different RD to resolve.

Updated

3 years ago
See Also: → bug 1157157
(Reporter)

Updated

3 years ago
Summary: [110n][First Time Experience]Bengali India: The "out of 26" is displayed with truncation on "Import contacts" view. → [l10n][First Time Experience]Bengali India: The "out of 26" is displayed with truncation on "Import contacts" view.
Duplicate of Bug 1157157
(Sue: let's not file more bugs of this instance for other locales. Rather please comment on Bug 1157157 what other languages are affected when you notice them, since i made that a general bug. thanks!)
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(lulu.tian)
Resolution: --- → DUPLICATE
Duplicate of bug: 1157157

Comment 2

3 years ago
(In reply to Delphine Lebédel [:delphine - use need info] from comment #1)
> Duplicate of Bug 1157157
> (Sue: let's not file more bugs of this instance for other locales. Rather
> please comment on Bug 1157157 what other languages are affected when you
> notice them, since i made that a general bug. thanks!)
> 
> *** This bug has been marked as a duplicate of bug 1157157 ***

Delphine,
Thanks, I will convey this message to other person in our team.
Flags: needinfo?(lulu.tian)
(Reporter)

Comment 3

3 years ago
Created attachment 8597000 [details]
out of 26_update.png

Maybe the original screenshot is misleading, and actually, it is 2.2 English+2.2 bn-in, not 2.1 English+2.2bn-in.
To make it more clear, I have updated the screenshot with some labels on it: "2.2 english", "2.2 bn-in", "2.1 bn-in" on.
See attachment: out of 26_update.png
Thanks!
Created attachment 8615140 [details]
Verify1_BN-IN_Flame2.1&2.1s_Fail_Flame2.2_Pass.png

According to the STR in comment 0, this issue is verified pass on latest flame 2.2 user build, but still exist on flame 2.1 and 2.1s build.
Hi Mike,
Could you confirm whether this issue will uplift to 2.1 or 2.1s user build or not?
Many thanks!
See attachment: Verify1_BN-IN_Flame2.1&2.1s_Fail_Flame2.2_Pass.png.
Flame 2.2 reproducing rate:0/10
Flame 2.1 & 2.1s reproducing rate:10/10

Flame 2.1 user build (Fail)
Build ID               20150603161201
Gaia Revision          2304a1f6327c2ccf35d6995ee16f2231ed1f22a3
Gaia Date              2015-05-26 13:30:41
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/4219ad1958a3
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150603.193416
Firmware Date          Wed Jun  3 19:34:28 EDT 2015
Bootloader             L1TC000118D0

2.1s (512) build (Affected)
Build ID               20150603001202
Gaia Revision          e29043077da834854bfda9d409d1e690fb8070c3
Gaia Date              2015-06-01 10:35:56
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1s/rev/5685467cbdb5
Gecko Version          34.0
Device Name            scx15_sp7715ea
Firmware(Release)      4.4.2
Firmware(Incremental)  122
Firmware Date          Thu Feb  5 12:42:58 CST 2015

Flame 2.2 user build (Pass)
Build ID               20150603162502
Gaia Revision          b92e782ca12397acc3eb52f2e237522c0213f4e0
Gaia Date              2015-06-03 21:02:56
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/74421c778aff
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150603.194942
Firmware Date          Wed Jun  3 19:49:55 EDT 2015
Bootloader             L1TC000118D0
QA Whiteboard: [MGSEI-Triage+][MGSEI-l10n-1F]
status-b2g-v2.2: affected → verified
Flags: needinfo?(mlien)
Whiteboard: LocRun2.2, MGSEI-l10n-1F-Bengali India → LocRun2.2
Comment hidden (obsolete)

Comment 6

3 years ago
Sorry Lancy, please ignore  comment 5, since bug 1157157 can resolve this issue's problem, please comment on there and change the b2g-status to affected on v2.1 and v2.1S, then request the patch uplift

Comment 7

3 years ago
Thanks Mike and Lancy.
You did the great job!

Have a nice day!:)
Flags: needinfo?(yulan.zhu)
Per comment 49 to comment 53 in bug 1157157, this issue will not fix on v2.1 & v2.1s.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.