[l10n][First Time Experience]Multiple locales: The text "No friends imported (out of 46)" is truncated in FTE.

VERIFIED FIXED in 2.2 S11 (1may)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: lulu.tian, Assigned: apastor)

Tracking

({regression})

unspecified
2.2 S11 (1may)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 wontfix, b2g-v2.1S wontfix, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: LocRun2.2, [systemsfe])

Attachments

(15 attachments)

136.31 KB, image/png
Details
124.35 KB, image/png
Details
129.32 KB, image/png
Details
105.55 KB, image/png
Details
105.13 KB, image/png
Details
130.23 KB, image/png
Details
111.95 KB, image/png
Details
46 bytes, text/x-github-pull-request
sfoster
: review+
epang
: ui-review+
Details | Review
35.37 KB, image/png
Details
40.44 KB, image/png
Details
40.81 KB, image/png
Details
486.63 KB, image/png
Details
452.82 KB, image/png
Details
340.75 KB, image/png
Details
335.38 KB, image/png
Details
(Reporter)

Description

4 years ago
[1.Description]:
[l10n][v2.2][First Time Experience]Serbian Cyrillic: When user imported 0 or 1 facebook contact, the text "No friends imported (out of 46)" or "One friends imported" is truncated in FTE.
See attachment:No friends imported.png

[2.Testing Steps]: 
1. After flashing the phone or reset, select language as "Српски" and tap "Next" until reaching the "Select a Network" screen 
2. Connect to a network and then tap "Next" until reaching the "Import Contacts" screen 
3. Tap on "Facebook" and login to an account with at least 2 Friends 
4. Tap the "x" to cancel the import, observe the message in the facebook section
5. Restart the device and tap "Next" until reaching the "Select a Network" screen, connect to a network and then tap "Next" until reaching the "Import Contacts" screen
6. Tap on "Facebook", select 1 friend and then tap "Import" in the upper right corner

[3.Expected Result]: 
4&6. There is no truncation. Nothing overlaps. The UI should not appear broken in any way. 

[4.Actual Result]: 
4. The text "No friends imported (out of 46)" is truncated.
6. The text "One friends imported (out of 43)" is truncated.

[5.Reproduction build]: 
Device: Flame 2.2 user (affected)
Build ID               20150421002501
Gaia Revision          828dd03a0e3b140d74b2e49355197df4d91d9227
Gaia Date              2015-04-20 18:28:39
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/36f72a3efb9b
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150421.042925
Firmware Date          Tue Apr 21 04:29:36 EDT 2015
Bootloader             L1TC00011

Device: Flame 2.1 user (unaffected)
Build ID               20150421001205
Gaia Revision          bbe983b4e8bebfec26b3726b79568a22d667223c
Gaia Date              2015-04-09 13:52:48
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/b85d4f4a6d61
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150421.040717
Firmware Date          Tue Apr 21 04:07:27 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
12257
(Reporter)

Updated

4 years ago
(Reporter)

Comment 1

4 years ago
This same problem  in different language need different RD to resolve.
See Also: → 1157153
Nominating since this is a regression and was fixed in 2.1. Also, it affects multiple languages.
Moving over to FirefoxOS component so that this can get a fix.
Component: sr / Serbian → Gaia::First Time Experience
Keywords: regression
Product: Mozilla Localizations → Firefox OS
blocking-b2g: --- → 2.2?
Changing the title.
This affects multiple shipping locales
Summary: [l10n][First Time Experience]Serbian Cyrillic: The text "No friends imported (out of 46)" is truncated in FTE. → [l10n][First Time Experience]Multiple locales: The text "No friends imported (out of 46)" is truncated in FTE.
Duplicate of this bug: 1157153
Asking for UX help on this! thanks
Flags: needinfo?(firefoxos-ux-bugzilla)
blocking-b2g: 2.2? → 2.2+
Posted image Serbian Latin.png
According to the STR in comment0, This issue also exist on Flame2.2[User build] when system language is in Serbian Latin.

Reproduction Frequency: 5/5

Device: Flame 2.1 user [Unaffected]
Build ID               20150422001201
Gaia Revision          bbe983b4e8bebfec26b3726b79568a22d667223c
Gaia Date              2015-04-09 13:52:48
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/685fa69b59dc
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150422.035556
Firmware Date          Wed Apr 22 03:56:07 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 2.2 user [Affected]
Build ID               20150422002505
Gaia Revision          41a85c5f9db291d4f7c0e94c8416b5115b4ee407
Gaia Date              2015-04-21 17:23:41
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/a87a05e7d0ef
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150422.040316
Firmware Date          Wed Apr 22 04:03:27 EDT 2015
Bootloader             L1TC000118D0

Comment 7

4 years ago
See that this is already + as a regression, but I'm not sure what the UX need is. Since it's a regression we'd expect that this would look as it did previously.
Flags: needinfo?(firefoxos-ux-bugzilla)
Whiteboard: LocRun2.2, MGSEI-l10n-1F-Serbian Cyrillic → LocRun2.2, MGSEI-l10n-1F-Serbian Cyrillic [systemsfe]
Assignee: nobody → apastor
According to the STR in comment0, This issue also exist on Flame2.2[User build] when system language is in Portuguese Brazil.

Reproduction Frequency: 5/5
Device:FLame user 2.1[Unaffected]
Build ID               20150423001201
Gaia Revision          bbe983b4e8bebfec26b3726b79568a22d667223c
Gaia Date              2015-04-09 13:52:48
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/6a68a038146a
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150423.035520
Firmware Date          Thu Apr 23 03:55:31 EDT 2015
Bootloader             L1TC000118D0

Device:Flame 2.2 user[Affected]
Build ID               20150423002502
Gaia Revision          b838d0e7c163e66660dcb6e387d8339944a7a30e
Gaia Date              2015-04-23 02:32:46
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/8dce56574f28
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150423.035211
Firmware Date          Thu Apr 23 03:52:22 EDT 2015
Bootloader             L1TC000118D0
According to the steps in comment 0, this issue still exist on latest build of Flame 2.2(user build) in Polish.
See attachment: Polish_No friends imported.png & Polish_one friend imported.png

Device:FLame user 2.1[Unaffected]
Build ID               20150423001201
Gaia Revision          bbe983b4e8bebfec26b3726b79568a22d667223c
Gaia Date              2015-04-09 13:52:48
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/6a68a038146a
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150423.035520
Firmware Date          Thu Apr 23 03:55:31 EDT 2015
Bootloader             L1TC000118D0

Device:Flame 2.2 user[Affected]
Build ID               20150423002502
Gaia Revision          b838d0e7c163e66660dcb6e387d8339944a7a30e
Gaia Date              2015-04-23 02:32:46
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/8dce56574f28
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150423.035211
Firmware Date          Thu Apr 23 03:52:22 EDT 2015
Bootloader             L1TC000118D0
Whiteboard: LocRun2.2, MGSEI-l10n-1F-Serbian Cyrillic [systemsfe] → LocRun2.2, MGSEI-l10n-1F-Serbian Cyrillic [systemsfe], MGSEI-l10n-1F-Polish
(Assignee)

Comment 11

4 years ago
I'm not sure this is a regression... at least, not a code regression. In all the examples we have, the translation has changed to a longer string. I'm pretty sure that 2.1 would be affected as well if the string was longer.

The question here is, what should we do when the string is larger than the width of the screen? Should we add a ellipsis or should we jump to another line? 

Thanks!
Flags: needinfo?(lebedel.delphine)
See Also: → 1158102
Correct, these are not regressions. I was mislead because of lack of screenshots comparing 2.1 and 2.2.
In these cases, it seems localizers used a longer string in 2.2, for some reason. I think we can start by asking them why, and if they can shorten them back like they were. Adding them in CC here. 
Concerning what we should do (ellipsis or jump to another line) I *think* that would be a UX decision.
blocking-b2g: 2.2+ → ---
Flags: needinfo?(lebedel.delphine)
Keywords: regression
Flags: needinfo?(mv.nsaad)
(In reply to Delphine Lebédel [:delphine - use need info] from comment #12)
> In these cases, it seems localizers used a longer string in 2.2, for some
> reason. I think we can start by asking them why, and if they can shorten
> them back like they were.

Translations are different because strings are different even if en-US values and the place where they appear seems the same, gaia developers should be asked why…

> Concerning what we should do (ellipsis or jump to another line) I *think*
> that would be a UX decision.

BTW: ellipsis wouldn't work for pl at all
Flags: needinfo?(splewako)
Our pt-BR seems fine since it's comparing two different strings. Regarding the ellipsis vs line jump, I think there should be a new line, since the information is valuable to be omitted, but that's just my two cents.
Flags: needinfo?(mv.nsaad)
Strings were removed from import_contacts.properties and added to ftu.properties almost one month apart (atleast Serbian repo) and I did not realize that they were actualy the same strings (older version was shorted because of truncation).

Fixed:
https://hg.mozilla.org/gaia-l10n/sr-Cyrl/rev/786924c5d02a
Flags: needinfo?(tumbas93)
Thanks guys. 
:msaad actually if you look at the screenshot on comment 8, there is the string to the right that you may want to try to shorten, if that's possible of course. This bug is kind of messy so hard to see that...
Flags: needinfo?(mv.nsaad)
Seems like although testers initially filed this bug for the string "no friends imported" they soon also added the issue with "aa/bb friends imported", which is creating confusion.
Let's keep this one about "no friends imported". I'll file another one for the other string.
:delphine, Comparing those two strings doesn't make sense. One is when friends were imported, and the other is when no friends were imported. This is as short as it gets. Am I still missing something? :(
Flags: needinfo?(mv.nsaad)
:msaad: yes that's why I said this bug was messy (testers filed bug for 2 different strings) and that I'd file another one in comment 18 :) 
I've added you already to Bug 1158224 which covers the second issue
Msaad: this bug is about the string "no friends imported", and comment 8 shows that it is truncated on 2.2 in pt-BR (see right of screen): https://bug1157157.bugzilla.mozilla.org/attachment.cgi?id=8597098
Alyssa: could you please provide the correct screenshots for pt-BR, comparing the "no friends imported" screen on 2.1 and 2.2 (the one in comment 8 was of 2 different strings)? I'd like to see if there was any regression between both versions.
Flags: needinfo?(huayu.li)
It seems to me this string (and the case covered by bug 1158224) is likely to need 2 lines in lots of languages. Trying to squeeze the translation or let it truncate is doing to risk the message losing is meaning. We should just let it wrap. Alberto, can you see if that's feasible?
Flags: needinfo?(apastor)
According to the STR in comment0, when system language is in Portuguese Brazil, "No friends imported (out of **)" is truncated on both Flame 2.2 and 2.1, "One friends imported" is right on both Flame 2.2 and 2.1, please see new attactment about this.
Flags: needinfo?(huayu.li)
(Assignee)

Updated

4 years ago
Flags: needinfo?(apastor)
Attachment #8597891 - Flags: review?(sfoster)
(Assignee)

Comment 27

4 years ago
Comment on attachment 8597891 [details] [review]
[gaia] albertopq:1157157-ftu-button-truncated2 > mozilla-b2g:master

Asking Eric to confirm that's what we want from a UI perspective.
Attachment #8597891 - Flags: ui-review?(epang)
(Assignee)

Comment 28

4 years ago
Posted image fb-pt.png
This is how it looks with the patch (Note that I manually changed only that string, so the rest is in English)
(In reply to Alberto Pastor [:albertopq] from comment #28)
> Created attachment 8597895 [details]
> fb-pt.png
> 
> This is how it looks with the patch (Note that I manually changed only that
> string, so the rest is in English)

Hey Alberto, wrapping the text to a third line makes sense to me.  I'm having trouble testing the patch since I can't seem to get the 'no friends imported' string.  Can you attach another screen that is more scrolled up (I'll use the screen to review)?  Just want to check the alignment of the text/icon.  Mainly want to check that there is even spacing at the top and bottom of the section and that the icon is vertically centered.
Flags: needinfo?(apastor)
Target Milestone: --- → 2.2 S11 (1may)
(Assignee)

Comment 30

4 years ago
Posted image fb-scrolled.png
Flags: needinfo?(apastor) → needinfo?(epang)
Comment on attachment 8597891 [details] [review]
[gaia] albertopq:1157157-ftu-button-truncated2 > mozilla-b2g:master

Looks good, thanks! Lets get Eric's thumbs up before landing, but from what I can see, the icon does indeed look vertically centered and the text there looks correctly wrapped, padded etc.
Attachment #8597891 - Flags: review?(sfoster) → review+
(In reply to Alberto Pastor [:albertopq] from comment #30)
> Created attachment 8598099 [details]
> fb-scrolled.png

Hey Alberto, can you make one quick change?  Can you make the spacing at the bottom equal to the top (on top of facebook)?  Should be good after this change.  Thanks!
Flags: needinfo?(epang)
(Assignee)

Comment 33

4 years ago
Posted image fb-padding.png
Flags: needinfo?(epang)
Duplicate of this bug: 1158102
Duplicate of this bug: 1159145
Comment on attachment 8597891 [details] [review]
[gaia] albertopq:1157157-ftu-button-truncated2 > mozilla-b2g:master

thanks for updating the padding.  Looks good now :) R+
Flags: needinfo?(epang)
Attachment #8597891 - Flags: ui-review?(epang) → ui-review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
https://github.com/mozilla-b2g/gaia/pull/29738

Autolander could not land the pull request due to not having collaborator rights. This is possibly due to a tree closure. Please check the tree status and request checkin again once the tree is open.
(Assignee)

Comment 38

4 years ago
master: https://github.com/mozilla-b2g/gaia/commit/3711c76a2ced99d074b87a74f60a4fd064e24ba5
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Duplicate of this bug: 1158224
This issue has been successfully verified on flame3.0.
Reproduce rate:0/3
See attachment:
Verify1_pass_3.0user_No contact imported.png
Verify1_pass_3.0user_One contact imported.png

Device: Flame 3.0 user[Verified]
Build ID               20150504160201
Gaia Revision          70077825aab2c7a79611befb40a5fe7e610d5443
Gaia Date              2015-05-04 18:09:33
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/102d0e9aa9e1
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150504.191951
Firmware Date          Mon May  4 19:20:03 EDT 2015
Bootloader             L1TC000118D0
blocking-b2g: --- → 2.2?
blocking-b2g: 2.2? → 2.2+
Could you help uplift to 2.2 since it is a blocker?
Flags: needinfo?(apastor)
(Assignee)

Comment 43

4 years ago
Comment on attachment 8597891 [details] [review]
[gaia] albertopq:1157157-ftu-button-truncated2 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
[User impact] if declined: When importing contacts in the FTU, the confirmation message gets truncated
[Testing completed]: manual testing as is a css only change
[Risk to taking this patch] (and alternatives if risky): css only. low risk
[String changes made]: none
Flags: needinfo?(apastor)
Attachment #8597891 - Flags: approval-gaia-v2.2?

Updated

4 years ago
Attachment #8597891 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
Flags: needinfo?(hcheng)
This issue has been successfully verified on flame2.2.
Reproduce rate:0/3
See attachment:
Verify1_pass_2.2user_No contact imported.png
Verify1_pass_2.2user_One contact imported.png

Device: Flame 2.2 user build[Verified]
Build ID               20150519162501
Gaia Revision          63e9eeec3032318f8a240f80b6a184fa4b50b6e1
Gaia Date              2015-05-19 17:52:15
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/4e078e1364d3
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150519.200733
Firmware Date          Tue May 19 20:07:45 EDT 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
thanks!
Flags: needinfo?(hcheng)
QA Whiteboard: [MGSEI-l10n-1F]
Whiteboard: LocRun2.2, MGSEI-l10n-1F-Serbian Cyrillic [systemsfe], MGSEI-l10n-1F-Polish → LocRun2.2, [systemsfe]
According to the comment 4&6 in bug 1158102 and comment 4&6 in bug 1157153, this issue can be reproduced on latest Flame 2.1 and v2.1s build, so change the b2g-status to affected on v2.1 and v2.1S.
Hi Mike,
Could you help to request the patch to uplift to 2.1 and 2.1S?
Many thanks!
Hi Alberto, could you help uplift to v2.1 since this is a regression issue?
Flags: needinfo?(mlien) → needinfo?(apastor)
(Assignee)

Comment 51

4 years ago
Hi Mike,

Are we sure this is a regression? Can we find the regression window in 2.1?
Just making sure that this should be uplifted, even if the bug existed from the beginning in 2.1.

Thanks!
Flags: needinfo?(apastor) → needinfo?(mlien)
Oh, my fault, the regression mark is for original problem.

Hi Josh and Steven, please help to judge if this should be uplift to v2.1 and v2.1S
Flags: needinfo?(styang)
Flags: needinfo?(mlien)
Flags: needinfo?(jocheng)
I'm okay not to fix it on 2.1s.
Flags: needinfo?(styang)

Updated

4 years ago
Flags: needinfo?(jocheng)
You need to log in before you can comment on or make changes to this bug.